Niall Posts: 11,115
edited December 2021 in MyDrive Connect/MyDrive Web

This applies to the following devices
TomTom GO 2535 TM WTE TomTom GO LIVE 2535 M TomTom GO 2535
TomTom GO 2505 TomTom GO 2435 TomTom GO 2405 TomTom GO LIVE 1535
TomTom VIA 1605 / Camper TomTom VIA 1400 / 1405 TomTom VIA 1410 / 1415 (M / TM / M SE)
TomTom VIA 1430 / 1435 (TM) TomTom VIA 1500 / 1505 (M) TomTom VIA 1510 / 1515 (M / TM / M SE)
TomTom VIA 1530 / 1535 TomTom VIA 1605 / VIA 1605 M RV
In Europe
TomTom GO 1005 / GO 2050 TomTom GO LIVE 1000 TomTom GO LIVE 1005
TomTom GO 1000 TomTom GO LIVE 820 TomTom GO LIVE 825
TomTom Start 60 / Via 620 (2012) TomTom Start 25 TomTom Start 20
TomTom Via 130 / 135 TomTom Via LIVE 125 TomTom Via 125
TomTom Via LIVE 120 TomTom Via 120 TomTom Via 110
TomTom GO LIVE 1005 / Camper & Caravan
In Australasia
TomTom GO LIVE 2050 World TomTom GO 1050 World TomTom GO 1050
TomTom GO LIVE 1050 / GO LIVE 2050 TomTom GO LIVE 1000 TomTom GO 1000
TomTom GO LIVE 820 TomTom GO LIVE 825 TomTom Via 620
TomTom Via 260 / 280 TomTom Via 225 / All Blacks Edition TomTom Via 220
TomTom Via LIVE 180 TomTom Via 180 TomTom Via LIVE 160
TomTom Via 160 TomTom GO LIVE 1005 / Camper & Caravan

[h3]"Official" TT tips[/h3]

If these didn't help, then try some of these:

*Always make sure that you are logged in with the correct account. One device, one account*

[h3]*** for Windows 10 users ***[/h3]

If you have just updated recently, you might run into trouble with TT (and other devices too). Disconnect the device, uninstall the MyDrive Connect support app with Revo Uninstaller, restart the PC, download the latest MyDrive Connect installer from and install it again. Also in Windows 10, click on the "Start" menu (Windows icon in lower left corner), click on Settings and then Updates. Look for further updates, download and install those. Restart the PC, wait a minute or two, until everything starts up. Connect the device. If it is not recognised yet, keep it connected and then press and hold the ON button, until you hear the drum roll. Then wait another minute. If you have no luck yet, visit the web site of the manufacturer of the PC and look for newer (Windows 10 compatible) USB or chipset drivers for your computer and install it.

*** TT CS official reply that worked for many with W10 issue ***

Close MyDrive Connect completely:
If your navigation device is connected to the computer, disconnect it.
Click the MyDrive Connect icon ( or ) in the Windows notification area or Apple menu bar and then select > Quit
Uninstall MyDrive:
Click on the Start button and go to All Programs › TomTom › Uninstall TomTom MyDrive
Alternatively you can use Add or Remove Programs in the Contol Panel to remove TomTom MyDrive Connect.
Remove the application file:
Press the Windows logo key +R to open the Windows Run dialog
Type %localappdata%. Click OK.
You will see list of folder. Find and open TomTom folder
Delete HOME 3 folder.
Delete the MyDrive Connect folder from: C:\Program Files (x86) (if still present)
Delete the TomTom folder from: C:\Users\[username]\AppData\Local\ (USERNAME - It is the user name which you use to login to Windows )
Delete the TomTom folder from: C:\Users\[username]\AppData\Roaming\
Delete every file and folder from: C:\Windows\Temp\ (in case some files can't be removed, reboot the PC and retry)
Restart your computer.

Re download a new installer from (I recommend you to use the Google Chrome while downloading the installer)

Now install MyDrive Connect with the newly downloaded installer.

After the installation process of the new MyDrive application completes successfully, please restart your computer. Now, check if the application is able to connect to your device properly or not.

*** For further troubleshooting tips, please see below ***


- It is very unlikely that one would have to do these all, it is usually one of the below mentioned possibilities

- As in IT Crowd: Have you tried to turn the computer off and on again?

- Try to add MyDrive Connect to the exclusion list of your antivirus and firewall (or disable those temporarily)
- Make sure that your computer is not going into stand-by or similar (this shouldn't happen with the latest MyDrive Connect)
- Clear the cache before each update attempt. Also could do a soft reset before and after the update
- Make sure you have all the latest updates and hotfixes/patches to your OS (not only the mandatory ones, but the optionals too)
- In case the device looks like hung during the update or the counter stopped (or not visible at all), just leave it.
Most probably it will be fine in a few minutes (or within a couple of hours, in case of installing large maps)
- Check your network connections, make sure that the TT's network adapter is enabled
- Try to uninstall and re-install the MyDrive Connect application (best to use Revo Uninstaller to remove)
- Try to use a USB port on the mainboard, rather than a USB hub (desktop PC)
- Try to change the port to 5000 (or 5001) in MyDrive Connect's settings
- Try to run the MyDrive Connect app as administrator
- Sometimes disabling caching large files helps too
- It is worth checking the USB power saver settings

- Any further issue: Try it on another PC, try it with different USB lead...the shorter the better (below steps are Windows specific)
- Whilst the device connected, remove the drivers from the Device Manager (Windows/Control Panel), DELETE the drivers
- Remove the MyDrive Connect application and run CCLEANER (will remove your history, cookies, etc by default)

- At the moment certain USB3 port looks like incompatible with the TT devices (those are usually coloured blue on the PC).
Could try BIOS update on the PC or enable "Legacy mode" for the USB ports in the BIOS (for further instructions, look for the user manual of your PC/mainboard)
- Don't use the magnetic mount whilst updating, connect the micro USB directly into the device
- Disable any network monitoring software
- Update one item at a time, don't select all.
Best order: NavCore/software - Map - QuickGPSfix - Speed Cams - Map Share Corrections (this is the smallest but longest in some cases)

Certain Mac versions (10.10.2, 10.10.3 10.10.4 and 10.10.5) have USB issues, but there is an official fix available, provided by Apple.
The latest version of MyDrive connect is not compatible with Windows XP SP2 and below, make sure that you update to SP3 and install ALL the other updates.



  • MikkoK
    MikkoK Retired TomTom Employee Posts: 23,905 Retired Community Managers and Staff
    Hi Niall,

    Perhaps Zsolt would like to post this himself? ;) But as long as you guys are fine with I'm fine with it :D

    Cheers, Mikko
  • MikkoK
    MikkoK Retired TomTom Employee Posts: 23,905 Retired Community Managers and Staff
    Hi Niall,

    You might reconsider the title. I doubt many customers will no what Nav3, Nav 4, etc stand for. They're also not likely to find this topic with their google searches. This is about MyDrive Connect, really, isn't it?

    It might also be good to describe the scenario(s) for which this applies.

    Cheers, Mikko
  • Niall
    Niall Posts: 11,115

    I have tweaked this a bit, can you change the title of the thread to the heading please
  • VikramK
    VikramK Administrators Posts: 13,781
    Hi Niall

    Title changed..