Map doesn't show - only blue/grey square — TomTom Community

Map doesn't show - only blue/grey square

JurriaanJurriaan Posts: 9 [Legendary Explorer]
My Go app which had worked just fine on this phone is now unusable.

When I start the app, I get a blue/grey background instead of a map.
Routes seem to compute normally, I see a distance to home that is correct, and other routes give a message that the route is being computed - all the while showing no map, just a blue/grey background.

I've tried downloading other maps, but Benelux, Western Europe and Europe all show the same blue/gray screen.

Re-installing the app (and losing all my destinations) didn't help either.
I'm not too sure on what happened before I got this - the phone is constantly updating apps of course, and I don't navigate daily - might not even be weekly.
It's an Samsung Note 4, running Android 7.1.2, no other issues that I know of, and as I write, it used to run just fine.

What now? Is there a logfile somewhere that I can post here?

Comments

  • ZsoltZsolt Posts: 36,011
    Superusers
    Was there any ROM update recently? Also have you tried to restart the phone?
  • JurriaanJurriaan Posts: 9 [Legendary Explorer]
    No, the rom has not changed since the app working correctly. Restarting the phone didn't help. There's nothing wrong with the GPS, by the way, google maps works fine, for example.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Jurriaan,

    Welcome to the Community!

    Did you perhaps recently update the Android on your phone? I'd recommend you to clear the app data in Application management and re-install the app once more. Please note, that this will delete your personal information, e.g. My Places, My Routes and destination prediction data. You can save and restore My Places with MyDrive.

    Should that not help you sort this out, please report to Customer Service. They'll be able to get to the bottom of this and assist you accordingly.

    Cheers, Mikko
  • JurriaanJurriaan Posts: 9 [Legendary Explorer]
    No, I did not recently update Android. I removed the app and all folders with tomtom in the name before re-installing. No luck,

    We'll see what Customer Service has to say - I'll post here if and when it's resolved.
  • JurriaanJurriaan Posts: 9 [Legendary Explorer]
    So far, every different person of Customer Service insists on clearing caches, removing the SD-card and frequent re-installs. This seems, after the third iteration, based more on 'hope that it works' than 'know what's going on'. One person mailed a diagnosis: 'Go can't read the map'. After I pointed out that removing the SD-card and reinstalling for the third time wasn't going to solve this problem, it's been silent for a while. I feel like a cherished paying customer.
  • VikramKVikramK Posts: 12,167 Moderator
    Hi Jurriaan

    Sorry to hear about the ongoing problems with the app. I have sent a heads up to the customer service and they will get back to you.

    Regards
    Vikram
  • Jay101Jay101 Posts: 1 [Apprentice Traveler]
    Hi. Did you get a response to this? I have the exact problem you describe - grey screen and no maps? Please share if you got the issue resolved. Thank you.
  • JurriaanJurriaan Posts: 9 [Legendary Explorer]
    Oh yes, I got a response. Translated from Dutch to English it reads like this:

    I just got a response from our technical department. They haven't seen this problem with any other customers.
    At the moment, we don't have a solution. Our apologies!

    We will add another three months to your license, to recompense you for this problem. At the end of that period, the problem should have been solved.

    If you still have questions, feel free to email me.



    Feel free to write your experiences here.
  • AndyennAndyenn Posts: 1 [Apprentice Traveler]
    I have the same problem. I too have reinstalled acouple of times, but that doesn't seem to help.

    I have tried installing it on 2 android phones. Both Motorola. 1 works fine, but the other gets the grey map problem (but worked fine a few days ago). Are there any more ideas on this? I got a 3 year licence a few months ago and it is starting to seem like a bad decision.
  • JurriaanJurriaan Posts: 9 [Legendary Explorer]
    I solved it by flashing a completely new rom on my Note 4 (910F) with the sd-card removed, then installing TomTom Go, then adding the SD-card as removable storage.

    TomTom never bothered to reply to my question what if anything had happened after the three month period I mentioned above. Very nice, I feel a valued customer.
  • AsprinAsprin Posts: 271 [Supreme Pioneer]
    Jurriaan,

    How is TomTom to know that you had a problem with your Note 4 and that effected the app or apps on your phone?

    It wasn't till you redid your phone that the problem went away.

    We can not always say it is TomTom's fault for a problem that was clearly the phones fault.

    So many user's do lots of things to their phones or tablets and put the blame on the app that is not working.

    Not saying you did something to your phone, but it was clear something was wrong with your phone that you had to re-flash the ROM and start over again.


    I am not saying that TomTom Go is a perfect app, it has it's problems with some phones and tablets and the versions of Android that are being used.

    Going to the forum first and posting the problem rather then going to the support line is not always the best way to get problems fixed.
  • JurriaanJurriaan Posts: 9 [Legendary Explorer]
    The problem is not so much there was a problem. The problem appeared 'suddenly' - that is, the rom version didn't change, but individual apps including TomTom did receive automatic updates, of course, a good diagnosis wasn't carried out (I was never asked for logfiles or tests, just the standard ways of re-installing, removing sd-card etc.), the problem was classified as 'one of a kind, we'll revisit this in three months' and then, no answer at all anymore after those three months.

    I have no idea if you're correct there was a problem with the phone. I never noticed any other problem with any other app, including google maps and Sygic. I re-flashed it for different reasons, not to try to solve this problem. Nor did I _have_ to reflash it, by the way.

    Finally, I created incident 170805-000875 with TomTom on the 4th of August 2017, which I think clearly predates my first forum post of '5 months ago', so I disagree I went to the forum first, and I sincerely think TomTom could have known I had a problem - there was an incident, after all.

    A non-working app can't be prevented, I can accept that. But the handling of the problem is not what I expected. I still think an update of TomTom broke something - it worked, and then it didn't. Without a correct diagnosis, how would anybody know?
  • AsprinAsprin Posts: 271 [Supreme Pioneer]
    What I have found when it comes to problems with smartphone and Tablets is:

    The SD card was not of the best quality.
    The SD card not fully in the slot. (reasons phone was dropped)
    Trying to update over data connection (not good to do)
    Nor download newer maps over a data connection.
    Problems with not disconnecting from the PC correctly

    The same goes for Free hotspots not the best way to do any updates.

    Then there are the problems with how wifi connections.
    The smartphone or tablet disconnects from your router.
    That will cause all types of problems when updating anything on your phone or tablet.
    And you might not of seen it disconnect and reconnect again.

    Then there is the clearing of cache.
    I always clear all running programs from the cache before updating anything.
    Making sure that the phone is fully charged?
    And turning it off from time to time. (not restarting fully off)

    I have tested TomTomGO and many other apps on many versions of Android and makers of phones and tablets.

    I have yet to run into any problems with TomTom GO but have run into problems with other GPS apps along with other types of apps.

    There is not clear reason why some apps work great on one phone and not the other.

    Now clearly you had some type of problems that you had to re-flash your phone.
    Which did clear up problems you had along with getting TomTomGo to work again.

    Samsung and HTC seem to have the most problems with 3rd party apps for one reason or another.

    And Android version 8 seems to give a lot of headaches to some users.
  • JurriaanJurriaan Posts: 9 [Legendary Explorer]
    Asprin624 wrote:
    Now clearly you had some type of problems that you had to re-flash your phone.

    It's sure hard to comprehend how you can state this, knowing I wrote 'I re-flashed it for different reasons, not to try to solve this problem. Nor did I _have_ to reflash it, by the way.'.

    I wanted (wished? longed for? dreamed of?) an up-to-date Android version. I didn't have any problem except TomTom Go that made it necessary to do that. I can't write it any clearer.
  • AsprinAsprin Posts: 271 [Supreme Pioneer]
    This info was for all the users that have or could have problems with any type of app including GPS apps.

    Like I pointed out have had problems with other GPS apps that friend of mine showed me and we fixed the problems by doing the things I listed above.

    As for TomTomGo I have not run into any problems nor have any of the people I know.

    The fact that all is working with TomTomGo for you was just an extra.

    As it being related to the re-flashing no one will know if that was the cause.
  • BernardohollandBernardoholland Posts: 2 [Apprentice Traveler]
    I have the same problem as Jurriaan. I can only see the contact layer in the surrounding neighbourhood, but no maps, no roads. Just the night view or day view colour.
    It was a first time install. It ran smoothly with Benelux downloaded and installed. But after adding France the problem started.
    It occurred twice. I have just today installed big android and Samsung update on my Samsung S8.
    The smartphone hasn't had any issues before and has not been tampered with.

    Any suggestions?
  • BernardohollandBernardoholland Posts: 2 [Apprentice Traveler]
    My problem is solved. After some exploring I found out that in settings-maps, France had been selected after downloading the map of France. And as I am located in the Netherlands, my map didn't show in the opening interface of the app. After selecting Benelux in maps I had full view of my map, surrounding streets etcetera. Simple! Jurriaan , does this offer suggestions for your problems?
  • JurriaanJurriaan Posts: 9 [Legendary Explorer]
    It might have, but I have since solved the problem by reflashing the phone, as I wrote above.
  • Ro_DRo_D Posts: 1 [Apprentice Traveler]
    I had the same problem.
    My phone died so I revived an old phone (Samsung S5 mini) with an 64gb SD card and installed the Go app on it and also got a blue/grey map. Tried reinstalling the app and downloading different maps (and made sure I had the right map selected) but eventually fixed it by:
    • clearing the cache
    • removing local data
    • uninstalling the app
    • removing the SD card
    • reinstall the app on the internal memory of the phone
    Not sure what caused it, the SD card works fine and the phone doesn't have any other issues either, so draw your own conclusions :)
  • DougBrooksDougBrooks Posts: 22 [Master Explorer]
    I have the same problem with the western europe map (5.8 gig) it was working fine after downloading it and using it a couple of times as and when needed. i fire it up on friday and it has gone (or rather the map is there but just a grey box) . No updates done or needed during this time. i turned the car off (android 6 head unit) to fill up, come out and its gone. WTF , i am in the UK the map pack has the UK included within it so what gives.
    There has to be a fix for this, surely a force recheck of the map pack needs to be introduced so it can fix itself . , to have to remove the app to redownload it all again is just plain not good enough!

    I have it installed to the internal memory of the head unit, not to a card.
  • AsprinAsprin Posts: 271 [Supreme Pioneer]
    DougBrooks,

    I have read all your posts and you have been told by others that it is not supported.

    But you keep going on and on about your Android Head Unit.

    TomTomGO is a Smartphone and Tablet app, that is all?

    Many user's here have tried to install TomTomGO on Head Units.

    Some work OK to a degree others only have problems.

    It is not supported.

    Time to move on mate........
  • HcadenasHcadenas Posts: 1 [Apprentice Traveler]
    I see many complaints about the app from CELLPHONE users, so the problem isn’t only HU. I have the same problem and service customer have no idea what’s going on. I made a big mistake purchasing a full year subscription to such useless app. Shame on you TomTom. Shame on you.
  • MrRob_inMrRob_in Posts: 3 [Neophyte Traveler]
    Same problem for me on new Android 8.0 Xtrons unit.
    Map details show in 2d map screens and Turning off 3d view allows me to see map details in nav mode.
  • AsprinAsprin Posts: 271 [Supreme Pioneer]
    @Hcadenas,

    This is the forum for smartphones.

    It it not??????

    So user's will post here if they have a problem with their smartphone correct ?????

    Better to contact support if you really have a problem with the TomTomGO app.

    There are many reasons why user's have problems a lot has to do with the SD quality for one.

    That being the most important issue.

    Then there is what other apps user's are trying to run at the same time with the GO app that might be causing a problem.

    It is what is know as compatible problems.

    Then there are the smartphones that just give problems.
Sign In or Register to comment.

Who's Online in this Category0