No heart rate since update

kphill
kphill Registered Users Posts: 4
Apprentice Traveler
edited January 24 in TomTom Sports
Since the update a few days ago I have completed 2 x 5k runs and neither have displayed heart rate. When I completed both runs and paused for recovery It was unable to give me a score. What's worse is that it has not recorded my last run at all! I can see it in my daily activity record but it is not displayed in my list of runs.

It worked perfectly prior to the update. I'm pleased tom tom are making progress and updating things but you have now rendered the device unusable.

Comments

  • tfarabaugh
    tfarabaugh Posts: 16,938
    Superuser
    You probably want to call Customer Support to ask them about it, but I would try a factory reset first in case it is just an issue in your firmware install. To do a factory reset, make sure the Connect software is running and dock the device to your computer. The Connect window will open; press the gear at the top right and select factory reset from the next screen. Follow the steps provided and when prompted to register or sign in to MySports, select sign in and use your existing account credentials. It is fairly straightforward and should take less than 5 minutes.

    To get the number for Customer Support, go to tomtom.com/support, choose Contact at the bottom, select the service required and the product name and click Contact Customer Care and then Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • kphill
    kphill Registered Users Posts: 4
    Apprentice Traveler
    Performed factory reset but issue not resolved and now completely unable to connect via Bluetooth.

    Infuriating!
  • tfarabaugh
    tfarabaugh Posts: 16,938
    Superuser
    If you are trying to connect to BT to your phone, you need ot take specific steps after factory resetting the watch. You first need to remove the watch from the phone's BT menu (in iOS you have it forget the device) after you reset or try pairing again. The steps are: factory reset the watch (which you did), uninstall the app (you can probably skip this), remove or forget the watch from the phone's BT menu, reinstall the app (only if you uninstalled the app), select Pair New on the app, select Pair New on watch (press down from the clock and select Phone>Pair New, not Sync) and follow the prompts on the phone. You should not be pairing the watch first through the phone's BT menu; it is all done through the app and you must have the phone forget the watch in the BT menu before re-pairing.

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • kphill
    kphill Registered Users Posts: 4
    Apprentice Traveler
    Followed these exact steps but fails to pair new. Just gets stuck on connecting page.