Watch stuck on clock screen and not connecting to pc — TomTom Community

Watch stuck on clock screen and not connecting to pc

asderasder Posts: 3 [Apprentice Traveler]
edited January 30 in Runner & Multi-Sport
Hello my watch has stuck on clock screen neither the button works and when i plug it to pc nothing happens ,but the time counts fine. Before that the button was like pressing continiously right,until battery when off. I tried reset but it didnt worked i know i am out of warranty.Is there a fix .

in the forums i read that you might give me a discount on a new watch i live in Greece so it would be very thankful of yours. I am a pro athlete and i need a watch immediatly.

Thank you,
Stavros Avramidis

Comments

  • tfarabaughtfarabaugh Posts: 15,819 Superusers
    I would try to perform a reset on your watch using the recovery mode, follow these steps:

    1. Place your watch in the dock before you connect the dock to the computer.
    2. On your watch, move DOWN but keep the button pressed.*
    3. Connect the dock to the computer. Keep pressing the button until your watch shows tomtom.com/reset.
    4. Release the button and wait for MySports Connect to show Update.
    5. Click Update in MySports Connect.
    * If the USB port on your computer is not easily accessible, connect the dock to the computer without the watch. Then move down from the clock screen while you slide the watch into the dock.

    If that does not work you should call Customer Support. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, go to tomtom.com/support, choose Contact, enter the product name and click Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • hattmartinhattmartin Posts: 1 [Apprentice Traveler]
    I'm having the same problem, watch got stuck on clock mode this morning and the suggested method of resetting doesn't work. Is there anything else to try or do I need to get a new device?
  • Jim07Jim07 Posts: 3,337 TomTom Moderator
    Hi,

    @pmerson Could you check is the 4 pins of the cable are at the same level?

    Regards,

    Jim
Sign In or Register to comment.

Who's Online2

2 Guests