GO 510 Continual updating device — TomTom Community

GO 510 Continual updating device

acawleyacawley Posts: 5 [Master Traveler]
edited January 30 in MyDrive Connect
Had real issues with my GO510. Not used the device for a few months when everything previously worked fine including installing USA maps on a SD memory card.
Switched back on last night to check for updates to maps and experienced two main issues:
1. Connected my device to MyDrive Connect to find my SD memory card was being recognised by the device but not by MyDrive Connect. Reformatted the card to FAT32 on my PC and inserted back in the device. Reconnected to MyDrive Connect but no joy.
2. Updated one of the 5 recommended updates to what I thought would be the device - seemed to work OK but I kept on getting the message 'Waiting for Device' on the PC and 'Updating - please do not disconnect your device' on my actual device. It would occasional restart but would then go through the loop again - I left the device running overnight for 7hours but was still in that loop when I checked in the morning.

Can anyone help please - I need the device for an upcoming family holiday...

Comments

  • ZsoltZsolt Posts: 36,020 Superusers
    Have you updated the MyDrive Connect to the latest version? There was an update just "now".
  • acawleyacawley Posts: 5 [Master Traveler]
    Updated the software OK.
    When the device was connected it seemed to download items to the PC and now in the "Updating - do not disconnect your device" on my device and "Updating device - waiting for your device" on my PC. My device has restated a few times.
    Not sure if this is the process of updating taking its course or I have entered the loop again..?
  • ZsoltZsolt Posts: 36,020 Superusers
    Depending on what items were updating, it is normal to restart sometimes.
  • acawleyacawley Posts: 5 [Master Traveler]
    I have left the device connected overnight.

    I returned to it with the device showing it is connected to MyDrive but my PC showing the device was restarting. After waiting a while the device clearing wasn't restarting so I disconnected and reconnected the device - it has now gone back into the loop previously indicated...
  • dhndhn Posts: 33,206 Superusers
    Try the Recovery Process. See here:
    [video]

    If that doesn't help, then support:

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • acawleyacawley Posts: 5 [Master Traveler]
    Thanks for the advice. Tried this - recovery seemed to work but I have now got back into the loop again.

    Any thoughts?

    I have raised a call with TT Support which essentially has reiterated what we have already tried.

    Is this a faulty device? Now really concerned as this was purchased several months ago ready for a US trip coming up in the next few weeks...
  • ZsoltZsolt Posts: 36,020 Superusers
    Can you try it without the memory card?
  • acawleyacawley Posts: 5 [Master Traveler]
    Recent instance was without the memory card.
  • bobuk48bobuk48 Posts: 2 [Apprentice Traveler]
    I Know it doesnt reaally help but I have exactly the same problem with my GO500. I updated the device a few days ago but this issue started today for no apparent reason. Just keeps on looping through the restore procedure. I am raising a call with TomTom but your comments dont give me much hope. Can't help thinking this is down to the last update.
  • ZsoltZsolt Posts: 36,020 Superusers
    Best for both then to get in touch with TT CS and they can check their end. Maybe a server error.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi bobuk48,

    Welcome to the Community!

    According to our logs your device is up to date now. Is it working fine now?

    Your device seems to be low in memory so I'd recommend you to remove some voices you don't use and/or to factory reset your device by choosing Settings (cog wheel) - System - Reset - Reset. Please note, that this will delete your personal information, e.g. My Places, My Routes and destination prediction data. You can save and restore My Places with MyDrive. This removes the MapShare Correction patches from your device which frees up some space.

    Cheers, Mikko
  • bobuk48bobuk48 Posts: 2 [Apprentice Traveler]
    My device is not fine. Still cycling through the startup sequence but never getting there. Have followed the reset procedure and the restore procedure but both only get as far as the "do not disconnect" screen. It never gets to any menus so I have no idea what to try now.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    HI Bob,

    I'm sorry to hear the issue persists!

    Last connection to our server from your device indeed seems to be from a couple of weeks ago. I’d recommend you to set your device to recovery mode [support FAQ - Red X]. Please note, that this will delete your personal information, e.g. My Places and destination prediction data. You can save and restore My Places with MyDrive. The following video walks you through the recovery mode process:
    [video]

    Also check the Connection to computer and Internet connection sections in this FAQ.

    Cheers, Mikko
  • cjoenow12cjoenow12 Posts: 1 [New Seeker]
    AC I think you have TomTom support confused with someone that cares? Good Luck!
Sign In or Register to comment.

Who's Online16

16 Guests