Computer will not install my Via 52 — TomTom Community

Computer will not install my Via 52

Albert RossAlbert Ross Posts: 17 [Apprentice Seeker]
edited January 28 in MyDrive Connect
Trying to get my TomTom to install is proving a nightmare.

I connected the TomTom to the computer via the USB and all seemed fine, it appeared to install correctly, but MyDrive software was not to be found on my hard drive. I then realized that I needed to download it from the net, which I did. On running the program with the TOMTOM still connected, the program started to download updates automatically to the computer. It then started to download these updates to the TomTom. With around 3 minutes left, the device turned itself off the program did warn me that this would happen so I was not too concerned. When it turned back on again the device said to connect to MyDrive., despite the fact that it was already connected to the program.

I decided to uninstall the TomTom installation, NOT the MyDrive program and try again. This time half way through the install process, the installation stopped and I was asked to insert the installation disk. The TomTom did not come supplied with a disk!! What to do now. Any ideas? The whole process seems very unstable.

Comments

  • ZsoltZsolt Posts: 36,020 Superusers
    What sort of PC do you use?
  • Albert RossAlbert Ross Posts: 17 [Apprentice Seeker]
    It's a desktop PC running on Vista O/S
  • ZsoltZsolt Posts: 36,020 Superusers
    Vista is supported yet, so shouldn't be an issue. First of all I would check the USB power settings and disable any power saving feature. Otherwise here is a list to go through :) There is a specific Vista tip on the bottom, but from your description, seems like this is not the issue.

    "Official" TT tips:

    https://en.discussions.tomtom.com/go-800-1000-2000-series-via-series-start-20-and-60-series-mydrive-19/faq-mydrive-connect-troubleshooting-tips-990570

    If these didn't help, then try some of these:

    *Always make sure that you are logged in with the correct account. One device, one account*

    *** for Windows 10 users ***

    If you have just updated recently, you might run into trouble with TT (and other devices too). Disconnect the device, uninstall the MyDrive Connect support app with Revo Uninstaller, restart the PC, download the latest MyDrive Connect installer from http://www.tomtom.com/getstarted and install it again. Also in Windows 10, click on the "Start" menu (Windows icon in lower left corner), click on Settings and then Updates. Look for further updates, download and install those. Restart the PC, wait a minute or two, until everything starts up. Connect the device. If it is not recognised yet, keep it connected and then press and hold the ON button, until you hear the drum roll. Then wait another minute. If you have no luck yet, visit the web site of the manufacturer of the PC and look for newer (Windows 10 compatible) USB or chipset drivers for your computer and install it.

    *** TT CS official reply that worked for many with W10 issue ***

    Close MyDrive Connect completely:
    If your navigation device is connected to the computer, disconnect it.
    Click the MyDrive Connect icon ( or ) in the Windows notification area or Apple menu bar and then select > Quit
    Uninstall MyDrive:
    Click on the Start button and go to All Programs › TomTom › Uninstall TomTom MyDrive
    Alternatively you can use Add or Remove Programs in the Contol Panel to remove TomTom MyDrive Connect.
    Remove the application file:
    Press the Windows logo key +R to open the Windows Run dialog
    Type %localappdata%. Click OK.
    You will see list of folder. Find and open TomTom folder
    Delete HOME 3 folder.
    Delete the MyDrive Connect folder from: C:\Program Files (x86) (if still present)
    Delete the TomTom folder from: C:\Users\[username]\AppData\Local\ (USERNAME - It is the user name which you use to login to Windows )
    Delete the TomTom folder from: C:\Users\[username]\AppData\Roaming\
    Delete every file and folder from: C:\Windows\Temp\ (in case some files can't be removed, reboot the PC and retry)
    Restart your computer.

    Re download a new installer from http://www.tomtom.com/mydrive (I recommend you to use the Google Chrome while downloading the installer)

    Now install MyDrive Connect with the newly downloaded installer.

    After the installation process of the new MyDrive application completes successfully, please restart your computer. Now, check if the application is able to connect to your device properly or not.

    *** For further troubleshooting tips, please see below ***

    PLEASE NOTE:

    - It is very unlikely that one would have to do these all, it is usually one of the below mentioned possibilities

    - As in IT Crowd: Have you tried to turn the computer off and on again? :)

    - Try to add MyDrive Connect to the exclusion list of your antivirus and firewall (or disable those temporarily)
    - Make sure that your computer is not going into stand-by or similar (this shouldn't happen with the latest MyDrive Connect)
    - Clear the cache before each update attempt. Also could do a soft reset before and after the update
    (http://uk.support.tomtom.com/app/answers/detail/a_id/6965/)
    - Make sure you have all the latest updates and hotfixes/patches to your OS (not only the mandatory ones, but the optionals too)
    - In case the device looks like hung during the update or the counter stopped (or not visible at all), just leave it.
    Most probably it will be fine in a few minutes (or within a couple of hours, in case of installing large maps)
    - Check your network connections, make sure that the TT's network adapter is enabled
    - Try to uninstall and re-install the MyDrive Connect application (best to use Revo Uninstaller to remove)
    - Try to use a USB port on the mainboard, rather than a USB hub (desktop PC)
    - Try to change the port to 5000 (or 5001) in MyDrive Connect's settings
    - Try to run the MyDrive Connect app as administrator
    - Sometimes disabling caching large files helps too
    - It is worth checking the USB power saver settings

    - Any further issue: Try it on another PC, try it with different USB lead...the shorter the better (below steps are Windows specific)
    - Whilst the device connected, remove the drivers from the Device Manager (Windows/Control Panel), DELETE the drivers
    - Remove the MyDrive Connect application and run CCLEANER (will remove your history, cookies, etc by default)

    - At the moment certain USB3 port looks like incompatible with the TT devices (those are usually coloured blue on the PC).
    Could try BIOS update on the PC or enable "Legacy mode" for the USB ports in the BIOS (for further instructions, look for the user manual of your PC/mainboard)
    - Don't use the magnetic mount whilst updating, connect the micro USB directly into the device
    - Disable any network monitoring software
    - Update one item at a time, don't select all.
    Best order: NavCore/software - Map - QuickGPSfix - Speed Cams - Map Share Corrections (this is the smallest but longest in some cases)

    Certain Mac versions (10.10.2, 10.10.3 10.10.4 and 10.10.5) have USB issues, but there is an official fix available, provided by Apple.
    The latest version of MyDrive connect is not compatible with Windows XP SP2 and below, make sure that you update to SP3 and install ALL the other updates.

    IMPORTANT CHANGE FOR XP AND VISTA: https://uk.support.tomtom.com/app/answers/detail/a_id/20314
  • Albert RossAlbert Ross Posts: 17 [Apprentice Seeker]
    Thanks for your speedy reply Zsolt. I checked the USB connection and all seemed OK. Then I went on power saving options and altered that to maximum power and then tried again. Same result. What I did notice is that the connection appeared to be loose, if I picked up the device to preposition it, the device said that it had been disconnected from the computer and gave me the countdown to turning off. Giving the lead a little jiggle then reconnected to the computer.

    Is there a way of being able to download a driver direct from this site, rather than having to mess about like this?
  • ZsoltZsolt Posts: 36,020 Superusers
    Try maybe with another micro USB cable. Anything you need to download goes through MyDrive Connect only.
  • Albert RossAlbert Ross Posts: 17 [Apprentice Seeker]
    It does seem that either the cable or the jack that it plugs into is at fault. Bearing in mind that I have only had it for just over a month, it looks like I will have to send it back under the guarantee which is a bit of a nuisance. Just checked and we can send the item back to QVC for a replacement. Thanks for your help Zsolt.
  • NiallNiall Posts: 10,564 Superuser
    @Albert Ross

    Contact Customer Services to get a returns reference, there will be much less hassle when you get to the shop where you bought the device. If necessary, point the CS rep to this forum thread ;)

    CS United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
    Help others identify useful content :-
    If someone posted something that was helpful? Click the Like button 👍
    If someone answered the question you asked? Answer Yes to "Did this answer the question? Yes · No"
  • Albert RossAlbert Ross Posts: 17 [Apprentice Seeker]
    Thanks Niall for your advice. I bought the device from a shopping channel called QVC and I phoned their customer services to explain the problem.

    All the items that QVC sell have a no quibble 30 day money back guarantee. Luckily for me this would have come to an end on the 2nd of August.- phew!! Over the next day or two a courier will pick the TomTom up and deliver it back to QVC and it will be replaced with a new one, and hopefully one that will work as it should. Thanks again, Steve.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Albert,

    Welcome to the Community!

    I'm glad the see you're getting this sorted with the help here :D I'd still commend you to try another USB cable as it might save you the hassle of returning your device. In case of a faulty cable our Customer Service can send you a new one. But in case of a faulty connector in the device replacing it is of course the quickest way to get it sorted.

    When you're satisfied that your question is answered, please mark your topic as solved so that others with a similar question may find the answer easier.

    Cheers, Mikko
  • Albert RossAlbert Ross Posts: 17 [Apprentice Seeker]
    Thanks MikkoK,

    The reason I decided to go down the route of returning the device to where I bought it, was simply because there was no way of finding out whether it was the cable itself or the connector that was faulty. Had I been convinced that it was the cable that was the culprit, I would have asked TomTom for a replacement cable. With time being a little tight and not knowing how long the replacement cable would take to arrive, I thought it would be better to contact the vendor and get a complete replacement. All packed up now and waiting for Hermes to collect. All the best, Steve
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Steve,

    Fair enough :D

    Please, post back here if you have any further questions.

    Cheers, Mikko
  • Albert RossAlbert Ross Posts: 17 [Apprentice Seeker]
    I have my replacement TomTom and it installed in a blink of an eye. Went to download some updates and all went well until the computer decided that the device was no longer connected to the internet. On my computer screen it said to connect your device, but on my device it said 'connected to your computer' This time though my USB connection appears to be sound, no amount of jiggling will disconnect the power to the device. In device manager it says that I have the TomTom installed, but each time I plug in the device the computer is saying 'installing driver software' as though it wasn't installed, and again I am getting the request to input a disc. On further inspection, when I look at the properties of the installation I am getting this. Any help appreciated.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Steve,

    I'm sorry to hear your troubles continue with the replacement device!

    Your computer doesn't seem to recognise the device correctly and installs a wrong driver. Please, see the Driver issues section in this FAQ for troubleshooting tips.

    As the device initially connected correctly, it could also be an internet security software causing this. Some such software are rather aggressive about connecting network devices. The Connection to computer section of the above FAQ has more troubleshooting steps for this scenario.

    Cheers, Mikko
  • ZsoltZsolt Posts: 36,020 Superusers
    Sometimes malwares might block the connection to a TT device (or any other network device). It is highly advised to run a few of these checks sometimes. In case of a large storage and many files (and huge amount of data) and on a non-SSD system, it might take a few hours easily.

    Download:
    - rkill.com (bleepingcomputer)
    - tdsskiller (by Kaspersky)
    - ESET online scanner (by ESET)
    - Malwarebytes Antimalware (by Malwarebytes, the FREE version is enough, PRO not required)
    - Super Antispyware (the FREE EDITION is enough)
    - CCLEANER (the FREE version is OK, disable monitoring within if don't want background check)

    Run (install all the above, but the rkill, as it doesn't require installation):
    - In normal mode, run the TDSSKILLER and accept the terms and let it update.
    - In normal mode, run Malwarebytes and update.
    - In normal mode, run Antispyware and update.
    - In normal mode, run CCLEANER and update.
    - In normal mode, run CCLEANER. Clean all the rubbish, plus the registry too.

    Restart the PC in "safe mode" (different Windows version have different ways to do - from XP to W7, press F8 at startup, in W8-W10, need to do some manual labour to achieve, GiYF ), then keep this order:
    - Run RKILL.COM, wait to finish.
    - Run TDSSKILLER, wait to finish.
    - Run CCLEANER, wait to finish. Again, the rubbish and the registry too.
    - Run Malwarebytes Antimalware, wait to finish. When done, go to history and delete the whole quarantine.
    - Run Super Antispyware, wait to finish. Use the high boost scan. Whatever it pops-up at the very beginning as rubbish extension in browsers or such, delete all.
    - Run ESET online scanner, wait to finish. Search for all possibilities it offers (possible threats and so).
    - Run CCLEANER, wait to finish. Again, the rubbish and the registry too.

    Restart the PC and it should be all dandy again.
  • Albert RossAlbert Ross Posts: 17 [Apprentice Seeker]
    Thanks Mikko and Zsolt,

    Wow that's some list you have given me there. I have been to all the sites and bookmarked their download pages. At the moment I have Avast anti-virus installed, do I need to do anything with that before I start implementing your suggestion? I had heard, (rightly or wrongly),that running different anti-viruses do not work when run together.
  • ZsoltZsolt Posts: 36,020 Superusers
    In safe mode I think it wouldn't run, or at least not as usual. Shouldn't be a problem.
  • Albert RossAlbert Ross Posts: 17 [Apprentice Seeker]
    I did all of the above but still no joy I'm afraid. Still getting the same old messages.

    Is it possible that the TomTom was damaged when it failed to download the updates part way through the process, citing that it was no longer connected, which is why the computer can no longer identify the appropriate files on the device, have they become corrupted?

    I did contact the technical department a couple of days ago, but still waiting for them to come up with a solution.
  • ZsoltZsolt Posts: 36,020 Superusers
    Odd... Have you checked this one too?

    https://uk.support.tomtom.com/app/answers/detail/a_id/20314
  • Albert RossAlbert Ross Posts: 17 [Apprentice Seeker]
    I did have a quick look at that page earlier, but discounted it as when you click on "Click here to see which products/categories this applies to." The Via 52 is not mentioned, all the other via models appear to be there but not the model that I have.:? Would this be an error on the page, I have no idea. IF, and it's a big IF, it does apply to my Via 52 how would I update the device to version 16.6?

    All of this appears to be unnecessarily complex. On my previous TomTom that I purchased about 10 years ago, once you had connected it to your computer it acted as another hard drive and you very simply downloaded updates from TomTom and pasted them into the appropriate folder.
  • ZsoltZsolt Posts: 36,020 Superusers
    The latest software is 17.2xx and should be valid to your model too. Yeah, the old ones behaved as an external USB storage, but these models are like network devices.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Steve,

    The FAQ Zsolt linked to applies to all devices connecting to MyDrive Connect, yours included. It just seems to be missing from the list. I'll report that to the online team.

    Cheers, Mikko
Sign In or Register to comment.

Who's Online22

AndrewNZL
AndrewNZL
martinshephard_un44
martinshephard_un44
Robert_Bagley2309
Robert_Bagley2309
YamFazMan
YamFazMan
+18 Guests