Watch Charging Issue — TomTom Community

Watch Charging Issue

Ian LatimerIan Latimer Posts: 2 [Apprentice Traveler]
I am trying to charge my watch. I have connected to my laptop, and via an iphone plug to a wall socket, both of which have previously been successful. I do not have administrator rights on the laptop, so the Tom Tom sports connect application is out of date. Now all I see is the not charging icon in the bottom lhs of the screen. The watch is approximately 3 months old.

Comments

  • tfarabaughtfarabaugh Posts: 16,620
    Superusers
    It sounds like you may have a bad dock. Look at the pins, are any of them bent or misshapen? The outer two provide power while the inner two are for data. If they are compressed or bent, try straightening them out with a pin. You should also call Customer support and get them to replace it. To get the number for Customer Support, go to tomtom.com/support, choose Contact at the bottom, select the service required and the product name and click Contact Customer Care and then Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • Ian LatimerIan Latimer Posts: 2 [Apprentice Traveler]
    Thanks for your help. One of the outer pins seemed to have worked loose. I have temporarily been able to push it back into place, but will also contact Customer support.
  • GusColGusCol Posts: 1 [Apprentice Traveler]
    I cleaned the connectors on the watch and the pins on the charging cable with a pencil eraser (as indicated in one of the threads) and it worked like a charm!!! My watch is charging and back in business :)
Sign In or Register to comment.

Who's Online in this Category0