Multisport Button Fault Resolved — TomTom Community

Multisport Button Fault Resolved

alko12alko12 Posts: 3 [Neophyte Traveler]
edited January 2019 in Runner & Multi-Sport
Hi all I know this an old topic but is one that is still effecting owners. I had been having the stuck right button issue (in my case) when I rode my road bike for around 9 months now. In my case the right press button was the problem and it took several hard presses before it would move the display until it got to a point where starting, restarting after pausing during refuelling breaks during a workout was almost impossible, I had to use several really hard presses to get out of pause mode again, sometimes it would work, sometimes it wouldn't budge so I just gave up. Which defeats the purpose of the watch.

Anyway the way to resolve it (other than send it back for repair if still in warranty) (mine wasn't) is to remove the metal surround on the operation button (it comes off without too much problem with a fingernail) the metal surround has four longer lugs that click into a small slot you can see on the base of the button surround. What has happened is the pressure pad that the very tip of this lug contacts with (similar to the old digital watch button contacts) has moved into the watch very slightly, either through wear and tear or use). Once you have identified the side that is a problem ( right side lug in my case) all you need to do is cut a tiny bit of either electrical tape ( I used Gorilla tape) cut it really thin to the width of the lug, just stick the tape to the front side of the lug run it over the end overlapping the end of the lug and stick the reminder to the back so it has now made it slightly longer. You only need one layer of the gorilla tape as it is thicker, but may need two strips of the thinner electrical tap. Now just click the surround back into place, (if you have to force it too much you've used too much tape so just thin it down) and voila the button works like new again. It may be temporary until the tape wears down I guess but I'll just do it again if so. At least now the watch is back to being usable and I can enjoy the ride. Hope this helps as I know a lot of people have had this problem and it's very frustrating. Cheers

Comments

  • lampardlampard Posts: 5,606 Moderator
    Hi alko12,

    Welcome to the Community & sorry about the delay in response!

    Thank you for sharing this! We are sorry to hear that you had some issues with the control button on your watch.

    Interesting to see how you got it fixed. I've added some public tags to this post so that other users can find it and will find this helpful.

    Cheers,
    lampard
This discussion has been closed.

Who's Online in this Category0