Can't setup my new multisport cardio

DLR2017 Registered Users Posts: 4
Apprentice Traveler
edited January 24 in TomTom Sports
Hi all,

I am new to this forum and also new to the technology of gps watches! please excuse me, I genuinely do not know what I'm doing wrong!

So, I followed the set up instructions and downloaded the desktop app and iphone app. I set all of my credentials and selected English Uk as the language, however the language on the screen is not English and I cannot get it to change. I also cannot pair it with my iphone!!

I haven't even got as far as trying it out properly... please may someone help me out and point me in the right direction?!
Many thanks :)


  • tfarabaugh
    tfarabaugh Posts: 16,975
    You can set the language in two ways. First, go to the MySports site, click your name in the upper right and select Settings. Under the preference tab , select your language and then plug the watch into your PC to sync it. You can also change it on the watch itself (assuming you can read the language currently on the watch). To get to language, press down from the Clock, go down to the eighth menu item (Profile), click right and the top item is Language. You can then scroll through to get your language (English is the top of the list). Bear in mind if it is wrong on MySports, it will switch right back when you sync as the MySports setting takes precedence over the watch setting.

    Pairing it with your phone will depend on your phone, not all phones are compatible. What type of phone is it and what version of the OS is it using?

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
This discussion has been closed.