Sport Connect won't finish installation

AudioDoc Registered Users Posts: 3
Apprentice Seeker
edited January 24 in TomTom Sports
I'm running Windows 10 64 bit with an AMD Fire Pro V4900 graphics card with the latest driver. My computer is optimized for photo editing. I get the get the error message below about Open GL. Windows doesn't seem to want to let me know about which version of Open GL I'm running, though it must be at least version 2.0. Can't even begin to image why this would be important for this software!

Any help or suggestions will be greatly appreciated!

Kind regards,

Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 1, profile 0) .
This is most likely caused by not having the necessary graphics drivers installed.

Install a driver providing OpenGL 2.0 or higher, or, if this is not possible, make sure the ANGLE Open GL ES 2.0 emulation libraries (libEGL.dll, libGLESv2.dll and d3dcompiler_*.dll) are available in the application executable's directory or in a location listed in PATH.


  • AudioDoc
    AudioDoc Registered Users Posts: 3
    Apprentice Seeker
    Ok, I did not like it that I had to install a third party utility, because of this software installation problem,, but it tells me that I have Open GL 4.4, so why is this software giving me this error message?
  • tfarabaugh
    tfarabaugh Posts: 16,943
    For a question of this technical depth you are better off calling Customer Support directly, there is not much we can do on the user forums (unless one of the developers happens to see your post). To get the number for Customer Support, go to, choose Contact at the bottom, select the service required and the product name and click Contact Customer Care and then Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • AudioDoc
    AudioDoc Registered Users Posts: 3
    Apprentice Seeker
    Thank you Mark.

    Thank did indeed work! Much appreciated!


  • KarateTinTin
    KarateTinTin Registered Users Posts: 14
    Outstanding Explorer
    Just to add, I had to play about with the target a wee bit to get it to recognise it as a path, you need a space before the " --hw-gfx"

    So should look something like this:-
    "C:\Program Files (x86)\TomTom\MySportsConnect\TomTom MySports Connect.exe" --hw-gfx