Bandit App not going past 'Connecting' screen — TomTom Community

Bandit App not going past 'Connecting' screen

guystapes82guystapes82 Posts: 1 [New Traveler]
edited August 2019 in TomTom Bandit Action Camera

I've been using the camera and app together fine for a couple of weeks. I went to use it yesterday and the app won't work.

I can open the app and create the wifi connection between the app and the camera (camera screen confirms connection), however the app won't go past the 'connecting' screen. I'm not doing anything differently to before when I've been using both together - I've uninstalled the app 3 times, reset both the phone and the camera but still nothing.

Any ideas?


  • lampardlampard Posts: 5,391 Moderator
    Hi guystapes82,

    Welcome to the Community & sorry about the delay in response!

    Have you installed the latest software version 1.61.508 on the Bandit camera? Which Bandit App (Android/iOS) version are you using? As you're having issues with pairing to the Bandit App then you can also download the Bandit Studio software on your PC and update the software using it, see here: Update your camera software

    Please make sure to update the camera and give it a test run again to see if its the same after pairing with the smartphone.

  • Luke MaximousLuke Maximous Posts: 2 [Apprentice Traveler]
    Hi, was this ever fixed?

    I have exactly the same problems and have followed these steps to the letter and its still stuck on the connecting screen.

    Used to work now it never does.

    Im using a oneplus 3T


  • lampardlampard Posts: 5,391 Moderator
    Hi Luke,

    Do you have the latest software version 1.61.508 on the Bandit camera? Please follow the steps in the above response if not.

    At first, I would advise you to make a reset (RESET ALL) on your Bandit camera by following the steps here in public FAQ: How do I reset my Bandit GPS Action Camera?

    Once you make a rest, Please follow the link here to troubleshoot the connection between the camera and the App: Troubleshooting the connection between your watch and your Android device
    Cheers, lampard
  • vehicle-graphicsvehicle-graphics Posts: 1 [Apprentice Traveler]
    I have just bought my camera 1 week ago. Right out of the box I couldnt connect it to the phone. Actually I can but it drop the connection every 1 second and then connects again, drops and connects, This forever.

    I went back to the store, after I talked to support, and exchange it for a new one.

    Same problem,
    Changed another Iphone , and 6S ; Same problem
    Changed to a 8 plus ( I have the 7plus ) ; Same exact problem
    Yesterday I checked on an Android with a friend of mine and there all was Perfect.

    Updated the camera to latest software, Upldated the Phone App to latest.

    Anyone has any idea how can I make it work on Iphone. I would like to keep the camera but I see myself forced to return it for good if I cannot make it work
  • six3sevensix3seven Posts: 8 [Apprentice Traveler]
    January 2019 and this is still a problem... I've used my camera about 3 times in two years because of the inability to connect.
    lampard wrote: »
    Once you make a rest, Please follow the link here to troubleshoot the connection between the camera and the App: Troubleshooting the connection between your watch and your Android device

    That page is empty.
  • six3sevensix3seven Posts: 8 [Apprentice Traveler]
    Solved it... saw another post where someone said to turn of mobile data... because the app looks for the camera via mobile data connection... WTF would it do that!?!?

    This camera has basically been an expensive paperweight, I've fogotten wifi, reset the camera, reset wifi, removed the app, reinstalled so many times and it was probably mobile data all along.
  • CycleMichaelCycleMichael Posts: 1 [New Seeker]
    'six3seven' you are lifesaver !!

    "..... turn off mobile data... because the app looks for the camera via mobile data connection... WTF would it do that!?!?"

    Sheesh, I've been searching for this solution for months.

    So happy to get this solved.

  • wellyftwwellyftw Posts: 2 [New Traveler]
    That did the trick for me too. Surely tomtom could push out a fix for this? Don't need anything else than for this to work. I realise the camera is a little bit old but I'm sure it wouldn't cost them too much in developer time/wages to release an update of the software that fixes this bug.

    How about it, tomtom?
  • MarizMariz Posts: 1 [Apprentice Seeker]
    I continue to have the same problem even after following all of the above, even tried with cellular data turned off. Please someone at TomTom help ASAP as I need to use this camera in a few hours.
  • Glenda1979Glenda1979 Posts: 1 [New Seeker]
    i've found a way round it.

    turn off data.
    turn wifi on.
    connect via wifi scrreen to the cameras wifi. **DO NOT USE THE APP TO CONNECT TO THE CAMERA'S WIFI**
    launch tomtom app on phone.
    then go through options to connect.

    worked fine for me,
  • jftorresjftorres Posts: 1 [New Seeker]

    I have the same problem,
    In the connection process it does not pass the 'Connecting' screen
    This started after I did the software update
    I noticed that in the option ...
    > General> Connect> ....
    The "Phone" option does not appear
    Only options: "Remote" and "Sensors"

    Any idea?
    Was it because of the Android version?
    Or because of the camera software update?

    Tank´s for any help!
  • ThomsonThomson Posts: 4 [Master Traveler]
    I also experienced this app issue and simply accepted the fact that app will no longer be usable. And today I came across this thread. Turned off mobile data and app works again. Thanks a lot!
  • kumokumo Posts: 7,780
    edited February 28
    Samsung Galaxy A42 5G (Android 10)

    I purchased this smartphone end of 2020 and today I had the time to connect it with my old Bandit cam.

    1st of all - Bandit app is not available via PlayStore anymore :/

    Yes, I understood that development of Bandit app has stopped :'(

    I found a version v1.6.9.025b152 on a other site and hope that I can trust it. TomTom Release notes indeed lists v1.61.508 as 'latest' one. v1.6.9 is higher but close. I did *not* install a version v1.9.6 that can also been found on apk download sites. Are six and nine mismatched or is this a ugly trick to deceive users???

    I faced the same problem that is mentioned above:
    The app did not pass the 'Connecting' screen.

    Solution part 1: (maybe required):
    Turned off mobile data as suggested in several posts above.
    This alone did not make the trick.

    Solution part 2:
    Connected via smartphone WiFi screen to the cameras WiFi and DID NOT USE THE APP TO CONNECT TO THE CAMERA'S WIFI (thanks to @Glenda1979 for this suggestion)

    Now it seems to work. Real life will tell.

    Nonetheless TomTom ( @lampard ) should consider to place a direct download link to the latest *.apk on their own sites. There are still Bandit users out there in the world. Otherwise users like me have to search for the apk on other sites. Trust them or not... this is the question...
  • JimmeJimme Posts: 1 [New Seeker]
    edited March 30
    Sony Xperia XZ1 Compact - Android 9
    Bandit Version 1.61.508

    Thanks! your summary of previous solutions, helped me to finally get my Bandit to work again.

    NOTE 1:
    You can still download the official app from the Play store. It is still available in the Library in My apps & games.
    tested: 2021-03-30

    Note 2:
    If you downloaded the official app, it is possible to create your own APK file if you have your phone rooted. (google is your friend), but I agree again with Kumo that TomTom @lampard should have the APK file, as well as the studio program for windows, available for download, for us diehard bandit fans =) .

    Hope this helps.
Sign In or Register to comment.

Who's Online in this Category0