Spark 3 doesn't work anymore

Freedumz Registered Users Posts: 1
New Traveler
edited January 24 in TomTom Sports
Hi Everyone,

I've had my spark 3 since Christmas and it was worked fine on my computer
But since the last week, I haven't been able to update my activities on my computer
When I plug my watch, I've tomtom sport connect which start but I've a screen which register your device and when I click on register, I've an error message which said we met a problem, you've to reset your watch, so I click on reset and after that I've an error message which occurs, a problem has happened
I can update my data with the app on my smartphone and today I tried to plug my watch in another computer and it worked, so I'd like to know, what could i try?
I tried to uninstall and install the software but nothing has changed

Many thanks in advance



  • tfarabaugh
    tfarabaugh Posts: 16,943
    At this point I would suggest calling Customer Support to see what they can do. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, go to, choose Contact at the bottom, select the service required and the product name and click Contact Customer Care and then Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.