Spark 3 and Sports Connect

rabbat
rabbat Registered Users Posts: 3
Apprentice Traveler
edited January 24 in TomTom Sports
Just Bought Spark 3 GPS Watch. I'm using Win 10 on a desk top. I have down loaded Tom Tom connect when I first connected via USB the Spark 3 updated quite fine and up to that point all was good. Alas, when I connect to view my daily stats it shows no stats for anything. I swim every day also walk 10k steps. So is there something that I should do to upload the data or is it automatic? When I am connected it shows Battery charging on the watch! Any advise would be helpful.
Thanks.............rabbat

Comments

  • tfarabaugh
    tfarabaugh Posts: 17,004
     Superuser
    First I would check that the activity tracker is actually turned on. Go to Tracker>Goals>Steps and set a goal, pressing right to save it (pressing left will not set it). Are you getting any error messages when you plug the watch in or is it being recognized at all? If the clock face change to a battery charging icon this indicates it is getting power so there is a partial connection. A few things to look at (and I apologize if some are very basic but it is best to get past the obvious issues first):

    1) Are you plugged directly into the machine and not a hub?
    2) Does the port work, can the computer detect other devices (like flash drives) in that port?
    3) Is the watch firmly snapped into the cradle and the USB plug firmly in the port?
    4) Is the USB plug free of any debris or blockages?
    5) Is the Connect software actually running (is there an icon for it in the notification area)?
    6) Did you install MySports Connect, not MyDrive Connect? It is downloaded from tomtom.com/123
    7) Do you have administrator rights to the computer?
    8) Is a firewall or antivirus running that is blocking the software from connecting to TomTom (try turning them off before docking the watch)?
    9) Does the computer have a good Internet connection (Internet is required to sync)?
    10) Can you try installing it on a different machine to determine if it is an issue with the computer versus the watch?

    In particular, make sure it is fully snapped into the cradle. If it does not have a full connection it will charge but it will not be recognized by the computer. It seems simple but this is generally the issue. It needs to fully click into the cradle and it may help to take it out of the band to do so. Also check that none of the pins on the dock are bent or pressed in, as that will prevent a connection.

    If nothing above helps you may have a bad dock or there may be computer setting blocking it. At that point I would suggest calling Customer Support and seeing what they can do. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, go to tomtom.com/support, choose Contact, enter the product name and click Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • rabbat
    rabbat Registered Users Posts: 3
    Apprentice Traveler
    Thank you for your time, in replying. Most of the basic things that you mentioned I have checked and the watch seems to snap into the cradle really nice, also goals set. I will check my anti-virus programs and take it from there. I will switch machines also.

    I will post if I find a solution.

    Thanks again.............rabbat
  • rabbat
    rabbat Registered Users Posts: 3
    Apprentice Traveler
    Solved, as far as I can tell. Last week I switched to MS Edge, because I had some kind of conflict, I fired up Fire-Fox and viola all's good!

    Thanks for your time...........................rabbat