iPad 2 compatibility — TomTom Community

iPad 2 compatibility

Tomsan1Tomsan1 Posts: 2 [Apprentice Traveler]
edited January 2019 in TomTom Bandit Action Camera
Hi, new here so apologies if this has been asked before ..
Just been trying to download the app for my new bandit cam and App Store says my device is not compatible

I am on an iPad 2 which should work, running iOS 9.3.5. I can't get any info out of App Store other than saying 'this app is not compatible with your device'. It's definitely the bandit app! Do I need an upgrade of any sort or am I just being a bit simple?

Not sure why this is happening, any advice would be appreciated
Thanks
Tom

Comments

Sign In or Register to comment.

Who's Online in this Category0