Updating problems with TomTom ? — TomTom Community

Updating problems with TomTom ?

Hi

I'm at the end of my tether with TomTom.

I am sick & tired of my TomTom not updating, or saying the map is corrupted and then my computer (with superfast broadband connection) taking an hour to download the update...only to get a message on my TomTom at the end to say it still has no maps loaded. Then there have been problems with inserting an SD card for extra memory and, even after formatting the card and using different sizes, have never worked.)

Anyway, one question - is it possible to "do the mother of all resets" and how?

I travel frequently and my current TomTom has let me down so many times, and I've just had to rely on the map on my phone as a short term solution, which is far from ideal.

I just want my TomTom to work!

Sorry, this is partially a rant but also a couple of questions in there that I would like answered. Thanks.

Comments

  • NiallNiall Posts: 10,854
    Superuser
    @Whide67

    Sound like you need to have someone hold your hand as your try each possible solution, I therefore recommend that you contact Customer Services; explain what you have already done and ask them to help you get your 510 running as it should be.

    CS United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
    Closed 17/04/2017
  • mrpj3mrpj3 Posts: 132 [Outstanding Explorer]
    "Secondly, is a Garmin any better or do they have the same software problems?"

    Yes and no are my answers to that. A full Garmin map update takes about 10-15 minutes, including download and install.
    I've never encountered one single problem since disposing of a Go6100 and buying a Garmin device. Their software works flawlessly unlike MyDrive. It displays P.O.I.s on the map too.
    Their traffic is not as good as TomTom's. However, my 6100 never managed to avoid any holdups but routed me to them!
    Garmin routing is probably on a par with TomTom's.
    I hated those 1 hour map installs and about 20 minutes to update camera updates of just a few mbs on a fast fibre internet connection.
  • RoadhopperRoadhopper Posts: 1 [New Traveler]
    I had a problem with updating the maps on my Tomtom Start 25. It was working perfectly until I tried to update, then all my maps were wiped off the device! After connecting to 'My Drive' and trying to install the map updates all the device kept saying was 'No maps detected' or some such.

    Anyway, I decided to leave it until I had some free time available to look at the problem again (luckily, I still had my old Tomtom One XL).

    When I came back to the problem, I connected the Start 25 to my computer. Went to the Tomtom web page. 'My drive' etc. Went to the update section. But, instead of trying to update 'Maps', I decided to update 'Software' instead.

    The instructions said right click (on the two handed symbol ) in the 'Status bar' of the computer, go to 'settings'. I did this. Got to the update software section. Where it said 'Western Maps' update, clicked that. Got a message saying '34 mins to update'. Waited. The device said 'update successful' (after waiting the allotted time.)

    I unplugged the satnav from the computer, turned it off, turned it back on again, and hey presto! My maps were back.

    So, after all the frustration of trying to install the 'map updates' to no avail, I can only recommend you just try installing the 'software updates' first.
  • Mr AngryMr Angry Posts: 7 [Apprentice Traveler]
    Massive up date issue
    I have just bought a New TOMTOM as my old Go940 is just not worth updating for a 1 off update of £50.
    If I get a new one I get map updates for life. Yeh right if you can get it to work.
    I connected my tomtom after downloading my drive program 69mb program down loaded in 2 minutes so no issue with my broadband.
    Started my up date & 18 hours later it failed.

    Called Tomtom.
    Of course its my pc that is the issue not there server.
    Switched off my firewall as tomtom said this causes most of the issues
    They reset my device.
    18 hours later still not updated.
    My device now has no map & does not work. I now have a £100 door stop.
    I spent over £100 for somthing you cant update. I might as well have stuck with my old device.

    What the hell is going on Tomtom.
    It should not be difficult to update such a simple device.
  • dhndhn Posts: 33,326
    Superusers
    Might you have an antivirus or firewall impeding proper transmission? Are you using the cable that came with the device? Use a usb2 port if you have one on the computer.

    https://en.discussions.tomtom.com/mydrive-connect-apps-474/faq-mydrive-connect-troubleshooting-tips-990570
  • Mr AngryMr Angry Posts: 7 [Apprentice Traveler]
    Yes as I said in my post.
    The Firewall is OFF Completely
    Yes im using the lead supplied.
  • Emma9219Emma9219 Posts: 8 [Master Explorer]
    I have same issue as Mr Angry. I can not seem to get a response from support. My maps got wiped out when I tried to update them and now I can't even turn my device on! Wish someone at Tom Tom Support would help. All I have got so far is an email that someone will get back to me shortly. That was yesterday and I have heard nothing.
  • Paw PtiPaw Pti Posts: 3 [Apprentice Seeker]
    Same issues as Mr Angry. Attempted on 2 computers, a MacBook and a Win 10 with new downloads of My Drive connect. The update for GPS erased my maps and now there are no maps installed. The "updates" all fail after an hour of "progress" . Is there really any support available for these devices? Or should this POS go to recycling and should I start using WAZE?
  • scubanutscubanut Posts: 1 [New Seeker]
    TomTom says I must update Start 50 or it will no longer work after April 6. Yet, when I follow their instructions to the letter, the update always snags at password. I know password is correct, but changed it anyway at TomTom site. Update still refuses to advance past password. Think I will buy a different product. TomTom updates in general have always been a frustrating experience.
  • dhndhn Posts: 33,326
    Superusers
    @scubanut

    Call Support:

    United States
    877-757-7137
    Monday - Friday: 9:00 a.m. to 7:00 p.m. EST
  • Leduc5059Leduc5059 Posts: 9 [Master Explorer]
    scubanut wrote: »
    TomTom says I must update Start 50 or it will no longer work after April 6. Yet, when I follow their instructions to the letter, the update always snags at password. I know password is correct, but changed it anyway at TomTom site. Update still refuses to advance past password. Think I will buy a different product. TomTom updates in general have always been a frustrating experience.

    Ihave the same problem after the update of WRNO. Here it is caused by the numeric keypad. It gives the wrong numbers : 1=3, 2=3, 3=4, 4=5, 5=5 and 6=8, 7=8, 8=9, 9=0, 0=0
    So it is impossible to enter the correct password. I have send a e-mail to Tom Tom so.....???
  • Paw PtiPaw Pti Posts: 3 [Apprentice Seeker]
    Well I spent four hours on the phone with three different tech support people. Still won't update after erasing my maps. They offered me a 25% discount on a new one. They must think I am crazy if they think I would ever buy another product from them. My next efforts are in finding a class action lawyer to sue the pants off them. They must all be on the drugs they get in Amsterdam.
  • YamFazManYamFazMan Posts: 18,452
    Superusers
    Hi
    @Paw Pti

    Which Tomtom Model do you own ???

    ATB YFM
  • s38533s38533 Posts: 1 [New Traveler]
    Hi everyone.
    My first post here.
    I had same problem today trying to download (upload?) updates.
    So I looked up this forum and seems that a lot of people are having same problems.
    Before attempting to sue the company try logging out of your account and then logging back in with your password. Started updating straight away.
    It worked for me. Hope it works for you.
  • UrhoUrho Posts: 1 [New Traveler]
    Hi,

    I had problem to update my GO500 with Windows 10. Problem was that I have VirtualBox installed on my machine.

    The device was connected ok and updating started. Then connect lost. Navigator asked wait when updating will start again. Never started...

    I disconnected cable and reconnected it. After about ten seconds updating tried continue but very rapidly connect lost again.

    I noticed that every time I was connected navigator then Windows eventlog get error message with device \Device\VBoxNetLwf. So I switched off Ethernet adabter: "VirtualBox Host-Only Ethernet Adapter" and rebooted and TomTom updating worked fine!
This discussion has been closed.

Who's Online in this Category0