After updating maps, "Voice Control Not Available this Country"

Reiffel Range
Reiffel Range Registered Users Posts: 5
Neophyte Traveler
edited January 2021 in Built in car navigation
I updated my maps recently in my Mazda CX-5 (NB1) built-in Nav system using the US/Canada map update. The new maps were downloaded to the Mazda Nav SD Card and installed in the vehicle. The Nav seemed to start up correctly afterwards.

However, when I tried to use voice control to "drive to an address", I got the message "Voice Control Not Available in This Country". What must I do to restart voice control to navigate to an address?

In addition, there are other problems. Although it shows the correct location when I choose "view map", searching for an address seems to default to Ottawa Ontario, before I put in any other information. That's 2,500 miles from where I'm located. Shouldn't the system default to something nearer to my location? Is there anything I can do to fix that?

When I updated the maps, all my "favourites" and "recents" were lost. That seems to be a pretty ridiculous programming error. Who would imagine that customers would want to abandon all their history whenever they update maps? It seems that a decision could have been made to keep the customers' history in a file that doesn't get over-written when the maps are updated.

Comments

  • dhn
    dhn Posts: 33,382
    Superuser
    Try a drum reset on the unit by holding the power button about 20 seconds till you hear the drum sounds.

    Also wait a few minutes for a gpsfix and see if are then located properly.

    Support to assist:

    1 877-757-7137
    Monday - Friday: 9:00 a.m. to 8:00 p.m. EST
    Saturday: 10:00 a.m. to 6:00 p.m. EST
  • Reiffel Range
    Reiffel Range Registered Users Posts: 5
    Neophyte Traveler
    Thanks for the suggestion.

    This is a built-in unit which does not have a power button. I'll try this holding in the "select Nav" button on the audio system in the vehicle.
  • roncasual
    roncasual Registered Users Posts: 2
    Apprentice Traveler
    Hi, have you solved the issue? I have the same problem that started when I updated the maps. I called Tomtom support and they wanted to sell me another upgrade. They did not seem interested in helping.
  • Reiffel Range
    Reiffel Range Registered Users Posts: 5
    Neophyte Traveler
    I tried their instructions, but they didn't work. I also called in several times and got a sympathetic customer service rep who asked me to gather a lot of data. After 6 weeks, she quit and the next person was useless.

    Over time, the GPS has gradually future out that I'm in Canada, and now most of the time it will take voice commands. Occasionally, it starts out thinking i'm in Alabama, and I have to resent the country, put in an address manually, and go. If I used voice command again before turning off the car, it works. But sometimes, if it is turned off, when it's restarted it think it's in Alabama again. But why not Kansas? Hahaha!
  • roncasual
    roncasual Registered Users Posts: 2
    Apprentice Traveler
    Thanks for your reply. I have to set my home address each time I want to use voice control. The unit defaults to USA (I'm in Victoria BC). Sometimes is okay until I turn off the vehicle, then have to reset again. I'll try contacting Tomtom again. Maybe if enough people complain about this issue they will provide a patch.
  • Wombleuk
    Wombleuk Registered Users Posts: 7
    Apprentice Seeker
    I have voice control on my Mazda 6. When I say drive to favourites, the list of favourites appears with a number and the name. I've tried saying both, but it says command not recognised. what should i be doing?
    Thanks
  • TheSeekerz
    TheSeekerz Registered Users Posts: 1
    Apprentice Seeker
    I have the same problem for a while now too. @TomTom have you got this fixed? It has been over three years since it was reported and the problem still exists!!

    Please advised!

    Thanks,
  • samsonsg
    samsonsg Registered Users Posts: 7
    Apprentice Seeker
    I have the same problem as I am being told that voice control is not available in the currently selected country which is Canada. Tomtom bot support gave help in other areas instead.
  • Transfr8
    Transfr8 Registered Users Posts: 2
    Apprentice Seeker
    I am having the same issue with Via 135. I tried to used voice recognition for three stops for a trip we are going on. Voice recognition was used for the first stop. When I tried to use voice recognition for the second stop (about 20 seconds later) Canada is not recognised. Southwestern Ontario is definitely in Canada so I am not sure it why it worked once and then suddenly stopped working. I switched from AL to Canada and it still does not recognise Canada. Any ideas?