GO 50 not connecting to MyDrive Connect — TomTom Community

GO 50 not connecting to MyDrive Connect

sewsablesewsable Posts: 12 [Outstanding Explorer]
edited January 2019 in MyDrive Connect
I've not done an update for a wee while and yesterday I checked and there were 3 updates after I updated the app. Plugged my Go 50 in and it started dowloading, computer went into snooze mode partway through and the download stopped. Since then I've had the following message on my Go 50 each time I've tried to connect it "Please open or install MyDrive Connect on your computer". It also says "Connected to your computer" above that.
I've uninstalled and reinstalled MyDrive Connect, rebooted my computer and still having the issue. I'm running Windows 7 64 bit and have it plugged in directly using the Tom Tom cable which has always worked perfectly. I've also tried 2 different USB ports on my PC. Help?


  • sewsablesewsable Posts: 12 [Outstanding Explorer]
    I've tried all that now, the device is coming up in "other devices" on my device manager and is named "RNDIS". I've uninstalled it twice now, checked my updates and downloaded the two that were optional, rebooted several times, soft reset of the device, complete removal of the driver both using Windows remove tool and Revo Uninstaller with fresh installs and no dice. I still get the same message on my device and it never connects.
    I might have to try support, but not today, youngest is home sick so it's not a good day for phone calls.
  • sewsablesewsable Posts: 12 [Outstanding Explorer]
    Have emailed support after trying it on another computer today, same problem and this computer has never had the Tom Tom app on it before which tells me the problem is the device, not the program or computer.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi sewsable,

    Welcome to the Community!

    You can install the drive manually as follows:
    • Right-Click the device in the Device Manager list
    • Select Update Driver Software
    • Click Browse my computer for driver software
    • Use the Browse button to navigate to C:\Program Files (x86)\MyDrive Connect\Driver\INF and click Next

    Please, post back here to tell us how you're doing so that we can help you further, if needed :D

    Cheers, Mikko
  • sewsablesewsable Posts: 12 [Outstanding Explorer]
    Hi Mikko,
    Thank you for helping, I tried your suggestion, when I had the [/b] on the end it couldn't find the path "The location you specified does not exist or cannot be reached", when I removed the bit on the end it simply couldn't find the driver software for my device. Any further suggestions?

  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Rachelle,

    Sorry, my bad! The "/b" was not supposed to be there. I've fixed my previous comment now.

    Cheers, Mikko
  • sewsablesewsable Posts: 12 [Outstanding Explorer]
    I thought that might be the case, unfortunately even with the correct path it still couldn't find the file, I tried the x64 path as well seeing as I have a 64 bit system, but that didn't work either. I don't think I'm going to have any luck with this somehow, unless you've got a genie up your sleeve? Who would have thought the system going into lock would cause this much of a problem. Unfortunately it's habit now, otherwise my 12 year old ASD son is on there doing who knows what.
  • dhndhn Posts: 33,341
    Rachelle, I too have a Windows 10 64 bit machine here; nevertheless, I have files in EXACTLY the folder that Mikko listed about. I'd check again starting in the C:\Program Files (x86) folder. For some reason, the folders listed in there may not be in alphabetical order. So look carefully.
  • sewsablesewsable Posts: 12 [Outstanding Explorer]
    The files I have in there are tomtom which is called a setup information file and ttrndis which is a security catalogue. Unfortunately if either of them is the right file my computer is not picking them up when directed to that folder.
  • dhndhn Posts: 33,341
    Call support then.
  • sewsablesewsable Posts: 12 [Outstanding Explorer]
    I have, they emailed last night and I'll be trying their suggestions this afternoon when I get back home :)
  • sewsablesewsable Posts: 12 [Outstanding Explorer]
    Unfortunately the factory reset they suggested made no difference :(
  • dhndhn Posts: 33,341
    Might you have access to a 2nd computer by chance?
  • sewsablesewsable Posts: 12 [Outstanding Explorer]
    Hi dhn, I've already tried that. My husband's laptop had never been used for Tom Tom before so I figured it was worth a try, same result after installing the software. This was after the full reset too, so I'm fairly sure it's the device at fault, something in it's been affected by the computer locking during the install. I've also tried another USB cable with no success, I can't think of anything else I can try so I think I'm just going to have to give up for the moment. Thank you for your suggestions, it's good to know I'm thinking of the same things.
  • NiallNiall Posts: 10,871

    That sounds like you need the help of Customer Services on Monday to check the status of your account their end and talk your through getting you back up and running.

    CS New Zealand
    0800 450 973
    Monday-Friday: 09:00-17:30 NZST
  • sewsablesewsable Posts: 12 [Outstanding Explorer]
    Tried again on the other computer this morning and this time it worked! Still won't on this PC, but I'll take what I can get. Might be time to do a fresh start on this PC I think.
    Thanks for everyone's suggestions, including the helpdesk :D
  • dhndhn Posts: 33,341
    Good news!!:D
  • ZsoltZsolt Posts: 36,011
    Some more ideas:

    "Official" TT tips:


    If these didn't help, then try some of these:

    *Always make sure that you are logged in with the correct account. One device, one account*

    *** for Windows 10 users ***

    If you have just updated recently, you might run into trouble with TT (and other devices too). Disconnect the device, uninstall the MyDrive Connect support app with Revo Uninstaller, restart the PC, download the latest MyDrive Connect installer from http://www.tomtom.com/getstarted and install it again. Also in Windows 10, click on the "Start" menu (Windows icon in lower left corner), click on Settings and then Updates. Look for further updates, download and install those. Restart the PC, wait a minute or two, until everything starts up. Connect the device. If it is not recognised yet, keep it connected and then press and hold the ON button, until you hear the drum roll. Then wait another minute. If you have no luck yet, visit the web site of the manufacturer of the PC and look for newer (Windows 10 compatible) USB or chipset drivers for your computer and install it.

    *** TT CS official reply that worked for many with W10 issue ***

    Close MyDrive Connect completely:
    If your navigation device is connected to the computer, disconnect it.
    Click the MyDrive Connect icon ( or ) in the Windows notification area or Apple menu bar and then select > Quit
    Uninstall MyDrive:
    Click on the Start button and go to All Programs › TomTom › Uninstall TomTom MyDrive
    Alternatively you can use Add or Remove Programs in the Contol Panel to remove TomTom MyDrive Connect.
    Remove the application file:
    Press the Windows logo key +R to open the Windows Run dialog
    Type %localappdata%. Click OK.
    You will see list of folder. Find and open TomTom folder
    Delete HOME 3 folder.
    Delete the MyDrive Connect folder from: C:\Program Files (x86) (if still present)
    Delete the TomTom folder from: C:\Users\[username]\AppData\Local\ (USERNAME - It is the user name which you use to login to Windows )
    Delete the TomTom folder from: C:\Users\[username]\AppData\Roaming\
    Delete every file and folder from: C:\Windows\Temp\ (in case some files can't be removed, reboot the PC and retry)
    Restart your computer.

    Re download a new installer from http://www.tomtom.com/mydrive (I recommend you to use the Google Chrome while downloading the installer)

    Now install MyDrive Connect with the newly downloaded installer.

    After the installation process of the new MyDrive application completes successfully, please restart your computer. Now, check if the application is able to connect to your device properly or not.

    *** For further troubleshooting tips, please see below ***


    - It is very unlikely that one would have to do these all, it is usually one of the below mentioned possibilities

    - As in IT Crowd: Have you tried to turn the computer off and on again? :)

    - Try to add MyDrive Connect to the exclusion list of your antivirus and firewall (or disable those temporarily)
    - Make sure that your computer is not going into stand-by or similar (this shouldn't happen with the latest MyDrive Connect)
    - Clear the cache before each update attempt. Also could do a soft reset before and after the update
    - Make sure you have all the latest updates and hotfixes/patches to your OS (not only the mandatory ones, but the optionals too)
    - In case the device looks like hung during the update or the counter stopped (or not visible at all), just leave it.
    Most probably it will be fine in a few minutes (or within a couple of hours, in case of installing large maps)
    - Check your network connections, make sure that the TT's network adapter is enabled
    - Try to uninstall and re-install the MyDrive Connect application (best to use Revo Uninstaller to remove)
    - Try to use a USB port on the mainboard, rather than a USB hub (desktop PC)
    - Try to change the port to 5000 (or 5001) in MyDrive Connect's settings
    - Try to run the MyDrive Connect app as administrator
    - Sometimes disabling caching large files helps too
    - It is worth checking the USB power saver settings

    - Any further issue: Try it on another PC, try it with different USB lead...the shorter the better (below steps are Windows specific)
    - Whilst the device connected, remove the drivers from the Device Manager (Windows/Control Panel), DELETE the drivers
    - Remove the MyDrive Connect application and run CCLEANER (will remove your history, cookies, etc by default)

    - At the moment certain USB3 port looks like incompatible with the TT devices (those are usually coloured blue on the PC).
    Could try BIOS update on the PC or enable "Legacy mode" for the USB ports in the BIOS (for further instructions, look for the user manual of your PC/mainboard)
    - Don't use the magnetic mount whilst updating, connect the micro USB directly into the device
    - Disable any network monitoring software
    - Update one item at a time, don't select all.
    Best order: NavCore/software - Map - QuickGPSfix - Speed Cams - Map Share Corrections (this is the smallest but longest in some cases)

    Certain Mac versions (10.10.2, 10.10.3 10.10.4 and 10.10.5) have USB issues, but there is an official fix available, provided by Apple.
    The latest version of MyDrive connect is not compatible with Windows XP SP2 and below, make sure that you update to SP3 and install ALL the other updates.

    IMPORTANT CHANGE FOR XP AND VISTA: https://uk.support.tomtom.com/app/answers/detail/a_id/20314
  • sewsablesewsable Posts: 12 [Outstanding Explorer]
    It's working now after I did a clean install of Windows 7 and then reinstalled all the other software. Not the simplest solution, but at least it worked.
  • KaborexKaborex Posts: 2 [Apprentice Traveler]
    I have a start 52 that was not connecting to two windows 10 computers. When plugged in windows 10 did not even search for the drivers. Nothing happened at all. I then proceeded to try it on a windows 7 laptop and straight away windows 7 searched and found the drivers and everything worked fine.

    It is an issue with windows 10, however the develppers at TomTom should be aware of that and should by now have a solution. Eg.... find the driver that works and add it as a download in the support section. Come on guys these devices are not cheap so help out the community.
  • ZsoltZsolt Posts: 36,011
    Works fine on all my Win10 PCs and I have a few. Most likely the culprit will be the USB driver of the W10 PCs you use. Check if there is a BIOS update or if you can set the USB to legacy or compatibility mode. Otherwise USB3 drivers and W10 are not friends in many cases.
  • KaborexKaborex Posts: 2 [Apprentice Traveler]
    Looked at this article before. It however assumes that device manager is picking something up. Nothing gets picked up in device manager. Tried on a surface pro, Asus allinone top specs machine and trust me I have access to all sorts of PC/tablets as I work in IT .... Nothing works apart from that one windows 7 laptop I tried.
  • ZsoltZsolt Posts: 36,011
    The Surface Pro has USB power saving that needs to be disabled via regedit. The top spec Asus most likely uses a sort of USB3, which has issues with TT and W10.
Sign In or Register to comment.

Who's Online in this Category0