A12 Essex Northbound Specs Cameras — TomTom Community

A12 Essex Northbound Specs Cameras

benbird7benbird7 Posts: 16 [Apprentice Traveler]
edited January 2019 in TomTom Services
I noticed on the way back from Dover last Friday that the specs cameras dotted along the A12 northbound are not showing up on the tomtom (around the Witham area) but obviously other tomtom road users were submitting these cams as they kept coming up asking if a mobile camera was still positioned there?

I have had a look at the site http://www.speedcameramap.co.uk/ and cannot see any SPECs cameras located in this area, which is making me wonder if they are actually active which is why they are not showing up?

Many thanks anyone who may know.

Does anyone know from the Essex area if this is the case?


  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Ben,

    Welcome to the Community!

    Our Speed Cameras team has checked this and these specs were there for the roadwork in that stretch. The roadwork is now finished and we've removed the cameras from our database.

    Please, post back here if you have any further questions :D

    Cheers, Mikko
  • duttonstduttonst Posts: 22 [Master Explorer]
    This is an issue, and I have it too.

    There are SPECS cameras northbound on the A12 just after Witham - assume these are the ones that @benbird7 saw. They are live and permanent and are nothing to do with roadworks. In fact they have been there for several years - you can see them in Google Streetview.

    They completely fail to show up on my GO5100. Tomtom, please fix this.
  • John-JayJohn-Jay Posts: 706 [Revered Pioneer]
    Hi, benbird7,

    I notice that the site http://www.speedcameramap.co.uk/ was last updated over 4 years ago - hence it is clearly out-of-date!

  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Thanks for your feedback regarding this!

    Our Speed Cameras team check these locations and confirmed that we have these cameras in our database. For some reason, however, these cameras are not shown on your devices.

    I'd first recommend you to reset your device by pressing and holding down the power button until you hear a drumming sound (ca 15 sec).

    Should this not help you sort this out, please re-install the cameras with MyDrive Connect.

    Cheers, Mikko
  • duttonstduttonst Posts: 22 [Master Explorer]
    Thanks. I've actually tried both these options previously, several times, without success. I've just tried a full factory reset - let's see if that helps. I'll be driving past these cameras on Thursday so will report afterwards if still not working.
  • duttonstduttonst Posts: 22 [Master Explorer]
    I drove past these SPECS cameras again last night. They are a string of four, and THREE out of the four cameras are still completely missing, even after my full factory reset. These are cameras that have been there since 2015. All the (many) other cameras on my route were correctly reported.

    I see the same issue was reported to you here: https://en.discussions.tomtom.com/speed-cameras-158/specs-cameras-993688. 12 months later the problem is still there.

    Please fix this!
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi duttonst,

    Thanks for coming back!

    There's indeed a device issue causing some cameras sometimes not showing although they are in our database. In most cases the troubleshooting measures I mentioned - or factory reset as you mentioned - have sorted these out, but unfortunately not in all cases. As this issue is difficult to reproduce, it's also difficult to fix. But every bit of feedback helps and I'll forward yours to the team as well :D

    Thanks, Mikko
  • duttonstduttonst Posts: 22 [Master Explorer]
    Hi Mikko. One of the three cameras is completely missing from your database if Map Share Reporter is to be believed, so it needs to be added. Either way, I really do need these cameras on my device - they are impossible to spot in the dark. Is there a way you can force them to update? e.g. delete/re-add to the database? Or if it's a device issue, replace my device?
  • RTwoRTwo Posts: 53 [Master Traveler]
    I can confirm there is one missing on the database/device
    But saying that, they are specs and still shows on my Go app as being in an average speed zone so not really something that concerns me personally.
  • duttonstduttonst Posts: 22 [Master Explorer]
    Good to know that you see the SPECS zone properly in the app. Sounds like this is a problem specific to the GO device. Interestingly when I approach the last camera in the series - the only one that DOES show up on my device - the graphic that appears is clearly the "end of SPECS zone" graphic (eg with avg speed) and for a couple of hundred meters it does realise I'm in a SPECS zone. Unfortunately it's no use at all by that stage.
  • RTwoRTwo Posts: 53 [Master Traveler]
    I'll be going down that particular road again on Tuesday, I'll have a good look at what the app is reporting Vs what is actually in front of me.
  • RTwoRTwo Posts: 53 [Master Traveler]
    Southbound on that stretch yesterday, just the first camera gantry was reported on the screen but the zone stayed live the whole way through on the Go Mobile App
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Please also note, that for average speed zones we only give warning for the beginning and end of the zone, not any cameras in between.

    Cheers, Mikko
  • NiallNiall Posts: 10,906

    With sectors being defined as the distance between each camera; that may be very problematical.
    Two scenarios
    1. Speed limit may change in each sector
    2. Some authorities fine for each sector that is exceeded
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Niall,

    That's a good point! The different sections are of course counted for as well. The average speed for the section is shown in the route bar with the camera icon.

    Cheers, Mikko
  • duttonstduttonst Posts: 22 [Master Explorer]
    Went through there southbound this morning with both my Go & iPhone active and can confirm both were in sync and correctly identifying the start & end of the SPECS zone, although I can see on Mapshare Reporter that one of the cameras is missing southbound as well (the one half way along the Kelvedon bypass).

    However it's only ever been northbound that I've noticed the problem so I'll repeat the experiment in a week or so when I next have to visit Ipswich.

    @MikkoK, any progress with a proper fix for this?
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi duttonst,

    Our Speed Cameras team has already confirmed that these are all in our database. If I understand you correctly they're also correctly alerted on by your device/app.

    If they're still missing in MapShare Reporter, you can report them.

    Cheers, Mikko
  • duttonstduttonst Posts: 22 [Master Explorer]
    No. To recap: the first 3 northbound cameras are NOT alerted on my GO5100, so the SPECS zone does NOT start in the correct place. This is even after a full factory reset, several restarts and adding/removing cameras from the device. I have no idea if the same is true of the app at this point.

    As above, if you cannot fix this I would like to exchange my GO5100 for a unit that works as advertised. Correctly alerting me to these specific cameras is very important to me as I usually drive this route in the dark and they are not easily visible.

    In MapShare reporter I can see 2 of the 3 cameras that my GO5100 fails to spot. I uploaded a missing camera report along with a geotagged photo of the missing camera over a week ago and as far as I can tell, nothing has been done.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi duttonst,

    Thanks for the clarification!

    I'm afraid I don't have further suggestions for you. Please, contact Customer Service. They'll be able to get to the bottom of this and assist you accordingly :D

    Cheers, Mikko
  • duttonstduttonst Posts: 22 [Master Explorer]
    To keep this thread up to date, I used TomTom GO on my iPhone through this section of the A12 on Friday and behaviour was EXACTLY the same as on my GO5100. All bar the last of the northbound cameras appear to be missing and my iPhone did not report that I was in a SPECS zone. In fact I can reproduce the problem 100% using “Play Route Preview” on both my iPhone & my GO5100 - I don’t even need to drive the route to see the problem.

    I also note that the same cameras have been reported as missing on the following threads, none marked as resolved:


    Possibly I'm just unlucky and just happen to have the only two malfunctioning TomTom devices as far as these cameras are concerned. More likely that they are missing from many or even **ALL** devices. Would be good to hear from anyone who is definitely being correctly warned about this SPECS zone by their device. To re-iterate, they are the ones on the A12 Northbound carriageway starting just after Witham and ending just after the Kelvedon by-pass.
  • benbird7benbird7 Posts: 16 [Apprentice Traveler]
    Here I am again 3 months after originally posting. Traveling back from Gatwick to East Anglia in the early hours of Sunday morning but no traffic on the road so nice and clear get to the northbound spec camera and yet again had to rely on my in built sat Nav to show these specs cameras on the A12. Fortunately I had the brains to import pgpsw cameras onto the built in sat Nav as a back up. Good job I did as that showed me where they were.

    The Tomtom pings up at the first camera asking if the mobile camera is still there.

    Please sort this out. Done a full map update and speed cam update the week before I left so two weeks ago. And before you ask. Yes I tried a factory reset too!

    To add the Dartford tunnel was closed due to maintenance Saturday night so they were running contraflow over the bridge. Went over that Tomtom didn't like it as it's not the normal route. When I return to the northbound carriageway the Tomtom wouldn't recognise and continued to place me in the southbound carriageway. Had to restart it and enter journey again for it to work.
  • benbird7benbird7 Posts: 16 [Apprentice Traveler]
    Here the speed cameras are taken from cameralert which the pgpsw app. I've circled them for clarity...

  • benbird7benbird7 Posts: 16 [Apprentice Traveler]
  • duttonstduttonst Posts: 22 [Master Explorer]
    Thanks @benbird7 - you are describing exactly what I see on my iPhone & GO5100. I raised this with TomTom support over a month ago. I've given them geotagged photos of the cameras, GPX files, chased them every few days and tried to get it escalated. All to no avail, so far anyway. Last week someone had the nerve to call me and suggest I reset my GO5100, as if I hadn't already tried that a dozen times already.

    I would urge anyone that sees this problem to log a call with TomTom so that at least they know it's a general problem. If you drive this route regularly you'll know these cameras can be tricky to see in the dark.
  • benbird7benbird7 Posts: 16 [Apprentice Traveler]
    Hi duttonst

    That's exactly the problem I had. I don't speed excessively but if it's clear I just want the peace off mind I know where these cameras are my average bring logged between them.

    I actually have a backup on my in car sat Nav showing the logos and in my central armrest a £15 Tomtom one with an sd card which I upload the mobile camera sites to switch on when going in unknown areas which ping these up such as "mobile 70" as I find the mobile alerts with the Tomtom go 510 inadequate.

    Doing about 18k a year I'm a higher risk and want to have what I can in place in the car to ensure that is minimised.

    Thanks :)
Sign In or Register to comment.

Who's Online in this Category0