GO 50 and iPhone 7 connection — TomTom Community

GO 50 and iPhone 7 connection

I had the same problem with my iPhone 5S but since getting a new iPhone 7 I can pair my Go 50 but it keeps losing its connection. I have factory reset the Go50 and done all the other suggestions but with no joy...Help please..
«1

Comments

  • RollingRockRollingRock Posts: 10 [Legendary Explorer]
    Hi stuart,

    this issue can be common with certain Bluetooth devices when they do not request to re-establish a connection, but your question doesn't really explain how the Bluetooth drops out.

    Does it happen when you walk away from the GO 50, or do you have to re-pair all over (note: not reconnect to an already saved Bluetooth pairing)? Please explain a bit in more detail what is happening exactly.

    It doesn't hurt to do a hard reset by holding down the power button on your GO 50 until you see the TomTom logo and hear the TomTom drum sound. This will give it a fresh restart if there are any issues with the OS.

    - RR
  • stuartR1271stuartR1271 Posts: 24 [Master Explorer]
    My Go 50 pairs up to my iPhone for a few seconds and then flashes 'Lost connection to your phone' then 'Phone connected' and keeps on cycling through these messages at the top of the Go 50 screen
  • RollingRockRollingRock Posts: 10 [Legendary Explorer]
    Hi,

    Did you try the hard reset as suggested?

    If yes; it would seem it's cycling between Bluetooth connections. If you check your phone's Bluetooth settings, do you see any other devices it's trying to connect to?

    It wouldn't hurt to try and disable other applications like Apple Aidrop to see if that improves stability.
    I would otherwise suggest a recovery mode for your GO 50 if there's something wrong with the software. Instructions can be found here (do not mind the title of article): https://uk.support.tomtom.com/app/answers/detail/a_id/1898/

    Let me know how it works out.

    - RR
  • stuartR1271stuartR1271 Posts: 24 [Master Explorer]
    Apple AirDrop is off. My Apple Watch stays connected and when unpaired doesn't help the Go 50 connection to lock on. I have done both a Factory and TomTom Drum beat reset. Neither of those helped. I will wait until tomorrow to do a software re-install. But in the mean time will attempt to pair my GO to my wifes iPhone 5...
    Thanks for the advice, but it looks like its a TomTom fault..
  • RollingRockRollingRock Posts: 10 [Legendary Explorer]
    Hi,

    If your wife's phone also fails it would seem to he be a hardware failure in my opinion, but it doesn't hurt to try the recovery mode.
    I presume you have checked for new updates in MyDrive Connect to see if there is a software update for your GO 50?

    Alternatively I would advice to contact support to see if they can help.

    https://uk.support.tomtom.com/app/contact Scroll down, select your product and scroll a bit further down to find a button to contact Customer Care. This will give you the option for a phone number and a way to e-mail the support.

    - RR
  • stuartR1271stuartR1271 Posts: 24 [Master Explorer]
    Update..I successfully connected my Go 50 up to my wifes iPhone 5...So the problem is between my new iPhone 7 and the GO 50.. Something to work on in the morning..
  • RollingRockRollingRock Posts: 10 [Legendary Explorer]
    Hi,

    glad to hear that it worked on your wife's iPhone, but not so much on your own iPhone.

    I would suspect some app is causing this issue, but one thing that can be tried is to reset the network settings as this will also (mostly) remove any bugged out network setting caused by WiFI, Bluetooth and other wireless capable components. This will remove previously stored WiFi, Bluetooth and personal settings for wireless/mobile network settings so only do this if you don't remember the settings.

    This is done under Settings, General, Reset, Reset Network Settings. This will not remove any personal data but if you have a custom provider you might have to set that up again.

    Alternatively you can put your iPhone in Safe Mode which will disable all custom installed applications and then see if it works that way.

    - RR
  • stuartR1271stuartR1271 Posts: 24 [Master Explorer]
  • CraigSCraigS Posts: 6 [Master Explorer]
    I've been having a similar problem for weeks. It starts with Traffic disconnecting even though the TomTom says it is still connecting to the cloud. Then I reset the TomTom and it toggles through connected/disconnected, then another drum-roll reset and it works for an hour or so.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Thanks for reporting this issue!

    Could you also state your phone model and OS version, please?

    @ Craig: I don't see a device registered on your TomTom account. Could you PM me the serial number of your device, please, so that I can log it into the ticket?

    Thanks, Mikko
  • stuartR1271stuartR1271 Posts: 24 [Master Explorer]
    MikkoK...My iPhone 7 is running the latest iOS 10.2.1
    For further info I have just returned from a 6 hour drive into London with no Traffic info...Just a TomTom Go 50 cycling through the "Connected" "Disconnected" screens.Deep Joy !!
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Stuart,

    Thanks for the info! I've added it to the ticket.

    Apart from factory reset you seem to have already done most of the suggested troubleshooting, but I'll list them below for others possible having the same issue. The steps are from the easiest to more tedious. You should re-try after every step before continuing with the next one.
    • Suspend/resume device (quickly press the power button to suspend, then again to resume)
    • Toggle off / Toggle on the Bluetooth profiles in the device's settings > Bluetooth > Phone_Name
    • Soft reset the device (hold the power button until the drums roll)
    • Restart the phone
    • Un-pair / re-pair phone and device
    • Factory reset (Settings (cog wheel) - System - Reset - Reset) the device and pair again. Please note, that factory resetting will delete your personal information, e.g. My Places and destination prediction data. You can save and restore My Places with MyDrive.

    We're currently investigating this issue and working hard to find a solution as soon as possible. I'll post back here as soon as I have news to share.

    Cheers, Mikko
  • CraigSCraigS Posts: 6 [Master Explorer]
    The latest TomTom update seems to have fixed it, I've done two 2-hour drives with no issues. Fingers crossed.
  • yammasyammas Posts: 3 [Neophyte Traveler]
    any update as I have same issue
  • yammasyammas Posts: 3 [Neophyte Traveler]
    my iphone 7 and Go keep dropping connection ...AARRRRRRGGGGHHHHH
  • yammasyammas Posts: 3 [Neophyte Traveler]
    Any update??
  • stuartR1271stuartR1271 Posts: 24 [Master Explorer]
    yammas..I tried again a week ago and still no joy! I'll try again tonight and update
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Unfortunately, I don't have an update about this issue. We're still investigating it. For most people the steps I listed above help to solve it. If this is not the case for you, please report to Customer Service. They'll be able to gather the relevant details to help our technicians investigate why this happens to you.

    Cheers, Mikko
  • Tim NicholsonTim Nicholson Posts: 1 [Apprentice Traveler]
    Unfortunately Tom Tom seem to be completely unable or unwilling to resolve the "dropped connection" issue, which has been ongoing for at least 2 years. My device exhibits what appears to be the typical problem - the device can be connected and working fine, and next the connection drops and no amount of resetting or re-pairing will resolve the issue. The last time this happened the device went off line for about 2 months and then started connecting again of its own accord . It now refuses to connect again, so no traffic updates possible for an unknown period. I cannot understand why Tom Tom will not get their act together and sort this out.
  • GarryCollinsGarryCollins Posts: 1 [Apprentice Traveler]
    I have just upgrade my mobile phone to an iPhone 7 and my phone does just this, it keeps dropping and connecting all the time. i have tried various things, but have found to only way to get the connection to stay is to reset the network connections on the phone and then the tomtom device get connected, but as soon as to turn the tomtom device off it stops working again.

    Please can someone advise have they managed to work this one out as this is a real disappointing as i use it for long journeys and rely on traffic updates.

    Cheers
    Garry
  • AgetroAgetro Posts: 2 [New Traveler]
    I´ve got the same problem
    "Hi all,

    I´ve got a problem between my Iphone 7 and GO 50.
    Imposible to maintain the bluetooth connections more than 5 seconds after they are pairing. So, i Can´t use the activation or my drive in the cloud
    I´ve reset the go 50 to factory defaults, and reset networks in my iPhone, but it still doesn't work.
    Could anybody help me? What can I do?
    Thanks in Advance.
    "
    BR

    Lorenzo
  • Major SinnerMajor Sinner Posts: 2 [Apprentice Traveler]
    Same issue here with iPhone 7+.. Tried all the resets, soft resets, software updates. Tom Tom blame Apple, Apple blame Tom Tom. I'm paying for Tom Tom services and cannot use them anymore. Aggravated to say the very least.
  • Major SinnerMajor Sinner Posts: 2 [Apprentice Traveler]
    SOLVED:
    No thanks to Apple or Tomtom.. I found the answer on another forum for iPhones.
    The problem seems to be with the iPhone 7 / 7 plus. Mine is a 7 Plus.
    Here is what to do, though I haven't tested the longevity of the fix as its only been a few days now..
    Remove tomtom from phone and phone from tomtom..
    SWITCH OFF bluetooth on your phone.
    Hard reset your phone. (iPhone 7 hold power and volume down buttons)..
    Restart phone and switch bluetooth back on.
    Connect phone to tomtom as normal.

    It works for me, I hope it fixes your issues !!.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Major Sinner,

    Welcome to the Community and thanks for sharing your solution!

    Re-pairing the devices has indeed been an effective measure in these cases for many, especially if the problem starts after an update for the phone or TomTom device. We're investigating this and working hard to find a solution as soon as possible.

    Cheers, Mikko
  • Agetro73Agetro73 Posts: 7 [Apprentice Traveler]
    Very Bad!!! ... i bought a 450 rider last week and i´ve done all.
    major sinner, thanks for your answer, but it is not a solution.
    Please Mikkok, we need a permanent solution
    L.
Sign In or Register to comment.

Who's Online7

Bembo
Bembo
Router1
Router1
scheibenklar
scheibenklar
+4 Guests