Stuck on 'waiting for you device' for latest update

mikeofhovemikeofhove Posts: 3 [Apprentice Traveler]
edited January 31 in MyDrive Connect
On trying to update the GO600, MyDrive Connect is stuck on 'waiting for your device'. The device displays it's connect to the pc via USB, original cable, direct to a USB port on the PC. I have tried restarting the PC, the TomTom but the update will simply not install. It's been well over half an hour and nothing has happened.

Can someone help with how I can get this to update???

I actually have issues updating my device, almost every time there is an update. This has been the case for both TomToms, different PCs, Macs, etc. No matter what I do, updating the device is a nightmare. It is very frustrating and it's about time TomTom sorted out their software so it works. Although I've had a couple of TomToms, I will definitely not be buying another as I have not a lot to lose by trying another brand. I would never recommend a TomTom to anyone, purely based on the major issues with updating the device.
«1

Comments

  • MedgeMedge Posts: 2 [Apprentice Traveler]
    My Start 25 is doing the same today.
  • andydajoandydajo Posts: 2 [Apprentice Traveler]
    Having the same trouble with my Go510, updated the MyDrive software on Mac currently version 4.1.3.3036. I selected what I wanted to uopdate, it downloaded and then the same issue as you, 'waiting for your device' although its connected with TomTom usb cable and MyDrive sees what is on the device and how much space is left.

    Hopefiully someone will have an idea on what is wrong. Like you i've uninstalled the Mydrive app and reinstalled - same problem.........
  • mikeofhovemikeofhove Posts: 3 [Apprentice Traveler]
    seems like you are having the same issue as me!
  • MedgeMedge Posts: 2 [Apprentice Traveler]
    For better or worse, what worked was to ignore the instruction to leave connected and use the expert solution of switching the device off and on again. It then re-downloaded and competed installation satisfactorily (well, it said it did)
  • arichardarichard Posts: 319 [Supreme Navigator]
    @Medge is right, although I thought recently there was supposed to be a fix. Maybe the software has become quantum and it depends upon your thoughts.
  • mikeofhovemikeofhove Posts: 3 [Apprentice Traveler]
    As I was busy, I just left my TomTom connected, eventually, it seemed to recognise it was connected and continued. At one point, it was almost done (1 minute remaining), then it was finishing. Then suddenly it started another process, so I had to wait longer. Overall, the update took just over 3 hours, ridiculous in my view. TomTom need to get their act together and sort out their software. I dread it every time I see I need an update as I know it will be a hassle to update. I regard this as a bad service from TomTom.
  • Ovalball03Ovalball03 Posts: 279 [Outstanding Explorer]
    Mine did the same.I disconnected it,fully charged the battery then tried again and all was good.
  • andydajoandydajo Posts: 2 [Apprentice Traveler]
    Mine is also working now but I empied the cache as suggested by another post I read on here.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Thanks for all your feedback regarding this!

    As mentioned here, the latest MyDrive Connect release addressed this issue, but unfortunately some may still experience it. We'll continue to investigate this in order to find a proper solution as soon as possible.

    Meanwhile, you can resume the installation of your updates by disconnecting and reconnecting your device.

    We're very sorry for the inconvenience this is causing you!

    Cheers, Mikko
  • dougalangham_un38dougalangham_un38 Posts: 11 [Master Explorer]
    I have had a similar problem for a number of months (the download to the device is stuck at 6% and the device itself is for ever ""updating" without actually finishing) but thought that by leaving the Go 6000 for a couple of months and then updating the system, that all would be resolved. However not! I had been in regular communication with Tom Tom engineers to try to solve this issue but it seems that the Tom Tom engineers have failed, which is a shame as I like the device when it is working! I have tried deleting the cache, deleting the My Drive installation and then updating it, tried resetting the device etc but still without success. I have just bought the update for Traffic Cameras but can't update the device, or find out if anything has actually been updated, as the device is frozen as it still thinks that it is being updated. Becoming frustrated is becoming the norm so when will Mikko and his team actually sort this issue???
  • VikramKVikramK Posts: 6,537 TomTom Moderator
    Hi dougalangham

    I had a look at your account and I see the latest map of Europe v980 is installed on your GO 6000 device(14th December 2016). So I wanted to know during which update do you see the process getting stuck at 6%.

    Thank you
    Vikram
    Have a question? Ask!
    Did a reply resolve your query, please mark it as answer!
    Try the search; the information you are looking for could already be available.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Please, make sure you're using the latest v4.1.4 of MyDrive Connect released yesterday. That release further addresses this issue.

    Cheers, Mikko
  • NiallNiall Posts: 10,410 Superuser
    @MikkoK



    A detailed list of what was fixed is needed!! I.e. proper change control!
    Help others identify useful content :- - If someone posted something that was helpful? Click the Like button :thumb_up:
    If someone answered your question? Answer yes to "Did this answer the question? Yes · No"
  • dougalangham_un38dougalangham_un38 Posts: 11 [Master Explorer]
    Hi Vikram. I have purchased the latest speed camera update and tried to download the 2mb version but the latter is stuck at 6% and it continues to try to download onto the device every time I link the device with the PC. I have managed to get some things updated on the device but when I can sometimes access the device downloads I noticed that not all countries have been successfully updated (e.g. Spain is not present). It is very frustrating especially as it has been a fault for some time now as I am not sure what has actually been successfully downloaded onto the device.
  • VikramKVikramK Posts: 6,537 TomTom Moderator
    Hi dougalangham

    Thank you for coming back!

    If you have the map of Europe v980 then it would include Spain as well. I have asked the customer service to get back, so they should be able to address the issues.

    Regards
    Vikram
    Have a question? Ask!
    Did a reply resolve your query, please mark it as answer!
    Try the search; the information you are looking for could already be available.
  • RoxaneRoxane Posts: 2 [Apprentice Traveler]
    I kept unplugging and replugging, and seeing if I started the software before or after to see if that made a difference. None of that worked, but what did is while it was connected, I switched off the device (still plugged in) and then started it again. It still said "waiting for your device" for about 30 seconds, but then it kicked in and did the update.
  • DebbieBethDebbieBeth Posts: 1 [Apprentice Traveler]
  • NiallNiall Posts: 10,410 Superuser
    @DebbieBeth

    Sounds like you need some help from Customer Services to check the status of your account from their end.

    CS United States
    866 486 6866
    Monday - Friday: 9:00 a.m. to 8:00 p.m. EST
    Saturday: 10:00 a.m. to 6:00 p.m EST
    Help others identify useful content :- - If someone posted something that was helpful? Click the Like button :thumb_up:
    If someone answered your question? Answer yes to "Did this answer the question? Yes · No"
  • vigmanvigman Posts: 5 [Master Traveler]
    I bought this TomTom Start for my wife as my daughter had a TomTom. As an ex IT Manager I would say it is the worst piece of computer related equipment that can be bought.
    On the first occasion it took ages to get My Drive Connect to put the initial maps on.
    I just put My Drive Connect 4.1.4.3089 (W7) PC. A map update appeared successful after about two hours but when starting the unit up again I get "No Maps Found". I cleared the cache, (which I had to do manually as there is now no right click on the icon option!) turned the unit on and off as well as connecting and disconnecting.
    All I get is "Waiting for device"............
    So now I have no maps and no way of updating the unit. This is really quite appalling and people should get a direct refund from TomTom
  • Tim_GTim_G Posts: 8 [Master Explorer]
    After a few years without any connection woes today I get an email about a map update and I'm having the same 'waiting for your device' problem. Three separate USB cables, several different USB ports on the PC and countless uninstall and re-installs later I am no further froward. Very frustrating.

    If I have any luck later I'll post here, but don't hold your breath.

    TomTom Go Live 825
    Win 7 Pro.
  • vigmanvigman Posts: 5 [Master Traveler]
    Following my last mail. I uninstalled MyDriveConnect and re-installed an earlier version. I then updated this. For several attempts the unit would not connect. Finally it did and I started the map update again. When prompted I disconnected the Start 25.

    I started it up................and it just stuck on the home screen. After about 20 times of turning on and off it appears to have gone into its 'normal' service.

    This is totally unacceptable. If TomTom can't automate a simple download and update, then just allow us to download the necessary files and copy them to the satnav ourselves, or at least give us that option.
  • Tim_GTim_G Posts: 8 [Master Explorer]
    Success at last. I tried updating only one update, the map update, and deselected the map share option and it worked like a treat. The map share did, after a few attempts update. It's not a problem peculiar to Tom Tom. My sister in law had connection issues with her Garmin unit last Christmas and it took hours to solve that. It seems the software interface is very poorly implemented for these devices.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    I'm sorry to hear of your problems updating your devices!

    The issue originally discussed here has been solve already. However, in some situations you may still see the "waiting for device" message. This indicates a problem with the connection between your device and MyDrive Connect.

    There can be various factors interfering with the connection. I've listed the most common causes here.

    Should those tips not help you sort our your problem, please contact Customer Service. They have more tools at their disposal to help you get this sorted.

    Cheers, Mikko
  • duckster43duckster43 Posts: 15 [Renowned Trailblazer]
    Well, every time I have to update map or speed camera, it is like a lottery. Very frustrating exercise. Nothing new, had the same problem with my old TT720 which used TomTom Home. I have not had 1 instance when the updates have gone smoothly. All I can say, when my Live 820 eventually is working, no problems, however last time after map update lost my red light cameras. Took several phone calls to Indian call centre to have them re-instated. In summary, TomTom, your software is quite flakey and I look forward eventually ditching TomTom and start using my Android /Google phone with the latest traffic, location and POI information.
  • Vince17Vince17 Posts: 2 [Apprentice Traveler]
    I have the same problem with my Go 5100 stuck in updating, so at the moment I have a device that is not usable as the maps are now corrupt.
    do Tomtom care, of course not, they have our money,as a company the are completely rubbish, no support no help or we will get back to you in 3 weeks maybe

    Perhaps I should start a do not buy a TOMTOM produck on the web,
«1
Sign In or Register to comment.

Who's Online24

24 Guests