SD card problem Rider 2 — TomTom Community

SD card problem Rider 2

Rosco2Rosco2 Posts: 1 [Novice Seeker]
edited January 17 in RIDER
No result for the search query 'Hi I have a Rider 2nd Edition which has just developed a fault. It is showing a diagram of the SD card removed with a red cross through it. When I remove the card and then replace it I get the same result. No SD card . What to do. Have tried holding the on/off button for 10 seconds to get the black screen with white writing but then just reverts back to no SD card logo. Any suggestions.'.

Comments

  • VikramKVikramK Posts: 7,964 TomTom Moderator
    Hi Rosco2

    Welcome to the community:)

    If you have active maps on your account then please format the SD card on a computer(FAT32) and then insert it in the device.

    Or else please check this with customer support.

    Regards
    Vikram
    Have a question? Ask!
    Did a reply resolve your query, please mark it as answer!
    Try the search; the information you are looking for could already be available.
  • Ste7iosSte7ios Posts: 725 Superuser
    First check if the card is ok with your computer.

    If you can see the files, make a backup.

    Format the card with FAT32 file system.

    Restore the files.

    Insert the card into the rider.

    If that doesn't work it must be a hardware problem.

    It can be corrosion of the SD card pins slot which may solved with a contact cleaner.
    Or it can be stg worst.
Sign In or Register to comment.

Who's Online19

19 Guests