New GO Mobile for Android v1.13.2 available for download

MikkoK
MikkoK Retired TomTom Employee Posts: 23,905 Retired Community Managers and Staff
Hi all,

We've just released a new v1.13.2 of the GO Mobile for Android and it's available for download in Google PlayStore.

[h3]What's new?[/h3]
• Performance improvements and fixes

Drive safe! :D

Cheers, Mikko
«1

Comments

  • davec321tt
    davec321tt Registered Users Posts: 7
    Apprentice Traveler
    Good afternoon,

    I have been unable to connect to Live Traffic since the last update v1.13.1.
    This update hasn't fixed the issue unfortunately.
    I've tried logging out and back in, turning 'Traffic and Speed Cameras' service off and on, restarting the app and the phone, but no luck.
    Can you offer any advice please as rely on this heavily?

    Many thanks,
    Dave
  • MikkoK
    MikkoK Retired TomTom Employee Posts: 23,905 Retired Community Managers and Staff
    Hi Dave,

    Welcome to the forum!

    Please, report this to Customer Service for further investigation.

    Cheers, Mikko
  • DCJunior06
    DCJunior06 Registered Users Posts: 66
    Renowned Wayfarer
    davec321tt wrote:
    Good afternoon,

    I have been unable to connect to Live Traffic since the last update v1.13.1.
    This update hasn't fixed the issue unfortunately.
    I've tried logging out and back in, turning 'Traffic and Speed Cameras' service off and on, restarting the app and the phone, but no luck.
    Can you offer any advice please as rely on this heavily?
    Many thanks,
    Dave

    Same problem here :(
  • riki66
    riki66 Registered Users Posts: 432
    Sovereign Trailblazer
    Same here! No traffic info at all on my Galaxy S6.
    1.13.1 was working just fine.
  • harsh1311
    harsh1311 Registered Users Posts: 196
    Supreme Navigator
    I had the same issue. I did manage to fix it by toggling the traffic and speed camera OFF and then back ON under tomtom services menu item. I think somehow the setting do not persist once one upgrades to 1.13.2 causing this issue
  • MikkoK
    MikkoK Retired TomTom Employee Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Thanks for reporting this!

    We're currently investigating this issue. Please, contact Customer Service. They can log your details to help with the investigation as well as keep you up-to-date about it.

    Cheers, Mikko
  • davec321tt
    davec321tt Registered Users Posts: 7
    Apprentice Traveler
    harsh1311 wrote:
    I had the same issue. I did manage to fix it by toggling the traffic and speed camera OFF and then back ON under tomtom services menu item. I think somehow the setting do not persist once one upgrades to 1.13.2 causing this issue
    Unfortunately this didn't work for me.
    I've reported to Customer Services as advised and waiting to hear back.
  • Uriel
    Uriel Registered Users Posts: 598
    Renowned Wayfarer
    I'm also on 1.13.2 and had no live traffic during rush hour this morning. Checked it a little after 9am and it was working.
  • davec321tt
    davec321tt Registered Users Posts: 7
    Apprentice Traveler
    Uriel wrote:
    I'm also on 13.2 and had no live traffic during rush hour this morning. Checked it a little after 9am and it was working.
    Thanks for posting. I've just checked it again and it's now working. Must have been an issue at the Tomtom end.
    Cheers,
    Dave
  • Maris
    Maris Registered Users Posts: 15
    Apprentice Seeker
    Kiitos!
  • Michael369
    Michael369 Registered Users Posts: 4
    Master Traveler
    I habe the 1.13.2 as well after days of no connection to tomtom server. I was happy today morning bc it worked for an hour on my way to work. But now it is dead again. My mate has the same app, but it's version 1.12. We just driving home from work. Funnily he has the HD Traffic for all the last days when I hadn't. He making fun if me. Because he blocks auto updates and I don't.
  • Tel911
    Tel911 Registered Users Posts: 3
    Apprentice Seeker
    Hi I had this problem and tried resetting the app through the settings menu fixed it for me on wifi and mobile data
    Will see if it continues to work
  • MikkoK
    MikkoK Retired TomTom Employee Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Thanks a lot for your feedback regarding the connectivity issue!

    Please, see here for more about that issue and what kind of information would help us investigate it.

    Cheers, Mikko
  • GetThereGL
    GetThereGL Registered Users Posts: 4
    Master Traveler
    Lately had a trip and used this app. The power consumption wass extremely high and the charger can't not keep up causing continuous draining of battery.
  • [Gelöschter Benutzer]
    [Gelöschter Benutzer] Posts: 5,321
    Supreme Navigator
    GetThereGL wrote:
    Lately had a trip and used this app. The power consumption wass extremely high and the charger can't not keep up causing continuous draining of battery.
    https://en.discussions.tomtom.com/search?q=drain+battery&forum=156
  • GetThereGL
    GetThereGL Registered Users Posts: 4
    Master Traveler
    Thanks, EthoZ. Seems the root cause still is this Go app. High rate charger/cable is only a temporary solution on user end. TomTom is losing ground.
  • Paskaaaaaa
    Paskaaaaaa Registered Users Posts: 3
    Novice Seeker
    Päivitykset on pelkkää Paskaa. Vaihtakaa Garmin:iin ja toimii
  • Yemble
    Yemble Registered Users Posts: 42
    Outstanding Wayfarer
    GetThereGL wrote:
    Thanks, EthoZ. Seems the root cause still is this Go app. High rate charger/cable is only a temporary solution on user end. TomTom is losing ground.

    By FAR, the biggest drain on modern smart phone batteries is the display. If you do not have an in-car charger that is correctly matched to the phone charging technology, then the charge rate will be extremely poor when the display is on. Add a few apps into the mix and the battery drain will exceed the charge rate.

    Yes, TomTom is a battery hog, but this only becomes an issue if the in-car charging setup is not matched to the phone. This is not a temporarary solution, it is the ONLY solution.
  • Tel911
    Tel911 Registered Users Posts: 3
    Apprentice Seeker
    I am using a galaxy S7 Edge and found battery drain a problem so I purchased a high output usb adapter and now the phone charges while I am using the app
  • NukeThemAll
    NukeThemAll Registered Users Posts: 52
    Outstanding Wayfarer
    Indeed: see also the discussion:

    https://en.discussions.tomtom.com/tomtom-go-mobile-and-navigation-for-android-156/17-1060-battery-draining-issue-back-again-989785/index2.html#post1054127

    All you need is a decent charger AND - this is important - a 'charge-only' cable.
  • MikkoK
    MikkoK Retired TomTom Employee Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Thanks for all your feedback!

    If you're experiencing excessive power usage with the GO Mobile app, please check out the power saving settings [user manual] of the app.

    Cheers, Mikko
  • cruiZer
    cruiZer Registered Users Posts: 68
    Outstanding Wayfarer
    Sorry to say MikkoK but that's no answer at all.
    TT advertises all sort of fantastic functionality, the use pays for it, and you advise to disable it.

    Just the fact that a charger is needed is questionable. True in a car it's no big issue. But TT also sells GO to route walking or biking trips.
  • MikkoK
    MikkoK Retired TomTom Employee Posts: 23,905 Retired Community Managers and Staff
    Hi cruiZer,

    I'm afraid you misunderstood me. I wasn't asking you to turn the power saving settings off but the try them out to see if they help you ;)

    When walking or biking you won't be needed TomTom Traffic so you could turn it off to save some power as well.

    Cheers, Mikko
  • lneam
    lneam Registered Users Posts: 87
    Supreme Trailblazer
    Hi MikkoK,

    back to year 2012 I had use to one Sony Ericsson Xperia neo V Android 2.3.4 (1 core CPU 1GHz, 512MB RAM, 1GB ROM=320MB free to user) the previous tomtom navigation software from playstore for a couple of times. A very light application and I need to congratulate the programmers for the excellent job they made. I wish today those team to continue develop ...
  • nbay4000
    nbay4000 Registered Users Posts: 4
    Neophyte Traveler
    So I just updated earlier this morning my maps and since then I have been in touch with customer service and they don't have any answers as to why my go app wont load all I get is a grey screen with menu options but no maps. I installed 1.13.2 map update for the southeastern US I was on phone for 40 minutes and the representative told me he needed to end the call and to email him back if the problems persists or it fixes itself. We tried to reset the app and also a clean uninstall and a reinstall and still the same problem.
This discussion has been closed.