TomTom Bandit will not turn on

Ken WoodKen Wood Posts: 1 [New Traveler]
My TomTom Bandit action camera will not turn on just recorded Great North Run charged the battery tested the battery showing 4 green light thats flashed 5 times inserted the battery into the camera body attemted to turn on and got nothing tried numerous charging usb and laptops desktops the battey appears to be charged yet the reb start button will not turn it on any help advice welcomed.

Comments

  • 47alma47alma Posts: 1 [Apprentice Traveler]
    Have braND NEW NEVER USED BANDIT, HAVE FOUR GREEN LIGHT BUT GET ABSOLUTELY NOTHING WHEN i PRESS AND HOLD THE RED BUTTON ON THE BACK OF CAMERA. HELP!!
  • ChrisChris Posts: 934 Retired Community Managers and Staff
    If the Bandit is new, make sure you have first removed the plastic that covers the metal pins on the batt stick, this prevents the battery discharging while shipping. If that's been removed, check that the Batt Stick is fully clicked in to make sure the connection of the pins and the connectors inside the barrel of the Bandit are touching correctly. Lastly if when you press the star button (with the Batt Stick removed), if the LEDs flash quickly on/off this could indicate a defective Batt Stick, if the LEDs remain on for a few seconds then it should be fine. In the case of a defective Batt Stick I recomend you contact Customer Care: https://us.support.tomtom.com/app/contact/locale/en_US
  • vdwuvdwu Posts: 7 [Master Explorer]
    I have the same problem. After buying the Bandit I did a few test and everything worked fine. The problem occurred after after a dive about 20 meters deep. No restart possible: I applied all tricks I know, but nothing works to revive the device. Battstick is OK, lights remain green for a few seconds outside the device. I wanted to send it back, but guess what? It worked again when return home, so I assumed it was an incident.
    Now I want to take it for a second scuba dive, but I think the Bandit got scared and stopped working again!
    In the manual no sign of a hard reset (e.g. press a few buttons at the same time...). I am very sure this is a software/boot problem. I will send it back for sure now!
Sign In or Register to comment.

Who's Online3

3 Guests