"Waiting for Device" while updating GO 6100 - Page 2 — TomTom Community

"Waiting for Device" while updating GO 6100

2

Comments

  • gladtobegrey5100gladtobegrey5100 Posts: 11 [Master Explorer]
    I have had this 'Waiting for device' message twice now, with my Go 5100. I AM using the TomTom supplied USB cable, so that isn't it.

    A new map's available, so I connected to update. I was told it would take 2+ hours initially (really?), so I left it to it. When I came back ... "Waiting for your device...".

    Disconnecting and reconnecting just went straight back to "Waiting...".

    Disconnect, turn the device fully off and on again, then reconnect ... the device says "Updating" and MyDriveConnect says "56 minutes left".

    Finally, it updated.

    This is pretty disappointing. My old Go 530 never had this problem. Solid as a rock, and always updated without hitches or hanging/losing connection like this.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Thanks for all your feedback regarding this!

    We're currently investigating this and working hard to find a solution as soon as possible. Meanwhile, disconnecting and reconnecting your device will help you resume updating.

    We're very sorry for the inconvenience this is causing you!

    Cheers, Mikko
  • Colonel CoconutColonel Coconut Posts: 9 [Legendary Explorer]
    Hi all

    I have just upgraded to the Go6100 from an ancient Go720 and have been fustrated by the setup issues.
    The software confirmed that a new map was available, so I connected TOMTOM usb cable to update. I was told it would take 2+ hours initially (how long?), so I left it to it. When I came back ... "Waiting for your device...".
    After 6hrs it was still 'Waiting for device' with the swirling arrow.
    In resource manager cpu was less that 2% so I risked disconnection.

    Disconnect, turn the device fully off and on again, then reconnect ... the screen then showed the map was downloaded but transfer to device would take a further 1hr 30mins. WHY does it take so long to download and transfer maps which are not huge files. I have an Xeon dual processor computer and fast internet connection so where is the restriction?

    I wish to download the USA maps onto a 16gb class 10 sd card. Will I experience the same issues when downloading this???

    All appears to be ok with the device and maps now, but I am appauled that I should have had to go through this procedure with a "flagship product" around £300. I have a reasonable level of PC knowledge, but there are many who wouldn't be able to comprehend what was going on.

    I never had these problems with my old Go 720 which always updated without hitches or hangs.

    Thanks
  • dhndhn Posts: 33,201 Superusers
    Your next experience with downloads/installs may be better. Maybe.

    You can change the default port in Settings of MyDriveConnect (get to it by clicking the UK flag in the opening screen) -->Downloads tab. Change to 5000 or 5001 and save the settings.

    Also, perhaps an anti-virus or firewall is impeding proper transmission.
  • gladtobegrey5100gladtobegrey5100 Posts: 11 [Master Explorer]
    Why will/might changing the default port make any difference to mid-update transmission? My Go 5100 does connect and start downloading, and only hangs once the process is (apparently) well underway.

    Unless I'm not getting something, if the port was the problem, wouldn't it fail to connect at all?
  • NiallNiall Posts: 10,597 Superuser
    @gladtobegrey5100

    The 4000 port is the default used by many devices, so if you have cordless mice/keyboards and any other USB devices attached to your computer they all try to use that port. The first part of the process is the download from TT servers and storage on your computer, then there is the delete of the old map from your device, then the download of the file(s) from your computer (via USB 1.0? protocol) to your device, followed by a cleanup process. All of these processes will be monitored by your anti-virus software / malware checker, and anything else that you have installed on your computer to protect against unauthorised file manipulation.
  • ZsoltZsolt Posts: 36,006 Superusers
    Seen a couple of updates hanging issues in the past few days. There might be a back-end issue also. In case it is not sorted by the morning, drop a mail to TT CS or give them a call.
  • Colonel CoconutColonel Coconut Posts: 9 [Legendary Explorer]
    Thanks for the comments everyone.
    Will try the 5000 port before downloading the Americas map.
    Regarding the antivirus/firewall, I disabled them temporarily on the download machine so they shouldn't have been an issue.
  • Colonel CoconutColonel Coconut Posts: 9 [Legendary Explorer]
    Just an update.

    USA maps loaded ok but still had to switch off 6100 after initial download of map to trigger transfer to device.
    Whole operation took about 2+hrs.
    I didn't disable antivirus/firewall.
  • gladtobegrey5100gladtobegrey5100 Posts: 11 [Master Explorer]
    Possibly just coincidence, but ... I installed a 32Gb microSDHC card in my Go 5100, which has been experiencing hangs/disconnections when updating maps etc.

    I reinstalled the map (Europe v9.75, 6540 Mb) so that it was, effectively moved from internal memory on to the new card. That also enabled the full map, including Russia, to be reinstalled (previously there wasn't enough memory following the new map release).

    Didn't change the port from the default, or disable antivirus/firewall.
    Took just under an hour, including a couple of follow-up updates.

    No interruptions/disconnections.

    Will keep monitoring when I next update.
  • CrystalbarnCrystalbarn Posts: 60 [Legendary Explorer]
    I am experiencing this issue "waiting for device" tried everything from resetting device to unplugging usb cable. I use the supplied cable (no mount) only. I've contacted customer support who just ask for screen shots and do nothing but waste my valuable time! Nothing resolves it!

    I've had this problem and lots of other updating issues from the day I purchased GO6100 8 months ago, it has been a constant frustration that never ends!

    I have just purchased the new Trucker 6000 lifetime edition and from new out of the box I have issues.....

    So that's over £700 on TomTom navigation devices that give me constant problems and have me wasting days of my life in front of the PC while customer support play me music!

    TomTom have consistently been the worst company/product I have ever encountered!!!
  • CrystalbarnCrystalbarn Posts: 60 [Legendary Explorer]
    MikkoK wrote:

    When MyDrive Connect is showing a "Do not disconnect" message it's installing updates. If in doubt whether the update is actually proceeding, you can check the activity with the Windows Resource Monitor as Therick did. If there's no activity you can troubleshoot as with a connection issue.

    Cheers, Mikko

    I have found the simplest way to see if the update is actually proceeding is to look at the device screen, if it has the swirling circle and says "updating", then it is, if device screen simply reads "connected to your computer" but MyDrive Connect says "installing updates" and "waiting for device" then there's no activity and you should proceed to troubleshoot connection issues....

    I will also add - these updating issues have existed for at least 8 months! Sometimes it works, sometimes it doesn't and the problems get worse not better!
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Cystalbarn,

    What you're describing is exactly the current issue discussed here. Updates can get stuck for various reasons but in this case - as in most cases - it can be resolved by disconnecting and reconnecting your device.

    We're investigating this issue and working hard to find a solution as soon as possible.

    Cheers, Mikko
  • CrystalbarnCrystalbarn Posts: 60 [Legendary Explorer]
    MikkoK wrote:
    Hi Cystalbarn,

    We're investigating this issue and working hard to find a solution as soon as possible.

    Cheers, Mikko

    Yes but again as I previously stated - this issue has existed for at least 8 months that I'm aware of..... I don't think that time scale is acceptable.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Crystalbarn,

    I understand that it may seem like that as the symptoms are similar but this scenario is actually a specific one. We're working hard to improve the updating experience. Meanwhile, for MyDrive Connect troubleshooting tips, please see this FAQ.

    Cheers, Mikko
  • Steve 12345Steve 12345 Posts: 1 [Apprentice Traveler]
    Same issue here but on a via 135. TomTom Connected, computer icon showing on sat nav screen, device shows as connected on TomTom Myconnect main screen then when I click to update it get 'UPDATING DEVICE - Keep you device connected and this app open while updating - Waiting for your device . . . '

    And never get past that.Have tried disconnecting and reconnecting, restarting both several times. No way past this. As soon as I unplug the device My Connect recognises the disconnection, but it seems unable to update?
  • dhndhn Posts: 33,201 Superusers
    Support Monday then:

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • AldridgeAndyAldridgeAndy Posts: 24 [Prominent Wayfarer]
    For the first time in many today I installed two updates ( map share updates and speed cameras separately as always to minimise issues ) and surprisingly everything went ok.

    I saw "waiting for device" but that cleared after 30 seconds or so by itself, which made a pleasant change.

    But just to add my voice to the many above, "waiting for device" is becoming an increasing problem, it also means that you can't update the device unattended as you always have to intervene at some point.

    Hopefully one days soon, I'll be able to connect my Go 5000 and select "update all" and walk away, then when I return the device will be up-to-date and ready to go. Basically as I used to for many years with my TomTom Go720.
  • patinipatini Posts: 3 [Neophyte Traveler]
    dhn wrote:
    I don't care what the instructions say. I KNOW that, for some, disconnecting and reconnecting DOES start the installation process -- including for me once or twice.
    This hint had unlocked my tomtom start 50 on windows xp.
    excellent.
  • Michael OwenMichael Owen Posts: 1 [Apprentice Traveler]
    I used the USB cable out of the box provided by TomTom and still got the issue. Disconnected and reconnected and the install continued.
  • RHD42RHD42 Posts: 4 [Neophyte Traveler]
    I was having this problem with Tom Tom VIA 135 and OS X Mavericks.
    I was havering over whether to disconnect the device or not when the software told me to disconnect it as it wasn't responding.
    I disconnected, reconnected and re-started the device and now it's installing.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    We've just released an update to MyDrive Connect that addresses this issue. Please, update and post back here your findings.

    Thanks, Mikko
  • Mike NewMike New Posts: 18 [Outstanding Explorer]
    It has NOT sorted out the problem - i spent all day yesterday trying in vain to update the EEurope map on my GO6000. I kept getting the 'Oops it's rush hour, try again' screen and now My Drive says the Europe map is corrupted - i click repair and it starts all over again and still does not complete. Nowi have a device with no maps installed and no obvious way forward. This is the first time i have had such major issues upgrading my maps, i even tried it on a different computer as suggested - same as the first computer, corrupted maps and device with no installed maps.
    Not a happy bunny!
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Mike,

    You're problem sounds like a different one discussed here. It's been solved and you can find further instructions in the topic :D

    Cheers, Mikko
  • AnatexisAnatexis Posts: 2 [Apprentice Traveler]
    OK Ive had it now. I have been trying for a week to update the software and maps on my Go50. I have been stuck on the same old rubbish screen of "waiting for device" every time. I have; restarted device numerous times, done a factory reset numerous times, disconnected and reconnected countless times, download every and any version of Tom Tom Home and My drive(I) I can find, used the Tom Tom cable and several others, tried on 3 computers, tried just downloading the software update and not my newly ordered map (96 dollars for useless junk I cant even get on my device), and decided that Tom Tom have sold me a pup. The best thing now is to use the Go50 as a fishing weight. Incidentally had it for 2 years and from the get go it has NEVER had more than 10 minutes battery life. I use Garmins professionally and Im going to go back to using my Garmin for my holidays now. Anyone want to buy a fishing weight?
Sign In or Register to comment.

Who's Online25

BIOXXxx
BIOXXxx
Heidekreis51
Heidekreis51
+23 Guests