"Waiting for Device" while updating GO 6100 — TomTom Community

"Waiting for Device" while updating GO 6100

TherickTherick Posts: 3 [Apprentice Traveler]
edited January 2019 in MyDrive Connect
After waiting two and a half hours to download the updates for my GO 6100, I've now waited another two and three quarter hours to transfer the downloaded files onto my GO 6100.
While downloading from the internet, I at least had a indication of how long it would take and the percentage of the download that was completed.
Now I have nothing, apart from the "Waiting for device" message, is this normal ?

My TomTom is still telling me that it is "Connected to your computer", but MyDrive is just telling me that it's waiting for my device, shouldn't it be telling m how much of the update has been copied across, or has every thing stopped ?

Thank you in advance for any help with this.



  • TherickTherick Posts: 3 [Apprentice Traveler]
    After looking on the "Resource Monitor", my "TomTom MyDrive Connect.exe" has sent a total of 420 B/s, is this normal ?
  • dhndhn Posts: 33,298 Superusers
    Try disconnecting and reconnecting the device while MyDriveConnect is open.
  • arichardarichard Posts: 319 [Supreme Navigator]
    @dhn your advice is the opposite of the messages the actual software gives. Having connected the nav and downloaded to computer, MyDrive Connect says "DO NOT DISCONNECT . . . " and the device itself continues to show a connected symbol. I believe most customers will be confused by this contradiction. I was. If your advice IS the correct response then the software engineers must be expecting to create a Shakespearian Sonnet by putting a monkey in front of a typewriter.
  • dhndhn Posts: 33,298 Superusers
    I don't care what the instructions say. I KNOW that, for some, disconnecting and reconnecting DOES start the installation process -- including for me once or twice.
  • NiallNiall Posts: 10,746 Superuser
    Another example of the fragility of TomTom software ;)
  • arichardarichard Posts: 319 [Supreme Navigator]
    [email protected] I do care what the instructions say and yes I also have done what you suggested with considerable un-necessary anxiety in order to make the sick software work. And I think it important to make the point about the Shakespearian Sonnet above.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    If I understand Therick correctly, MyDrive Connect is showing a "Waiting for device" message which means that it's not seeing the device being connected. In such case disconnecting and reconnecting would indeed be the first thing to try for refreshing the connection. Next I'd reset the device by pressing and holding the power button until a drumming sound is heard (ca 15 ca).

    When MyDrive Connect is showing a "Do not disconnect" message it's installing updates. If in doubt whether the update is actually proceeding, you can check the activity with the Windows Resource Monitor as Therick did. If there's no activity you can troubleshoot as with a connection issue.

    For further MyDrive Connect troubleshooting tips, please see this FAQ.

    Cheers, Mikko
  • arichardarichard Posts: 319 [Supreme Navigator]
    MikkoK wrote:
    Hi all,
    When MyDrive Connect is showing a "Do not disconnect" message when it's installing updates. If in doubt,
    Cheers, Mikko

    Sorry MikkoK I do not understand. What is your advice / instruction that seems to be missing from the first sentence above ? There is never any doubt about the message "Do not disconnect"
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Richard,

    I amended my post with an elaboration on that point. I hope it's clear now :D

    Cheers, Mikko
  • arichardarichard Posts: 319 [Supreme Navigator]
    Thanks MikkoK now I understand what you mean. I could not begin to do your job in a second language - I'm grateful. It is still very buggy and I'm sure many customers will not be familiar with windows resources or want to use them.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Thanks, Richard! :D

    Of course we don't expect customers to have to use Windows Resources or any other troubleshooting tools/measures to update their devices. However, if/when things go wrong it's nice to have some means to get out of the situation and/or understand what's happening. The FAQ I linked to above lists most of these. Customer Service is there to assist should those means fail to solve the situation and/or the steps are not clear to the customer.

    Cheers, Mikko
  • basixbasix Posts: 486 Superuser
    Hi Mikko

    It seems like this is a bug in mydrive connect (or nav4 software?) that is showing up on several windows installations, mine included (rider 400)

    I'm using a windows 8.1 pro laptop to update my rider. The issue occurs when mydrive connect has to upload multiple larger files to the tomtom. I only had this occur with large map updates, not with mapshare or speedcam updates (until now). Just unplugging the usb cable and plugging it back in will make the update continue from where it had stopped.

    Next time there is a big update, I'll try shutting down the tomtom and perform the update after a fresh boot to see if that changes anything.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi basix,

    Thanks for your input!

    These are best reported to Customer Service as they can see more what's happening in the backend and report further with more details.

    Thanks, Mikko
  • basixbasix Posts: 486 Superuser
    I'd rather not, I don't have the patience left for dealing with customer service ;)

    (That is until the device itself doesn't work or updates fail completely)
  • verheesverhees Posts: 1 [Apprentice Traveler]
    Is there a solution for this problem? I'm kinda lost here.

    I want to install a USA map on a SD card in my GO 5000. Bought the map from the store, but it didn't show up in MyDrive Connect at first. Called Customer Support and they solved this so I could download the map. So far so good.

    After the download MyDrive began to install the map on my device, but was stuck on the "Waiting for device" message for hours.
    I unplugged the device and plugged it back in and MyDrive shows the map is installed on the device, but the device still only sees a Europe map, even after reboot.
    As both maps are taking up storage space I tried to remove the USA map (to reinstall it) and it was stuck again on the "Waiting for device" message. This is when things got really bad.
    After unplugging and plugging the device, MyDrive says the USA map is not on the device (so does the device), but the storage space is still full and I cannot select anything to remove but the speedcam information.
    Eventually I even did a factory reset of the device, which doesn't clear the storage space at all.

    Any idea on how I can clear the storage space again and install the USA map correctly?
  • dhndhn Posts: 33,298 Superusers
    Call support again. They may have to look at the back end on your device to see what is happening.

    Nederland (Holland)
    020 850 1007
    Maandag t/m vrijdag van 9.00 tot 18.00
  • start62start62 Posts: 3 [Neophyte Traveler]
    My experience with the update is also quite troubling, hopefully it will eventually end well
    What I can say is that when it hangs, the only way to restart it is to switch off and restart tomtom
    In some ways, sometimes it works and the update goes on

    And yes, the feedback on what is happening is horrible and by horrible I mean totally unreliable.
    I had the 1:30 hours left indication come up multiple times in the multi hours update process.
    And... no indication of what is actually happening, just "updating'....

    Now, magically it has gone to 3% installation done (it was something like 40%) and just 5 minuted to go, but it is stuck here...
  • dhndhn Posts: 33,298 Superusers

    lunedì-venerdì: ore 09:00-17:30 CET
  • SteinschweigerSteinschweiger Posts: 2 [Apprentice Traveler]
    MyDrive works correctly only with the genuine TomTom USB data cable. Other USB cables are okay for powering your TomTom, and they will even produce the 'You are connected' message on your TomTom when you connect to a PC, *but* the actual data transfer wouldn't work. (I would love to know the technical difference - Mikko, could you let us into the secret?)
  • basixbasix Posts: 486 Superuser
    anyway a good move to remove the intermediary mydrive connect software on the newly announced devices. Please also let us users who have bluetooth enable this option - just show a warning that we only should use if on an unlimited data plan or tethered through bluetooth to a wifi hotspot

  • basixbasix Posts: 486 Superuser
    Updates via Wi-Fi

    Get the latest maps and software for your TomTom GO via built-in Wi-Fi. No computer needed. Your sat nav will notify you when new updates are available - simply connect to your preferred Wi-Fi network and choose what to install from the menu.*

    *We recommend to use a Wi-Fi network with a download speed of at least 30 MB/S, especially when updating maps which can be large downloads."

    30 MegaByte per second? Is that just a disclaimer to prevent users from complaining that it didn't work fast enough?
  • NiallNiall Posts: 10,746 Superuser
    I think that someone in TomTom's advertising department doesn't know the difference between Megabits (Mb) and MegaBytes (MB) (1 Byte = 8 bits) :)
  • arichardarichard Posts: 319 [Supreme Navigator]
    Niall wrote:
    I think that someone in TomTom's advertising department doesn't know the difference between Megabits (Mb) and MegaBytes (MB) (1 Byte = 8 bits) :)

    Maybe it's someone in their software department ? :(
  • Arian viewArian view Posts: 2 [Apprentice Traveler]
    Waiting for device
    MY DEVICE found the 5100, but then got stuck doing the actual software / map updating with “Waiting for device” message for hours.
    Solution use the Official TomTom USB Cable, job done!
  • tallpaul8tallpaul8 Posts: 1 [Apprentice Traveler]
    I had the same problem with a Via 1515 and Windows 10. Not without trepidation, I disconnected the TomTom, waited for the auto-off, then reconnected and the update (computer to TomTom) started. Not exactly bullet-proof software for a consumer item.
Sign In or Register to comment.

Who's Online in this Category0