"Your device is being added" taking a long time

TherickTherick Posts: 3 [Apprentice Traveler]
edited January 31 in MyDrive Connect
Why is my device taking so long to add to my account? this is not the first time that I've run "My Drive" with my TomTom, so I'm not sure why I have to add it again, but since I "have to" my device now it is taking quite a long time. 30 minutes I've been stuck on the "your device is being added" loading screen, and I'm still there, why is this? It is very frustrating.
I have performed a "reset on my TomTom", then loaded "My Drive" and only after the program had finished loading, have I connected to TomTom (Go 6100).
Why is "Your device is being added" taking so long ?

Thank you for any help with this,

Therick

Comments

  • Yak52Yak52 Posts: 2 [Apprentice Traveler]
    I am having the same issue with my Go51 ......It this normal with Tomtom?
  • dhndhn Posts: 32,988 Superusers
    Shouldn't take that long.

    To Yak52, Try a drum reset on the unit by holding the power button about 20 seconds till you hear the drum sounds.

    Support:

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.

    Australia
    1300 135 604
    Monday-Friday:9:00 am to 5:30 pm AEST
  • SCB74656SCB74656 Posts: 1 [Apprentice Traveler]
    Having the same issue - tried the reset and it still won't go beyond "Your Device is Being Added"
  • BasmanIIBasmanII Posts: 1 [Apprentice Traveler]
    Im having the same problem, ive tried restart device, restart pc and now even trying a diferent pc......it keeps on adding the device and nothing happens...someone knows how to fix this? ive been trying for a couple of hours now....
  • Bart-BCNBart-BCN Posts: 1 [Apprentice Traveler]
    It seems to be a problem with TomTom servers, yesterday i was installing new maps on my Go 6100 but today i cannot install maps, i made a reset on my two devices and removed from the account to add again and now i can't add the devices ...
  • wendylois_un66wendylois_un66 Posts: 1 [Apprentice Traveler]
    Similar problem but I'm updating my device and it's got stuck for the last 45 minutes. It's just saying 'waiting for your device' but the actual updating finished after about 30 seconds.
  • dhndhn Posts: 32,988 Superusers
    Too many users reporting the problem for it to be a minor glitch on the user's side. See what if anything TomTom reports tomorrow.
  • Rider400Rider400 Posts: 162 [Renowned Wayfarer]
    Indeed. I experience the same problem
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Thanks for reporting this!

    I've check with our technicians and we're not seeing any unexpected behaviour on our end. As we released new maps last Thursday you're likely just seeing a bit slower response time from our server as many people have been updating their maps this weekend.

    I'd recommend you to try again later. For MyDrive Connect troubleshooting tips, please see this FAQ.

    Should you still be unable to update your device, please contact Customer Service for further assistance. They have access to our backend to see more about what's happening in your particular case.

    My apologies for the inconvenience!

    Cheers, Mikko
  • Yak52Yak52 Posts: 2 [Apprentice Traveler]
    I ended up leaving my device connected all night and when I checked in the morning my device had been updated however the device was not listed on MDC.

    I didn't dare try to add it to MDC.... I just cut my losses and ran.
  • patinipatini Posts: 3 [Neophyte Traveler]
    + 1 my device is being added for infinite time...
    also map update says "Waiting for Device" and device doesn't responds ever.
    I tried everything (reset, hard reset, restart) disaster !
  • dhndhn Posts: 32,988 Superusers
    Try a drum reset on the unit by holding the power button about 20 seconds till you hear the drum sounds.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi patini,

    Your device is successfully linked to your account but the map update seems to be still pending in the queue. This is mostly caused by something interrupting the connection between your device and MyDrive Connect.

    I'd first recommend you to restart your computer and then try again. For further MyDrive Connect troubleshooting tips, please see this FAQ. See especially the section DOWNLOAD/INSTALLATION SLOW/GETTING STUCK.

    Please, post back here if this doesn't help you get things sorted so that we can help you further.

    Cheers, Mikko
  • mmeysenburgmmeysenburg Posts: 1 [Apprentice Traveler]
    This is still happening. I have a VIA 1515 and have never been able to successfully add it to MyDrive Connect. I've tried both Mac and Windows, restarted the computers, hard reset the device, etc. Same behavior every time: stuck on the "Your device is being added" screen for an indeterminate amount of time, and sometimes it comes back to say that I need to add the device again, which leads to the "your device is being added" screen for an indeterminate amount of time... Note that this has happened EVERY time I try to update my device, over the 18 months that I've had the device.
  • dhndhn Posts: 32,988 Superusers
    Perhaps, for the MDC on the PC, completely remove the application using the FREEWARE version of Revo Uninstaller found here:
    http://www.revouninstaller.com/revo_uninstaller_free_download.html

    Then get a fresh copy at tomtom.com/getstarted.

    Install and then connect the device to the computer and start the process over, hopefully with better success this time.

    And you are using the cable that came with the 1515, right?
  • JohnHappy51JohnHappy51 Posts: 2 [Apprentice Traveler]
    I have the same problem. I carried out an update and when it got to 43% it jumped back to 9%. It did this many times.

    So I told the software to forget the device.

    Added the device

    It then went into "Your device is being added" and will not move on from there.

    I have reset the Tomtom. I tried on a windows 10 PC, then a Windows 7 PC.

    Any suggestions would be gratefully received.
  • JohnHappy51JohnHappy51 Posts: 2 [Apprentice Traveler]
    the solution was to clear the cache on the PC hard drive. I found this under myapps/tomtom/cache. (clear cache = delete file in the folder. I also had to reveal hidden folders in order to see the folder myapps). This allowed me to then delete the corrupted map file and then install it again. This first attempt did not work, so I deleted the corrupted map file again, then installed it again. It worked the second time.
  • dhndhn Posts: 32,988 Superusers
    Thanks for your perseverance and feedback.
  • WheatyWheaty Posts: 1 [Apprentice Traveler]
    Hi so I'm trying to set up my TomTom VIA 52 for the first time and it is continuously on this screen for over 10 min now.

    On the TomTom itself it says "Your computer and device are now connected! Use MyDrive Connect to manage your device."... But it won't let me past this screen.

    Please help, thanks in advance.

    ef233b75-c9b4-4757-be81-eddfe748c656.pngef233b75-c9b4-4757-be81-eddfe748c656.png
Sign In or Register to comment.

Who's Online63

bes
bes
Justyna
Justyna
Jürgen
Jürgen
kumo
kumo
Ratso
Ratso
Tarnum1
Tarnum1
titus50
titus50
wihera
wihera
+55 Guests