TomTom Runner demo mode

Orchad
Orchad Registered Users Posts: 2
Apprentice Traveler
edited January 24 in TomTom Sports
I have a TomTom Runner watch and can't seem to get it to move on from demo mode, can anyone help please?

Comments

  • tfarabaugh
    tfarabaugh Posts: 16,935
    Superuser
    Orchad wrote:
    I have a TomTom Runner watch and can't seem to get it to move on from demo mode, can anyone help please?

    Press down and go to Options>Demo and select Off. If it is already off, what makes you think it is in demo mode? You may also need to do a factory reset to fix it. To do a factory reset, make sure the Connect software is running and dock the watch to your computer. The Connect window will open up and you will see a button at the bottom of the window that says "Factory Reset" (on the newer version of MSC, press the gear at the top right and select Factory reset from the next screen). Press it and follow the steps provided, giving the watch the same name and using the same email address. When prompted to register or sign in to MySports, select sign in and use your existing account credentials. It is fairly straightforward and should take less than 5 minutes.

    I hope this helps, please let me know if this answered your question. If it did, please mark it as a solution so others can look for it if they have the same question.
  • Orchad
    Orchad Registered Users Posts: 2
    Apprentice Traveler
    Brilliant thank you, all sorted
  • tfarabaugh
    tfarabaugh Posts: 16,935
    Superuser
    Orchad wrote:
    Brilliant thank you, all sorted

    Glad I could help. When you get a chance please mark my response as a solution so others with the same question can look for it.
  • MTBant
    MTBant Registered Users Posts: 1
    Apprentice Traveler
    Every Time I charge my watch it automatically switches Demo Mode on.
    How do I permanantly switch demo mode off ?
    It is a Multisport watch.
    Thanks
  • tfarabaugh
    tfarabaugh Posts: 16,935
    Superuser
    MTBant wrote:
    Every Time I charge my watch it automatically switches Demo Mode on.
    How do I permanantly switch demo mode off ?
    It is a Multisport watch.
    Thanks

    Go to Settings and select Demo>Off to run off demo mode. It is odd that it is turning it back on, I have never heard of this before. I would try a factory reset and see if that fixes it, as it may just be a glitch in the firmware. Otherwise I would suggest calling Customer Support to see what they can do. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, go to tomtom.com/support, choose Contact, enter the product name and click Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).
  • Kyle Fortune
    Kyle Fortune Registered Users Posts: 1
    Apprentice Traveler
    My Runner 2 does this. Just about to head off and have to mess about with the settings to switch it off. No idea why it even exists, TomTom needs to delete it, or enable it to be removed. It's hopeless.
  • tfarabaugh
    tfarabaugh Posts: 16,935
    Superuser
    My Runner 2 does this, drives me nuts. Just about to head off and have to mess about with the settings to switch it off. No idea why it even exists, TomTom needs to delete it, or enable it to be removed. It's hopeless.

    Once you shut it off, it shuts off for good. If it is turning back on you need to contact Customer Support (but I would do a factory reset first just in case).
  • spells
    spells Registered Users Posts: 1
    Apprentice Traveler
    My runner 3 defaults back to demo mode after every time I charge it. Extremely annoying I agree - I lost part of my first marathon forgetting to turn it off again. Is there a fix?
  • tfarabaugh
    tfarabaugh Posts: 16,935
    Superuser
    Did you try factory resetting the watch?
  • Barbarerik
    Barbarerik Registered Users Posts: 10
    Master Explorer
    I am sorry but that's stupidest think to defeultly turn on demomode guys you are intelligent right? So pleas don't ruin our first contact with our toys. Damet
  • WG5000
    WG5000 Registered Users Posts: 1
    Apprentice Traveler
    I have the same problem and it’s driving me nuts!

    I have to turn off demo mode everytime I want to start an activity.

    Please tell me how to fix this.
  • tfarabaugh
    tfarabaugh Posts: 16,935
    Superuser
    WG5000 wrote:
    I have the same problem and it’s driving me nuts!

    I have to turn off demo mode everytime I want to start an activity.

    Please tell me how to fix this.
    It should only need to be turned off once. Try a factory reset and see if that fixes it, otherwise call Support.