TomTom Runner demo mode — TomTom Community

TomTom Runner demo mode

OrchadOrchad Posts: 2 [Apprentice Traveler]
edited January 2019 in Runner & Multi-Sport
I have a TomTom Runner watch and can't seem to get it to move on from demo mode, can anyone help please?

Comments

  • tfarabaughtfarabaugh Posts: 16,806
    Superusers
    Orchad wrote:
    I have a TomTom Runner watch and can't seem to get it to move on from demo mode, can anyone help please?

    Press down and go to Options>Demo and select Off. If it is already off, what makes you think it is in demo mode? You may also need to do a factory reset to fix it. To do a factory reset, make sure the Connect software is running and dock the watch to your computer. The Connect window will open up and you will see a button at the bottom of the window that says "Factory Reset" (on the newer version of MSC, press the gear at the top right and select Factory reset from the next screen). Press it and follow the steps provided, giving the watch the same name and using the same email address. When prompted to register or sign in to MySports, select sign in and use your existing account credentials. It is fairly straightforward and should take less than 5 minutes.

    I hope this helps, please let me know if this answered your question. If it did, please mark it as a solution so others can look for it if they have the same question.
  • OrchadOrchad Posts: 2 [Apprentice Traveler]
    Brilliant thank you, all sorted
  • tfarabaughtfarabaugh Posts: 16,806
    Superusers
    Orchad wrote:
    Brilliant thank you, all sorted

    Glad I could help. When you get a chance please mark my response as a solution so others with the same question can look for it.
  • MTBantMTBant Posts: 1 [Apprentice Traveler]
    Every Time I charge my watch it automatically switches Demo Mode on.
    How do I permanantly switch demo mode off ?
    It is a Multisport watch.
    Thanks
  • tfarabaughtfarabaugh Posts: 16,806
    Superusers
    MTBant wrote:
    Every Time I charge my watch it automatically switches Demo Mode on.
    How do I permanantly switch demo mode off ?
    It is a Multisport watch.
    Thanks

    Go to Settings and select Demo>Off to run off demo mode. It is odd that it is turning it back on, I have never heard of this before. I would try a factory reset and see if that fixes it, as it may just be a glitch in the firmware. Otherwise I would suggest calling Customer Support to see what they can do. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, go to tomtom.com/support, choose Contact, enter the product name and click Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).
  • Kyle FortuneKyle Fortune Posts: 1 [Apprentice Traveler]
    My Runner 2 does this. Just about to head off and have to mess about with the settings to switch it off. No idea why it even exists, TomTom needs to delete it, or enable it to be removed. It's hopeless.
  • tfarabaughtfarabaugh Posts: 16,806
    Superusers
    My Runner 2 does this, drives me nuts. Just about to head off and have to mess about with the settings to switch it off. No idea why it even exists, TomTom needs to delete it, or enable it to be removed. It's hopeless.

    Once you shut it off, it shuts off for good. If it is turning back on you need to contact Customer Support (but I would do a factory reset first just in case).
  • spellsspells Posts: 1 [Apprentice Traveler]
    My runner 3 defaults back to demo mode after every time I charge it. Extremely annoying I agree - I lost part of my first marathon forgetting to turn it off again. Is there a fix?
  • tfarabaughtfarabaugh Posts: 16,806
    Superusers
    Did you try factory resetting the watch?
  • BarbarerikBarbarerik Posts: 10 [Master Explorer]
    I am sorry but that's stupidest think to defeultly turn on demomode guys you are intelligent right? So pleas don't ruin our first contact with our toys. Damet
  • WG5000WG5000 Posts: 1 [Apprentice Traveler]
    I have the same problem and it’s driving me nuts!

    I have to turn off demo mode everytime I want to start an activity.

    Please tell me how to fix this.
  • tfarabaughtfarabaugh Posts: 16,806
    Superusers
    WG5000 wrote:
    I have the same problem and it’s driving me nuts!

    I have to turn off demo mode everytime I want to start an activity.

    Please tell me how to fix this.
    It should only need to be turned off once. Try a factory reset and see if that fixes it, otherwise call Support.
Sign In or Register to comment.

Who's Online in this Category0