Blue & Me- Fails to connect/pair with the Fiat car bluetooth — TomTom Community

Blue & Me- Fails to connect/pair with the Fiat car bluetooth

fiatdriverfiatdriver Posts: 2 [Apprentice Traveler]
edited January 2019 in Built in car navigation
I recently purchased a brand new Fiat Punto which came with a tomtom blue and me 2 live which plugs in to the dock on the dashboard. I have followed the instructions and I cannot get the Bluetooth to pair with the car. All I get is a message saying " blue and me cannot be found". I've taken this back to fiat who said it's not compatible with Fiat software and the only way to connect is via a phone. I find it hard to believe they would supply a satnav with a brand new car that is not compatible. Has anyone else been able to pair their satnav with a Fiat? Thanks

Comments

  • NiallNiall Posts: 10,854
    Superuser
  • fiatdriverfiatdriver Posts: 2 [Apprentice Traveler]
    Yeah, that's when it says blue and me can't be found. The fiat dealer is telling me it won't find it because it's not compatible!
  • NiallNiall Posts: 10,854
    Superuser
    @fiatdriver

    Think it is time to get tough with the dealership, they should be providing a compatible device and fixing any problems, threaten them with going to trading standards. It is their problem not TomToms
  • Dazz77Dazz77 Posts: 2 [Apprentice Traveler]
    Hi. Have you managed to fix your problem as I have the same issue
  • CoastingCoasting Posts: 1 [Apprentice Traveler]
    We have the same problem with a brand new new Doblo (Fiat) it searches Blue&Me, can't locate the vehicle. I've upgraded the software on the tomtom but to no avail.
    From the messages in the above feed it looks like it is a Fiat (Dealership) problem.
  • DaiAnotherDaiDaiAnotherDai Posts: 1 [Apprentice Traveler]
    And we have exactly the same problem with a Fiat TomTom Blue & Me 2 unit (bought from the Fiat dealer) and my daughters Fiat 500. The garage is clueless and just say "Well it should work mate - you're doing everything correctly"! Updated the TomTom software, rest it, just says Blue&Me can't be found".
  • Agaman834Agaman834 Posts: 1 [Novice Seeker]
    I have same problem with my fiat 500 2010 model. Blue and me won't pair with tomtom. Screen remains find blue and me and no car symbol
  • Tier4Tier4 Posts: 4 [Apprentice Seeker]
    I have the same problem with my Fiat Qubo, does anyone have a solution?
Sign In or Register to comment.

Who's Online in this Category0