New software v10.855 for Mazda Navigation System NB1 available for download

MikkoK
MikkoK Retired TomTom Employee Posts: 23,905 Retired Community Managers and Staff
edited January 2019 in Built in car navigation
Hi all,

We've just released a new software update v10.855 for the Mazda Navigation System NB1 devices and it's available for download via TomTom HOME.

[h3]What's new?[/h3]
  • Fixed issues related to speed cameras
  • Fixed an issue that required re-enabling Live Services after every reboot
  • Fixed issues related to speech recognition (ASR)
  • Application is now robust against corrupt 'MapUserPatch.dat' file

Drive safe! :D

Cheers, Mikko
«1

Comments

  • dhirenmehta
    dhirenmehta Registered Users Posts: 2
    Apprentice Traveler
    Hi Mikko,

    Has there been any poor feedback on the new 10.855 software? it seems to have killed the TomTom in my Mazda CX-5.

    I noticed today that there were speed camera's missing from my system, so I attempted an update of the live services.

    I saw that there was a system update (mentioned above) which I thought i would apply first before attempting any other updates.

    Now TomTom refuses to start.

    Have attempted multiple things, formatted the memory card to re-install from scratch. Multiple different memory cards, on multiple Windows OS's. I now have a redundant TomTom in my car, please help! Can I downgrade somehow??
  • Michieltje
    Michieltje Registered Users Posts: 2
    Apprentice Seeker
    Same here. Tomtom restarting every time I start the car and IF tomtom manages to get past the "restarting tomtom" logo, it is not responsive and crashes.
  • pfm57
    pfm57 Registered Users Posts: 1
    Apprentice Traveler
    i have cx-5(2013) , 10.855 installed. looks ok. although as i just renewed my subscription to live services it doesnt seem to pull through yet. also it always takes an age for live services to boot up and advise status.
  • Michieltje
    Michieltje Registered Users Posts: 2
    Apprentice Seeker
    update: installed an new map (Europe, 3.7GB) together with the navcore update. It looks like the nice & fanc SD card (SanDisk 16GB extreme plus) that I bought for that purpose was the issue. Have now installed the map etc on a basic class 4 SD card and it appears to work.
    Going on holiday tomorrow, so fingers crossed that it works.
  • lcampana
    lcampana Registered Users Posts: 1
    Apprentice Traveler
    I´ve just installed the new version and some crashes come up in navigation state. By the way, the voice recognition in spanish is very poor, useless
  • dhirenmehta
    dhirenmehta Registered Users Posts: 2
    Apprentice Traveler
    Any advice from anyone on my particular situation? Nav button with SD card inserted does nothing; no beep, not TomTom logo - Nothing. Have formatted and retried multiple different cards so I don't think it's the cards. Even tried TomTom Home on different versions of Windows to install the novacore v10.855 but still no joy.
  • Samim
    Samim Registered Users Posts: 1
    Apprentice Traveler
    Hello Mikko & all,

    Any change to get the Mazda NB1 TMC operational, while making the next upgrade? Actually, I mean that to get the TMC operational while driving here in Finland, as the NB1 TMC start working fine just after exiting ferry in Sweden. TMC didn't work with 10.854 and it's still not working with the upgraded 10.855 (in Finland).

    Sami
  • c0ntax
    c0ntax Registered Users Posts: 1
    Apprentice Traveler
    I just tried to update my TomTom to the 10.855 version but it's telling me that there's not enough room on the device to install it (It's the 4gb SD card that came with the car/nav) and that the only way to make room for the update is to delete all the maps! (That's the only thing that's deletable that will free up the 80Mb of space I need to make for the update).

    Any suggestions? DO I need to buy a bigger SD card (that seems like it's going to create issues) or is there a way of compacting the data on the card?
  • Derwan
    Derwan Registered Users Posts: 43
    Apprentice Traveler
    Since updating my software to 10.855, the following happens every time I reinsert the SD card (after updating GPSQuickFix):
    • All favourites are deleted
    • The units reset to miles instead of kilometres
    • The volume resets to 10. (I usually have it on mute as I don't like the speed/red light camera warnings. Is there any way to turn these off?)
    • Recent destinations are cleared
    • I am prompted to authorise information sharing. (I have set it to not prompt.)

    Are others experiencing this or is it just me? Perhaps I need to reformat the card? (I forget how to do it, but will look it up if necessary.)
  • Derwan
    Derwan Registered Users Posts: 43
    Apprentice Traveler
    Two months since the update and we're still losing settings every time we take the SD card out. Several other threads here have been created about it but still absolutely nothing from the TomTom rep to address it. Poor form!!
  • Julian
    Julian Retired TomTom Employee Posts: 2,158 Retired Community Managers and Staff
    Hi Derwan,

    sorry to hear you are still facing this issue. :(

    This is not a general issue, so I assume the issue can be traced back to either:

    - the SD card being "corrupted", meaning it cannot change / delete / create items on the SD Card anymore
    - the file that stores this kind of information is broken and needs to be replaced

    So you can try another SD card, or simply delete the "loopdir" folder on your SD card, then turn on the car without the SD card, start the Navigation, then insert the SD card. Your NB1 will then replace that file. If everything goes well, your settings should be stored then again.

    Please let me know if this has helped!

    Regards

    Julian
  • Derwan
    Derwan Registered Users Posts: 43
    Apprentice Traveler
    Julian wrote:
    Hi Derwan,
    Please let me know if this has helped!

    Thanks Julian. It's nice to finally have some assistance on this.

    I deleted the loopdir folder as described and had the unit re-create it. I removed the card again, did an update of GPSQuickFix and the settings appear to have remained when I reinserted.

    I won't get too excited yet as the settings didn't vanish EVERY time I took the card out. However it was MOST times so it's looking hopeful.

    If it happens again, I'll grab a new SD card.

    I'm still having the issue where TomTom HOME says the maps are out of date even 'though they have been updated. This is less of an issue because I know the maps have been updated (by checking the version number). It just means that Mapshare corrections aren't installed - which I can live without.
  • Klaus Barfod
    Klaus Barfod Registered Users Posts: 2
    Apprentice Traveler
    The Device can't make a connection at startup to Live Services, (witch is normal because GPRS are not connected yet.) This makes planning a route fails at startup. After red error screen for missing Live Services shows up, and ok is chosen, planning a route can be made.
    After ca. 5min the connection to Live Services is ok.
  • Derwan
    Derwan Registered Users Posts: 43
    Apprentice Traveler
    Well the issue wasn't resolved with deleting the loopdir folder. I guess I'll try a new SD Card.

    However, given the number of people who have reported this issue (in other threads) and that it happened after updating the firmware, my suspicion remains that the firmware update has somehow caused this.
  • Dein
    Dein Registered Users Posts: 27
    Outstanding Explorer
    Hi

    You need to choose a smaller portion of EU like me, I use Europe_Zone_7 which will fit into my 4GB SD
  • Dein
    Dein Registered Users Posts: 27
    Outstanding Explorer
    Hi Dervan,

    I finally got a solid solution to the deleted Favorites tonight, so if you still need help on this one, please speak up.
  • Derwan
    Derwan Registered Users Posts: 43
    Apprentice Traveler
    The reason I ordered a 4GB card is because that's all that's guaranteed to work in this device. I'm in Australia and have no space issues.

    If you have a solid solution, I'd love to hear it. :)
  • VTMazda 6
    VTMazda 6 Registered Users Posts: 1
    Apprentice Traveler
    Hi Mikko,

    I have made the upgrade today to v10.855, and I have a big problem. My created POI categoy is missing. I have made an backup before the upgrade and a restore after the upgrade. I have tried everything. The problem is that I had more than 50 POIs in my POI category. They are all missing now and I am very MAD about this, because these POIs are a work of 3 years!!!!!!!!!!!
    Please give me some good News because I go crazy!!!!!!!!!!!!!!!!!!!!!!!!!!! I dont wont to spend hours in my car to write them all in again !!!!!!!!!!!!!!!!
    Thanks
  • Derwan
    Derwan Registered Users Posts: 43
    Apprentice Traveler
    VTMazda 6 wrote:
    Hi Mikko,
    My created POI categoy is missing.

    TomTom really botched this update. It sounds like they did little/no testing. Then they blamed my "corrupt" card for the issues. (No - a brand new card didn't fix them. Maybe I should ask TomTom to reimburse me!)

    Strangely though, I haven't had any issues with custom POI's going missing. It's only been favourites, recent destinations, settings, etc.

    3 months on and there is still no fix from TomTom.
  • SM57
    SM57 Registered Users Posts: 5
    Master Traveler
    The whole think is a disgrace. I have had a relatively operational sat nav until this last update. All my settings have disappeared, the speed cameras now operate for both side as of the carriageway where there are uni directional camera, I am asked to select the Europe map on boot up and the navigation voice activation feature has become useless. In addition to this some postcodes are not recognised as are many numbered building in various streets. My car is now 3 1/2 years old and I paid a lot of money to have the nav option. I have not been able to keep favourites for some time but for the first time ever today the system has crashed several times whilst driving. Don't TomTom have a duty or commitment to customers who have purchased their products? They should be forced by Mazda to get this right. I would have second thoughts about buying Mazda ever again. Any help would be gratefully received.
  • Dein
    Dein Registered Users Posts: 27
    Outstanding Explorer
    Hi,
    Do you know where to find your backup, and where you POI's are stored?
  • SM57
    SM57 Registered Users Posts: 5
    Master Traveler
    Hi, Yes I have a very recent back up (2 days ago) and I have some backups on another device from around 12 months ago. I haven't a clue however where the POI's are stored. I am using a mac with OS X 10.11.6. The TomTom home software is not very good and in order to add a crucial update, I usually have to download the latest version and undertake a fresh installation each time which is a real pain. Following on from the hassle of the system crashing, I have removed (yet again) the 'loopdir' folder and rebooted the disk in the vehicle which seems to have mildly improved the state of affairs for the moment. Strangely however it still doesn't recognise numbers at a particular postcode and I have to re input all of my settings and warnings each time I open TomTom Home when the disk is inserted into my computer. My subs for live services have just expired but I don't have sufficient confidence in this system to pay for another years worth of hit and miss navigation.
  • Dein
    Dein Registered Users Posts: 27
    Outstanding Explorer
    Hi SM,

    Ok two things:
    1. I'm using the Mazda NB1 Live EU (so I suppose we're using same version here)
    2. I've done quite a bit of investigation of the whole SD card, and more over the loopdir

    If we're on same type, then please have a look at my reply here: https://en.discussions.tomtom.com/built-car-navigation-25/mazda-nb1-latest-update-108552319141-1011690/index1.html#post1127383, where you'll get a close look into the loopdir.
    I'll get back to you on the POI's and their location.

    BR Bjarne
  • SM57
    SM57 Registered Users Posts: 5
    Master Traveler
    Many thanks for this. Yes, I think its the same version. Mine is 'Europe 2014 KDS1 66 EZ1B' (thats what is says on the SD card anyway). I have already looked at your fix... not implemented it yet - just a bit concerned that I can make it happen on my mac. Did you create this fix through a pc or mac?
This discussion has been closed.