Sports Connect- can't open on MAC 10.6.8 — TomTom Community

Sports Connect- can't open on MAC 10.6.8

SUPerSUPer Posts: 1 [New Traveler]
Hi,

I have a new Multi-Sport and I have a Mac running OSX Ver. 10.6.8. I tried installing MySports Connect but received a message saying app can't be opened because of a problem (although the app seems to be installed). I read through the TomTom forums and found that perhaps I needed to install an older version of the app for 10.6.8. I tried reinstalling but no luck, I receive the same message. Funnily enough, I was able to install TomTom Home which I found out doesn't recognize my watch.

The text below was part of the message I received.

Dyld Error Message:
Symbol not found: __xpc_type_dictionary
Referenced from: /Library/Frameworks/iTunesLibrary.framework/Versions/A/iTunesLibrary
Expected in: /usr/lib/libSystem.B.dylib
in /Library/Frameworks/iTunesLibrary.framework/Versions/A/iTunesLibrary

I have been having problems opening iTunes for a long while now. Could this be the problem?

Appreciate your feedback. :)

SUPer

Comments

  • Stuart McDonaldStuart McDonald Posts: 759 [Exalted Navigator]
    Hi. That problem is definitely related to your iTunes installation. I would hope that re-installing it would resolve that problem

    https://support.apple.com/kb/DL1774

    has a download for iTunes on 10.6.

    Once that is resolved you may still have problems. See this post for information

    https://en.discussions.tomtom.com/mysports-connectappswebsite-389/mysports-connect-v202-available-for-download-989950?postid=1090742

    Regards,

    Stuart.
  • zeeleezeelee Posts: 3 [Neophyte Traveler]
    I could not get TomTom MySport Connect to work on a Mac with Snow Leopard (10.6.8).
    However the new TomTom Sports mobile apps works on my iPod Touch (OSX 9)

    With the mobile apps (TomTom Sports), I can download all the activities and see various activities data (GPS, Metric ... etc!
  • Stuart McDonaldStuart McDonald Posts: 759 [Exalted Navigator]
    Hi. I believe most 10.6 OSX users can get Sports Connect to work if they minimise and restore the window (it starts off completely blank).
    Regards,
    Stuart.
  • zeeleezeelee Posts: 3 [Neophyte Traveler]
    Hello Stuart
    I could not get it to work. And I read multiple threads. The method that you mention seem to refresh the screen, but my runer cardio watch would not connect. I could not register or download activities. The watch became useless once the memory filled up. It was either throw the watch away or bit the bullet and try the new tomtom sport phone apps. The phone apps WORKS! I am able to register, download activities and see the graph of my activities! On both the phone and Computer! All without the workaround of minimizing and restore!

    The other issue was uninstalling the tomtom mysport software. I could not delete it from the trash. There must be a process running, even after quitting the application. Again, I read a few threads. One person suggest restarting the computer, but that did not help. Finally, I started up the MAC in the "GUEST" account and I was able to delete the tomtom mysport connect apps. I believe, the "GUEST" account does not load any application at startup. I believe starting the computer up in the "SAFE MODE" would also keep applications from loading at startup.

    Thanks for all your help. I read many of your helpful threads.
    BTW: the iPhone apps (tomtom sports) tends to freeze up after deleting an activity.
    Could be my legacy iPod touch 5th generation running OSX 9.3.
    No problems deleting activities from the MAC (10.6.8) and using the tomtom sports interface!:cool:
Sign In or Register to comment.
0

Who's Online in this Category