Can't import routes (gpx or POI) with mydrive on MAC — TomTom Community

Can't import routes (gpx or POI) with mydrive on MAC

pgreenpgreen Posts: 7 [Master Explorer]
Hi All, I'd appreciate some help with the above. I have no issue connecting to the device via mydrive on my iMac or updating the system and maps etc. The problem is there doesn't appear to be any way to import routes or poi's via mydrive? All of the previous comments I've found seem to relate to menu's and options I just don't seem to have? At present the only way I am able to get gpx files onto my rider 410 is via the web browser portal and then its only possible to upload one gpx file at a time and no poi's? These then sync to the 410 but I'd really like to be able to use the mydrive app and be able to load in poi's as well. Any help much appreciated. For ref... I'm running a new iMac running El Capitan 10.11.5 and latest version of mydrive. If when the device is connected I click on "import routes" then the device then shows as disconnected within mydrive and there appears to be no options anywhere to do the import. If the device is connected within mydrive i'm not seeing any option to import routes. I have read about loading files onto a microSD card. I have one installed but when I connect this to the mac and try to copy routes onto it it generates a not enough space error despite there being plenty of space. I'm guessing that this may be a formatting issue as when it was first installed in the device I chose "maps" as its default but not sure why that might preclude me using it for routes as well? If so it seems a very clunky way to handle additional space? Thanks in advance for any and all assistance! :)

NB I can import gpx & POI's via the browser mydrive... my questions above relate to the app. I'm hoping the app will allow multiple batch imports? And manage the routes easier, if I can get it to work! :) . Thanks

Additional NB! ;) Its seems all my issues are because I simply do not have the "Manage community content" menu in the mydrive apple menu bar.... The other three menu options are there... Open mydrive connect, Setting and Quit but no manage content? There's no mention of this feature not being available on a mac?

Comments

  • pgreenpgreen Posts: 7 [Master Explorer]
    Thanks for that info, much appreciated. Although I would say that TomTom need to update their sales blurb because you can't manage your content with the mydrive app on a mac like they say. You obviously need a third party piece of software to achieve that full functionality. That should be made clear as its pretty misleading at the moment. Also I'm not sure it actually works anyway... copied across 6 gpx files no problem.... but having selected them on the 410 to be imported its since just been hanging on importing tracks screen for 10 minutes so far. Very clunky and it would seem not actually usable anyway. Pretty disappointed with the connectivity on this device, especially having been assured it had these features on a mac.
  • basixbasix Posts: 486
    Superuser
    Can you try the mydrive.tomtom.com web application with your gpx files? assuming you are logged in to your live services on the rider, the files you upload there should appear on your device shortly after
  • pgreenpgreen Posts: 7 [Master Explorer]
    Yep, I've tried that and it works but only with one file at a time which is tedious if you have multiple gpx files to upload or manage. Also it appears using the Android app to be able to copy content via USB to the rider 400 doesn't work with POI's at all. The files copy but the device doesn't import them. Again I can import a POI via the web portal but that doesn't allow for BMP's to be imported so I lose the functionality of being able to have the custom icons for POI's. I really think they need to update their feature list for this product/software when used on a mac.... It just doesn't work as advertised. And ref the gpx files imported via the android linking app.... it appears the 400 just hangs on importing indefinitely. I clicked out of that screen and the routes seem to have imported but again its all very clunky and buggy. On a mac it just doesn't work as described and there are features that are supposed to be there that don't work at all. Not a problem if those limitations were made clear as you make your purchasing decision accordingly but a real problem when the product is advertised as having them!
  • basixbasix Posts: 486
    Superuser
    Haven't tried it myself this way but perhaps if you go to 'my tracks/my routes', and send all your gpx files over bluetooth, it might also just work.

    I have done it the other way, send a recorded track from the tomtom to my android phone.
  • pgreenpgreen Posts: 7 [Master Explorer]
    sorry but I'm not sure what you mean? probably me just being dense but I have an iPhone 6 which connects fine to the rider 410 and I have gpx and OV2 and BMP files on my iMac I'd like to send across to the rider 410. at the moment i can send individual gpx files and OV2's to the device via the web portal and that syncs ok but doesn't allow for bmp's or multiple batch uploads. I can copy gpx files to the device via your suggested 3rd party app "android file transfer" and that allows for multiple gpx files to be sent across but the 410 hangs on importing them.. although it appears they do import but the screen just hangs until you click out of it... so no way of knowing if they have successfully fully imported or not. the app also doesn't seem to work for OV2's or BMP's. the 410 just seems to ignore them. Not sure what you're suggesting above? Sorry and thanks for your help on this.
  • basixbasix Posts: 486
    Superuser
    BMP files are not supported anymore. OV2 only through the mydrive web app as far as I know.

    I just tried it with my android phone and you can also send gpx files in bulk via bluetooth, although it appears to hang on the 'importing tracks' screen like you're having. You can just click out of it like you said, and return to see that the tracks have really been loaded. Try searching for bluetooth file transfer mac

    64ffa828-65ae-48e5-b140-0b6c371ac443.pngcb2f6405-182a-4e90-96b4-37d115dee586.png07309c86-80f1-4fa2-a3db-b0f083dc9cd8.png

    Dear moderators, another bug: 'importing tracks' screen keeps hanging, the tracks seem to be imported though. Read topic for more details.

    2105f67e-56e3-4d55-978f-e0821e511779.png
  • pgreenpgreen Posts: 7 [Master Explorer]
    Thanks Basix, sadly my language skills are a little lacking but I get the idea.... from what you've described its basically going to get me the same functionality as the usb connection and using the android file transfer app as you are seeing the same hanging behaviour. Really appreciate your help on this....
  • pgreenpgreen Posts: 7 [Master Explorer]
    Also another little annoyance is gpx's loaded via the usb android file transfer app don't show up in the list on the mydrive web portal. This means you can't rename them either? Not great if you are trying to organise a large number of gpx's.
  • basixbasix Posts: 486
    Superuser
    another one for the moderators:
    - Enable two-way sync so routes on the device are also available in the mydrive web app
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi pgreen,

    Welcome to the forum!

    I see that basix has done a great job helping you getting this sorted :D A couple of things I'd like to add:

    Please note, that MyDrive Connect is only used for updating your device and managing maps and services on it. Routes and destinations are synced with MyDrive. For more information and troubleshooting tips for MyDrive, please see this FAQ.

    As basix has already mentioned, you can also share routes from your device via Bluetooth or SD card. This is instructed in the user manual.

    Since the latest software update you can now also export GPX tracks from your device to MyDrive. Please, see Update 7 in the above FAQ.

    Cheers, Mikko
Sign In or Register to comment.

Who's Online in this Category0