Speed cameras won't update

bedpostbedpost Posts: 1 [New Traveler]
edited January 29 in Archived Discussions
I have a One second edition for which I have just bought a renewal of the speed camera subscription. I cannot install them. I have the latest version of Home, I have followed all the instructions in FAQs to delete the cameras from the device and my computer and tried to reinstall but I just get a message that the download was interrupted because the file is invalid(archive file). There are no antivirus or firewalls preventing access, I updated the map successfully and can get Map share corrections with no problem. I have tried to contact support to get a refund but I get sent round in circles on the website. Tom Tom say my device is legacy and unsupported. The support link in my receipt e-mail takes me to the Dutch site. Changing it to English gets me nowhere. What do I do now?

Comments

  • BurgoBurgo Posts: 1 [Apprentice Traveler]
    I seem to have the same problem updated subscription through paypal so I have proof of purchase but no update from TomTom so some thing has gone wrong and it must be from there end
  • HEYGIDDAYHEYGIDDAY Posts: 1 [Apprentice Traveler]
    Hi I have the same problem as you . Like you I have PayPal on my side I have done all TomTom has said still cant download .
  • CiedricCiedric Posts: 13 [Legendary Explorer]
    I'm having the same issues even with the lifetime update. It will update for a couple of seconds but it won't finish it.

    https://en.discussions.tomtom.com/mydrive-connect-apps-474/wont-update-998855/index1.html#post1071197
  • BinkyminxBinkyminx Posts: 1 [Apprentice Traveler]
    Yep paid for update and still no speed camera loading keeps failing no matter what happens and this is the second device this has happened with wont be getting another TOM TOM or recommending it.
  • Les RLes R Posts: 2 [Apprentice Traveler]
    Same problem with me, paid for live services update through Paypal on 16.04.2016 and have invoice from Tomtom stating paid, but still no active services. Have been using for 7 years without any problems until now.
  • NiallNiall Posts: 10,474 Superuser
    Contact Customer Service to sort your subscription out

    CS United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
    Help others identify useful content :- - If someone posted something that was helpful? Click the Like button :thumb_up:
    If someone answered your question? Answer yes to "Did this answer the question? Yes · No"
  • Les RLes R Posts: 2 [Apprentice Traveler]
    Thanks Niall, will try them.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Thanks for reporting your issues!

    Unfortunately, we've had some technical problems with delivering speed camera updates. However, last Tuesday cameras were offered for all devices again :D

    We're very sorry for the inconvenience this has caused you and thank you for your patience!

    Cheers, Mikko
  • rdavisrdavis Posts: 2 [Apprentice Traveler]
    My XXL540 will only update Mapshare. Speed cameras do not update. My map is Eastern US & Can V965.7283 I have not been able to get updates for months. It is the same problem described above. Can anyone help?? :(
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi rdavis,

    Welcome to the forum!

    The above-mentioned issue with Speed Cameras not offered has been solved last week already :D

    You Speed Cameras subscription seems to have expired in February which is probably why you're not getting any updates for them.

    v965 is the latest map for your device. For more information about the new v970 maps, please see here.

    For further questions regarding your subscriptions, please contact Customer Service.

    Cheers, Mikko
  • rdavisrdavis Posts: 2 [Apprentice Traveler]
    My unit cam with "free" maps AND speed cameras for life. I had a similar speed camera issue before and the tech gave me a subscription update as a work around. How do I get my free updates back?
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi rdavis,

    Sorry for my late reply!

    Customer Service can best help with your subscriptions.

    Cheers, Mikko
  • Mr.BuzzMr.Buzz Posts: 2 [Apprentice Traveler]
    Hi MikkoK,
    I have just run an update on my 5100 but unchecked the speed cameras. then I updated the speed cameras and it has stopped at 71%!
    Has the issue really been fixed? Do I need to reboot my TomTom first?
  • Pete CockcroftPete Cockcroft Posts: 5 [Apprentice Traveler]
    94ff38f1-2ff4-4daf-a814-cb12df2d6069.png
    We have issues with speed cameras for quite some time now. The issue was sorted and then for some reason the speed cameras just stopped working - we had not tried to update anything, simply used the device which, until last week had been working fine.

    We have Northern Europe maps installed would it make any difference if we changed to Western European as we are in UK and that is the only place we are going to be driving.

    The image shows an error message that has been displayed every time the device is connected.

    We have uninstalled cameras from both the device and the computer, reinstalled and enabled alerts. We keep testing by driving past known speed and visible speed cameras in our area but they still do not work.

    We have an active account. The file size for the speed cameras on the device is 352 KB, Version No. 73369. Do we have the correct file?
This discussion has been closed.

Who's Online29

29 Guests