App stürzt seit Kartenupdate gleich nach dem Start ab. — TomTom Community

App stürzt seit Kartenupdate gleich nach dem Start ab.

AlexMaliAlexMali Beiträge: 20 [Master Explorer]
Ich habe heute früh ein Update der Karte gemacht.
Seit dem stürzt die App immer gleich nach dem Start ab.
Man sieht noch kurz die Straßen und gespeicherten Orte, dann startet die App neu.
Das wiederholt sich endlos.

Woran liegt das?

Beste Antwort

«134567

Antworten

  • hajuehajue Beiträge: 1,908 Superuser
    Hallo @AlexMali ,

    ich habe leider die gleiche Erfahrung machen müssen. Habe bei meinem Galaxy S8 mit aktueller Software die Europa Karte heruntergeladen. Beim Strte der App lädt die Karte und dann stürzt die App sofort ab und startet neu. Das läuft dann in einer Endlosschleife. Auch die Neuinstallation der App und eine andere Karte D-A-CH hat nicht gebracht.
    Vielleicht wissen ja @Jürgen oder @Justyna hierzu etwas mehr?

    Beeindruckend ist, dass einige User hier, die ein Navi benutzen, nach dem Kartenupdate auch von ähnlichen Problemen berichtet haben. Ich gehöre leider mit meinem GO5000 auch dazu.

    Gruß
    Hans-Jürgen
  • JürgenJürgen Beiträge: 5,088 Community Manager
    Ist die Karte intern oder extern gespeichert? Hier auf dem Galaxy S8 startet die App mit BeNeLux 10.35 ganz noremal. Ich installier mal DACH.
  • AlexMaliAlexMali Beiträge: 20 [Master Explorer]
    Karte (DACH) ist auf externer SD Karte gespeichert.
  • DagobertDagobert Beiträge: 3,947 Superuser
    bearbeitet 25. September
    Bei mir startet die App auch normal. ( Karte Europa aktuallisiert)

    App Version: 1.17.9 release/1.17 (2133)

    Galaxy S8, Android 9. Hatte noch am 22.09. ein System Update.

    Habt ihr auch das Handy neu gestartet...?

    Ich wurde so probieren:

    Die App deinstalieren, danach Handy neu starten, dann die App neu installieren und sich wieder anmelden.
  • AlexMaliAlexMali Beiträge: 20 [Master Explorer]
    Ich glaub ich hab noch keine App so oft neu installieren müssen wie diese. :s
  • JürgenJürgen Beiträge: 5,088 Community Manager
    DACH ist installiert auf Galaxy S8 und die App läuft. Könnt ihr die Karte löschen und noch einmal herunterladen?
  • hajuehajue Beiträge: 1,908 Superuser
    bearbeitet 25. September
    Hallo @Jürgen ,

    Karte Europa gelöscht, Handy neu gestartet, App gestartet, Karte D-A-CH heruntergeladen. App gestartet, App stürzt ab, App startet neu, usw. usw.
    Merkwürdigerweise kommt man bei der App ins Menü und sieht dann durchschimmernd auch die Karte mit Traffic. Sobald man aus dem Menü raus geht, stürzt die App ab und die Schleife startet wieder.

    Gruß
    Hans-Jürgen

    Nachtrag: Habe mal unterschiedliche Bildschirmauflösungen probiert. Verhalten ändert sich nicht.
  • JürgenJürgen Beiträge: 5,088 Community Manager
    Welche App-Version ist installiert, 1.17.8 oder 1.17.9?
  • AlexMaliAlexMali Beiträge: 20 [Master Explorer]
    1.17.9 release/1.17 (2133)
  • JustynaJustyna Beiträge: 3,595 TomTom Moderator
    Hallo zusammen,

    Wir haben ein altes Workaround für Forum Benutzer, bei denen die App eigenfroren bleibt. Das hat immer geholfen und wenn ich mich gut erinnere, ist es von @bjmawe:

    1.) Einstellungen -> Anwendungsmanager -> Go (Mobile App) -> erst App anhalten, danach Cache löschen, danach Daten löschen.
    2.) Einstellungen -> Anwendungsmanager -> Go (Mobile App) -> App deinstallieren
    3.) Sowohl im Gerät als auch auf der SD-Karte unter -> Android -> Android/data/com.tomtom.gplay.navapp löschen
    4.) Smart Manager -> Speicher -> Unnötige Dateien -> löschen (das löscht sämtliche temporären Dateien)
    5.) Mobiltelefon aus-/und wieder einschalten (Neustart)
    6.) Nach Neustart Google Play Store öffnen und die Go mobile App neu herunter laden und eine erste Installation versuchen. Klappt es bereits jetzt, ist hier Schluss; falls nein, dann unter Punkt 7 weiter
    7.) Einstellungen -> Anwendungsmanager -> Go (Mobile App) -> erst App anhalten, danach Cache löschen, danach Daten löschen.
    8.) App starten ... und dann sollte es direkt laufen.


    Momentan versuchen wir den Fehler zu reproduzieren..

    Gruß,

    Justyna
  • JürgenJürgen Beiträge: 5,088 Community Manager
    Ich habe es mit beiden Versionen versucht und kann das Problem nicht reproduzieren. Nochmals meine Frage: Ist die Karte intern oder auf einer Speicherkarte installiert?
  • AlexMaliAlexMali Beiträge: 20 [Master Explorer]
    Wie gesagt, bei mir ist die Karte auf einer externen SD Karte.
  • JürgenJürgen Beiträge: 5,088 Community Manager
    @hajue Ist sie bei Dir auch extern gespeichert? Ich müßte dann einen unserer Tester bitten, ob er es reproduzieren kann.
  • hajuehajue Beiträge: 1,908 Superuser
    Hallo @Jürgen ,

    App-Version 1.17.9 release/1.17 (2133).
    Karte auf externer Speicherkarte installiert.

    Gruß
    Hans-Jürgen
  • DagobertDagobert Beiträge: 3,947 Superuser
    bearbeitet 25. September
    Bei mir ist die Karte Intern gespeichert. Probiere mal die Karte noch mal zum downloaden wenn du keine Micro SD Karte im Handy hast. Wenn es klappt liegt es dann am Externen Speicher...
  • AlexMaliAlexMali Beiträge: 20 [Master Explorer]
    Die alte Karte vor dem Update lag auch auf der externen Mikro SD Karte und hat funktioniert. Erst seit dem Update habe ich die Probleme.

    Ich werde es heute Abend erst mal mit dem Workaround probieren.
  • hajuehajue Beiträge: 1,908 Superuser
    bearbeitet 25. September
    Hallo @Jürgen ,
    hallo @Dagobert ,

    ich habe jetzt mal die App deinstalliert und die Speicherkarte entnommen. Danach die App neu installiert und D-A-CH heruntergeladen.
    Die App startete danach (ohne eingesetzte Speicherkarte) problemlos.

    Smartphone ausgeschaltet und Speicherkarte wieder reingesteckt. Eingeschaltet, App gestartet und wieder Endlosschleife.
    Das Spiel habe ich mit insgesamt drei Speicherkarten durchgeführt, eine davon war Fabrik neu.

    Ich empfehle TOMTOM übrigens mal die Rezensionen für die App im Playstore zu lesen (Wichtig! Hier natür nach "Neu" sortieren). Seit gestern 24. September laufen hier die Meldungen von Nutzern ein, die das gleiche Problem haben. Und genau gestern kam ja bekanntermaßen das Kartenupdate.

    Man kann ja von Anwendern nicht verlangen, dass sie immer bei gewollter Nutzung der App erst die Speicherkarte herausnehmen. Zumal viele dort ja auch andere Daten drauf haben.

    TOMTOM ist jetzt also angehalten, hier kurzfristig eine Fehlerbehebung durchzuführen. Gerne auch durch die alte Kartenversion, die ja problemlos funktioniert hat.

    Gruß
    Hans-Jürgen

    PS: Ich habe mir die App extra vorgestern gekauft (Upgrade für ein Jahr), damit ich eine Rückfallebene für mein TOMTOM GO 5000 habe, welches ja auch seit dem Kartenupdate ebenfalls rumzickt (egal ob mit oder ohne Speicherkarte).
  • DagobertDagobert Beiträge: 3,947 Superuser
    bearbeitet 25. September
    Also sieht so aus dass die SD Karte probleme macht, bzw. die TT Karte die auf SD Karte gespeichert ist. Vielleicht kommt zu problemen wenn auf die TT Karte die auf SD Speicherkarte ist, zugegriffen wird. Wenn die TT Karte intern gespeichert ist, geht es ohne probleme...

    @hajue, hast du probiert die Karte auf internen Speicher zu downloaden und von der Sd Karte zu löschen...? So sollte dann die App funktionieren auch wenn die Karte drin ist....

    ich habe die SD Karte drin und muss die nicht rausnehmen...., ich glaube mein Glück ist, dass die TT Europakarte aufm Internen Speicher drauf ist.
  • JürgenJürgen Beiträge: 5,088 Community Manager
    Hallo Hans-Jürgen,

    Du hast Recht, Agnieszka bestätigt die Rezensionen (und ja, wir lesen die Rezensionen). Im Moment können wir leider nur warten.

    Gruß,
    Jürgen

  • hajuehajue Beiträge: 1,908 Superuser
    bearbeitet 25. September
    UPDATE:

    Hallo @Jürgen ,

    der weiter oben von @Justyna gepostete Work-Arround scheint evtl. helfen zu können.

    Ich habe die App gestopt, Cache geleert, Handy neu gestartet, Android/data/com.tomtom.gplay.navapp gelöscht, Handy neu gestartet.

    Momentan läuft die App (D-A-CH auf internem Speicher) auch mit eingesetzter Speicherkarte.

    Ich halte es jedoch für sehr grenzwertig, von einem normalen User (ich bin in der IT beschäftigt und schrecke vor nichts zurück ;) ) zu verlangen, dass er in den Tiefen von Android herumwerkeln soll (muss), damit eine App die bisher problemlos lief wieder nutzbar ist. Zumal es sich hier auch noch um Systemverzeichnisse handelt, die u.U. versteckt sind.

    Einen Test mit einer anderen Karte, die dann auf der Speicherkarte installiert wird, werde ich momentan nicht machen. Erstens habe ich einen Hauptberuf und nur begrenzt Zeit, zweitens sage ich mir momentan "never touch a runing System".

    Gruß
    Hans-Jürgen
  • hajuehajue Beiträge: 1,908 Superuser
    Dagobert schrieb: »
    Also sieht so aus dass die SD Karte probleme macht, bzw. die TT Karte die auf SD Karte gespeichert ist. Vielleicht kommt zu problemen wenn auf die TT Karte die auf SD Speicherkarte ist, zugegriffen wird. Wenn die TT Karte intern gespeichert ist, geht es ohne probleme...

    ...

    Hallo @Dagobert ,

    wie ich weiter oben ausführlich geschrieben habe, konnte ich die App mit installierter D-A-CH Karte OHNE EINGESETZTE Speicherkarte starten. Sobald eine Speicherkarte eingesetzt wurde (auch eine ganz neue!) kam die Schleife. Da konnte ja noch nichts von TOMTOM auf der Speicherkarte sein.

    Gruß
    Hans-Jürgen
  • DagobertDagobert Beiträge: 3,947 Superuser
    bearbeitet 25. September
    Ich denke wenn man die TT Karte ( welche auch immer) von Externen Speicher löscht und Die App installiert und dann neue TT Karte intern speichert, wird keine probleme geben. So wie @hajue geschrieben hat, liegt für mich Problem bei Zugrif auf die TT Karte aufm Externen Speicher....
  • DagobertDagobert Beiträge: 3,947 Superuser
    bearbeitet 25. September
    hajue schrieb: »
    Dagobert schrieb: »
    Also sieht so aus dass die SD Karte probleme macht, bzw. die TT Karte die auf SD Karte gespeichert ist. Vielleicht kommt zu problemen wenn auf die TT Karte die auf SD Speicherkarte ist, zugegriffen wird. Wenn die TT Karte intern gespeichert ist, geht es ohne probleme...

    ...

    Hallo @Dagobert ,

    wie ich weiter oben ausführlich geschrieben habe, konnte ich die App mit installierter D-A-CH Karte OHNE EINGESETZTE Speicherkarte starten. Sobald eine Speicherkarte eingesetzt wurde (auch eine ganz neue!) kam die Schleife. Da konnte ja noch nichts von TOMTOM auf der Speicherkarte sein.

    Gruß
    Hans-Jürgen

    Ich wurde , falls du noch Lust und Zeit hast, deine Micro SD Karte, wo die TT Karte gespeichert war, wieder einsetzen und einfach die TT Karte die auf SD Karte( noch besser alles von TT) löschen. Danach mit eingesetzte SD Karte die App instalieren und die TT Karte downloaden ALLERDINGS im internen Speicher. Ich glaube, die App wird dann auch mit eingesetzte SD Karte laufen.
    Bei mir ist nicht anderes, meine SD Karte ist ganze Zeit im Handy. Unterschied ist nur dass meine TT Karte aufm Internen Speicher war und ich sie auch da aktuallisiert habe..:-)
  • JürgenJürgen Beiträge: 5,088 Community Manager
    Überlassen wir die Experimente bitte unserem Test-Team. Die versuchen das Problem zu reproduzieren.
  • bkuhlsbkuhls Beiträge: 11 [Master Traveler]
    com.tomtom.gplay.navapp version 1.17.9, gestern ohne Probleme genutzt
    SD-Karte wird als "adopted storage" genutzt
    lineageos-16.0
    motorola x4 xt1900-7

    Kartenupdate wurde heute installiert, seitdem Abstürze, anbei ein Auszug aus logcat:
    09-25 17:22:53.156  8114  8204 E NavCorestderr: stack corruption detected (-fstack-protector)
    --------- beginning of crash
    09-25 17:22:53.156  8114  8213 F libc    : stack corruption detected (-fstack-protector)
    09-25 17:22:53.156  8114  8213 I PrintStacktrace: --- Begin backtrace ---
    09-25 17:22:53.156  8114  8213 I PrintStacktrace: PRINTING STACK TRACE IS NOT IMPLEMENTED
    09-25 17:22:53.156  8114  8213 I PrintStacktrace: --- End backtrace ---
    
Anmelden oder Registrieren, um zu kommentieren.

Wer ist online27

Bembo
Bembo
Elchdoktor
Elchdoktor
kumo
kumo
Tubi56
Tubi56
+23 Gäste