Reply
New Traveler
marym
Posts: 1
Registered: ‎21-05-2011
Location: US

No Image when turned on

I purchased two XXL's in December for Christmas Gifts.  I really like the product but have been experiencing some glitches for several months. The screen is NOT going on or goes on and then shuts down.  Someone mentioned that the connection from cable to device sometimes goes bad.  Please advise.

Message 1 of 7 (673 Views)
Please use plain text.
Revered Voyager
sallor225
Posts: 2,198
Registered: ‎29-04-2011
Location: US

Re: No Image when turned on

[ Edited ]

Don't know how your question got to be two weeks old.

 

First make sure the battery is charged. When it is connected a little green light should be on. Charge for at least 2 hrs. with the device off. Make sure your cigarette lighter plug is still intact; sometimes they start to unscrew causing a poor connection.

 

Second, if that does not help. Try resetting your device by holding down the on button untill you hear the double drum roll (15-20 seconds). Restart.

 

Third, if that does not help make sure you have the latest version of Home (go the Help/Update Home). Then connect your device to your computer, turn on, say yes to connect, then go to "Operate My Device" and navigate to some point, add or deleat a POI, safely disconnect your device (Device/Disconnect Device; wait for message "OK to Safely Disconnect"). Restart device and see if that helps.

Help others identify useful content:
- Did someone answer your question? Click Accept as Solution
- Did someone post something helpful? Click the kudos star .....

TomTom XXL 540TM Minneapolis/St. Paul, MN traffic
Message 2 of 7 (642 Views)
Please use plain text.
New Traveler
Jarod
Posts: 1
Registered: ‎27-07-2012
Location: US

Re: No Image when turned on

Hi,

 

I directed myself to this forum as I have had the same problem and have tried everything (charging for >2 hours, updating, hard reset, navigating to a point and safely disconnecting) and I still just have sound and no images. I received my XXL last summer and it has been working fine up until this past week as one day I turned it on, saw my intro image that I downloaded, and suddenly the screen went black and have been unable to visualize anything but a blank screen since. If you could let me know what would be the best course of action at this point I would really appreciate it. Thanks

Message 3 of 7 (529 Views)
Please use plain text.
Neophyte Traveler
theresa363
Posts: 3
Registered: ‎27-07-2012
Location: US

Re: No Image when turned on

i am having sort of the same problem i brought mine feb of last year hardly used it yet when i tried to use it the screen was just blank all you can hear is some type of sound last week , i just tried it and  a blue back ground with the picture of the tom tom is showing  it wont do nothing all day someone please help!!

Message 4 of 7 (525 Views)
Please use plain text.
Elite Voyager
Elite Voyager
dhn
Posts: 12,424
Registered: ‎01-03-2011

Re: No Image when turned on

Have you tried resetting the device by holding the power button about 15 seconds till you hear the drum sounds (unless your device has a dedicated reset hole on the bottom).

-------------------------------------------
I am a moderator at Tomtomforums.com, an independent community of Tomtom customers. .....I am not a TomTom employee.
Message 5 of 7 (516 Views)
Please use plain text.
Neophyte Traveler
theresa363
Posts: 3
Registered: ‎27-07-2012
Location: US

Re: No Image when turned on

i personally have hot the reset button  still nothing

Message 6 of 7 (513 Views)
Please use plain text.
Neophyte Traveler
theresa363
Posts: 3
Registered: ‎27-07-2012
Location: US

Re: No Image when turned on

 i also tried to up date it and is getting i need to format disk drive error message

Message 7 of 7 (511 Views)
Please use plain text.