Reply
Apprentice Traveler
tegehel
Posts: 2
Registered: ‎17-06-2012
Location: US

Bug: XL IQ sometimes hangs after booting, at "This device belongs to..."

Hi,

 

As the title says, on occasion, my TomTom XL IQ will hang after it reaches the "This device belongs to..." screen, and when I press [continue], nothing happens. This is the 3rd time it's happened since TomTom updated to the new interface (with the middle 2D/3D button) . I never had that problem with the old interface. I'm not sure if it's related, but I thought I'd mention it.

 

I can turn the device on and off, but everytime I restart, if it hanged before, it will hang again. The ONLY way that I managed to get rid of that problem  is to connect it to my PC and run some updates (new maps, etc...), and that seems to reset whatever problem there is...until next time it happens.

 

As I don't always have a laptop with me, if this happens while I'm on the road or without a mean to connect it to a PC, MY gps becomes useless. I just hope that it won't fail me when I need it most.  :smileyfrustrated:  

 

Regardless, it is a bug that needs addressing .

 

PS: Is there a specfial way to reboot my TomTom (combination of clicks?) when I'm on the road that would completely bypass the loading screen, or reset it in such as way that it doesn't hang again and again and again?

 

Thanks,


Cyril. 

Message 1 of 3 (1,435 Views)
Please use plain text.
Apprentice Traveler
tegehel
Posts: 2
Registered: ‎17-06-2012
Location: US

Re: Bug: XL IQ sometimes hangs after booting, at "This device belongs to..."

Addendum: This happened to me yesterday. Unfortunately, this time, even though I connected to my PC, it still hangs.

The only difference I have noticed is that it goes through all the warning screens, and at the end, instead of going to the normal map screen, it goes back to the "This device belongs to..." and won't do anything when I click continue...

Now, it literally has become useless until I find a way to fix this.
Message 2 of 3 (1,433 Views)
Please use plain text.
Zsolt
Posts: 21,416
Kudos: 2,399
Solutions: 554
Registered: ‎16-10-2011
Location: United Kingdom

Re: Bug: XL IQ sometimes hangs after booting, at "This device belongs to..."

Try to run the Clear Flash Tool 3 times:

http://uk.support.tomtom.com/app/answers/detail/a_id/6178/

If no luck:

Try to do a soft reset first. Either a pin hole on the bottom, or press and hold the on button, until you hear the drum roll (if your device has no pin hole).

If the above worked, happy days, if not, try the one below:

1. Save everything from the device, using Explorer (or Finder on Mac), include all the files (hidden as well). It is also known as a manual backup: http://uk.support.tomtom.com/app/answers/detail/a_id/13354/

2. Then format the internal storage (or memory card, depending which one you use) of your device. http://uk.support.tomtom.com/app/answers/detail/a_id/16172/

3. Go to TT HOME, Manage my "DEVICE", delete everything from the hard drive and try the update again.

4. Copy your voices and post codes back to the devices (also the maps if that didn't download either).

Tip: Help others identify useful content by clicking the kudos thumbs, and by selecting the best answer to your question as the accepted solution


Report map errors (MSR Tool - link)
Actual devices: GO 820 Top Gear Edition, GO 825, Start 60, One XL, GO 600, GO 1000, VIA 120, VIA 135, TomTom Android; Old devices: TomTom WM, GO 530, XL IQ Routes LIVE
How to contact TomTom's Customer Services (link)
TomTom's Customer Services numbers (thx Niall) (link)
How to soft reset your device (link)


I am NOT a TomTom employee, just a user like others.
Message 3 of 3 (1,428 Views)
Please use plain text.