Reply
Novice Explorer
v8boy
Posts: 8
Registered: ‎08-08-2012
Location: United Kingdom

TT ONE will not power up

Re below posting with regards to switch off when charger plugged in.

 

The unit will not switch on and cannot be seen by the PC.

Is there an internal fuse that it may have blown and if so can I get at it or is it a specialist job?

 

Thanking you in advance.

 

V8Boy

Message 1 of 6 (768 Views)
Please use plain text.
Revered Voyager
sallor225
Posts: 2,195
Registered: ‎29-04-2011
Location: US

Re: TT ONE will not power up

Will it operate while plugged in to charger? Does the green light on the bottom of your TomTom light when plugged in to USB or your car? Does it seem to charge up when left connected for a couple of hours (best to leave unit turned off)? How old is the battery?

Help others identify useful content:
- Did someone answer your question? Click Accept as Solution
- Did someone post something helpful? Click the kudos star .....

TomTom XXL 540TM Minneapolis/St. Paul, MN traffic
Message 2 of 6 (730 Views)
Please use plain text.
Novice Explorer
v8boy
Posts: 8
Registered: ‎08-08-2012
Location: United Kingdom

Re: TT ONE will not power up

Hi sallor225,

 

When the car charger is plugged in the light on the top of the unit comes on but the unit still fails to start, when plugged in via USB to the laptop it does not charge at all, and never has.

The problem came when I plugged the car charger in which I have done many times over the 6 years that I have had it, the lead was in the TT and I plugged it in to the lighter socket, the 2A fuse in the plug blew so I replaced this but still no joy! The TT was on and giving me directions at the time of the failure!

 

At the moment the charger appears to work as the light on the top of the TT is on but the TT will not switch on.

 

thanks for the help.

 

v8boy

Message 3 of 6 (705 Views)
Please use plain text.
Revered Voyager
sallor225
Posts: 2,195
Registered: ‎29-04-2011
Location: US

Re: TT ONE will not power up

When you refer to the light "on the top of the unit" are you refering to the TomTom or the plug? You may have to have your cords and possibly your unit checked for shorts or open circuits.

Help others identify useful content:
- Did someone answer your question? Click Accept as Solution
- Did someone post something helpful? Click the kudos star .....

TomTom XXL 540TM Minneapolis/St. Paul, MN traffic
Message 4 of 6 (687 Views)
Please use plain text.
Novice Explorer
v8boy
Posts: 8
Registered: ‎08-08-2012
Location: United Kingdom

Re: TT ONE will not power up

Hello sallor 225,

 

To clarify, the charger light is on and the light on the top of the TomTom One is on.

I have proven that the voltage at the battery is 3.6v and that with the charger plugged in it rises to 3.9v, the unit does not charge from the USB connection and to the best of my knowledge never has.
I know this as when I did a recent back up it came up with low battery half way through the back up so I did it the next day.

 

Someone else suggested that it may require a full charge so left it on charge for 24Hrs but still no joy!

 

A bit of background is that several times I have plugged the charger in whilst the unit was switched on with no problems, on this particular occasion I plugged the lead in to the TT and then in to the power socket on the car, the TT switched off and I found that the fuse had blown on the charger.  With a struggle I replaced the fuse in the charger and the rest is history! 

 

Is there an internal fuse? I did find a small button on the left hand side, looking from the rear of the unit, which I tried but it didn't appear to do anything.

 

Who in the UK can I go to, to have it looked at, or do I just call it a day and contact TT for a new version??

 

Thanks for your help

 

v8boy 

Message 5 of 6 (645 Views)
Please use plain text.
Revered Voyager
sallor225
Posts: 2,195
Registered: ‎29-04-2011
Location: US

Re: TT ONE will not power up

The  small button is probably the reset button. You should try that, who knows, it might help. Hold the reset button until you get the double drum roll.

 

It is possible that your battery is bad. I think a fully charged battery would read 5 volts.

 

Here is some information from another contributor that I saved:

And from DHN

A video to replace any GPS battery (must search for specific model):

http://www.youtube.com/watch?v=2wUysXky-DE&feature=channel_video_title

Battery source:

http://www.newpower99.com/SearchResults.asp?Search=xxl+540&Search.x=28&Search.y=14

Lupus

Battery http://www.batteryship.com/

Battery pack http://www.selectronic.fr/coupleur-pour-4-piles-lr6-avec-sortie-usb.html

Turbo charger http://www.allaboutsymbian.com/reviews/item/12146_Proporta_USB_TurboCharger_5000.php

Help others identify useful content:
- Did someone answer your question? Click Accept as Solution
- Did someone post something helpful? Click the kudos star .....

TomTom XXL 540TM Minneapolis/St. Paul, MN traffic
Message 6 of 6 (639 Views)
Please use plain text.