Reply
Neophyte Traveler
TomtomDumdum
Posts: 3
Registered: ‎17-03-2012
Location: United Kingdom

GO 910 problems

I note that TomTom now consider my Go910 as a legacy device and has withdrawn telephone and email support.

 

The problem is this...when trying to connect to TomTom Home my computer does not recognise the USB device with the message no driver loaded. In addition, the device is not starting. I have tried the reset function more times than I care to remember. I sometimes obtain the various lines of whiet text on black background but no progress occurs.

 

These problems seem to have occurred since I updated my device.

 

Any advice will be welcome.

 

Thanks

 

 

Message 1 of 7 (736 Views)
Please use plain text.
Zsolt
Posts: 21,369
Kudos: 2,393
Solutions: 554
Registered: ‎16-10-2011
Location: United Kingdom

Re: GO 910 problems

Have you tried to switch off the device, then connect to the PC, switch it on. It should see the unit as an external drive. Have you tried it on another PC? Try to un-install and install TT HOME.

Tip: Help others identify useful content by clicking the kudos thumbs, and by selecting the best answer to your question as the accepted solution


Report map errors (MSR Tool - link)
Actual devices: GO 820 Top Gear Edition, GO 825, Start 60, One XL, GO 600, GO 1000, VIA 120, VIA 135, TomTom Android; Old devices: TomTom WM, GO 530, XL IQ Routes LIVE
How to contact TomTom's Customer Services (link)
TomTom's Customer Services numbers (thx Niall) (link)
How to soft reset your device (link)


I am NOT a TomTom employee, just a user like others.
Message 2 of 7 (731 Views)
Please use plain text.
Neophyte Traveler
TomtomDumdum
Posts: 3
Registered: ‎17-03-2012
Location: United Kingdom

Re: GO 910 problems

Zsolt

Thanks but I have tried this and none of my computers recognise the external harddrive of the device.

 

 

Message 3 of 7 (727 Views)
Please use plain text.
Zsolt
Posts: 21,369
Kudos: 2,393
Solutions: 554
Registered: ‎16-10-2011
Location: United Kingdom

Re: GO 910 problems

It can be a dirty or dislocated USB plug or faulty internal drive than :smileysad:


Tip: Help others identify useful content by clicking the kudos thumbs, and by selecting the best answer to your question as the accepted solution


Report map errors (MSR Tool - link)
Actual devices: GO 820 Top Gear Edition, GO 825, Start 60, One XL, GO 600, GO 1000, VIA 120, VIA 135, TomTom Android; Old devices: TomTom WM, GO 530, XL IQ Routes LIVE
How to contact TomTom's Customer Services (link)
TomTom's Customer Services numbers (thx Niall) (link)
How to soft reset your device (link)


I am NOT a TomTom employee, just a user like others.
Message 4 of 7 (724 Views)
Please use plain text.
Neophyte Traveler
TomtomDumdum
Posts: 3
Registered: ‎17-03-2012
Location: United Kingdom

Re: GO 910 problems

Zsolt

At the mo the TT screen shows ten lines of text (white on black) with the last line stating "Retrieving disk info...". It has been like this for quite a while, and on previous attempts to get the device working I have left it in this state for several hours with no progress whatsoever.

 

This would suggest the disk is now useless?

Message 5 of 7 (721 Views)
Please use plain text.
Zsolt
Posts: 21,369
Kudos: 2,393
Solutions: 554
Registered: ‎16-10-2011
Location: United Kingdom

Re: GO 910 problems

It certainly looks like. Even if the data would be damaged, you should have the disk info available. It looks like the internal storage is a goner :smileysad:


Tip: Help others identify useful content by clicking the kudos thumbs, and by selecting the best answer to your question as the accepted solution


Report map errors (MSR Tool - link)
Actual devices: GO 820 Top Gear Edition, GO 825, Start 60, One XL, GO 600, GO 1000, VIA 120, VIA 135, TomTom Android; Old devices: TomTom WM, GO 530, XL IQ Routes LIVE
How to contact TomTom's Customer Services (link)
TomTom's Customer Services numbers (thx Niall) (link)
How to soft reset your device (link)


I am NOT a TomTom employee, just a user like others.
Message 6 of 7 (718 Views)
Please use plain text.
New Traveler
jbeuk
Posts: 1
Registered: ‎11-12-2013
Location: Netherlands

Re: GO 910 problems

I have exact the same issue, so I think my 20Gb disk is gone as well.?!

Message 7 of 7 (244 Views)
Please use plain text.