Reply
New Traveler
fatal
Posts: 1
Registered: ‎16-10-2012
Location: United Kingdom

Error writing file: /tthome.bif

I've been getting this error every time I connect my Tomtom Go 740 to my Mac to update it. I can't find anyone else having the problem either. I have my maps on a Sandisk 8GB SDHC card as they won't fit on the internal memory, but the card seems to be fine. 

 

Has anyone got any idea what might be causing this and what I can do to stop it? What is this file tthome.bif and where is it: on the Tomtom or on the SDHC card?

 

Here's the full gory details from the incident report ID 154562803:

 

ERROR: HomeBase/IO: Error writing file: /tthome.bif
@ /usr/local/parabuild/etc/build/b1172co/a/u/t/o/CodeBase/Sources/Home/DesktopSuite/../HomeBase/portable/cfile.cpp(1953)

in /usr/local/parabuild/etc/build/b1172co/a/u/t/o/CodeBase/Sources/Home/DesktopSuite/../HomeBase/portable/cfile.cpp:1953
Stack:
0. chrome://tthome/content/logic/deviceManager.js:371
} catch (e) { error(e); }
1. chrome://tthome/content/logic/deviceManager.js:396
this._notifyChange(deviceChanged, locationChanged);
2. chrome://tthome/content/logic/deviceManager.js:149
this._changed(false, false);{}

Time: Tue, 16 Oct 2012 19:05:50 GMT

Message 1 of 4 (1,460 Views)
Please use plain text.
Revered Navigator
Wyvern46
Posts: 489
Registered: ‎03-03-2011
Location: United Kingdom

Re: Error writing file: /tthome.bif

The bif file is part of the software application. So is located wherever the device application is stored. I would make a back-up of the device contents directly to your computer [not a /TT Home version], and store it separately.  Then using TT Home remove the application from your sat nav and computer [this is where Home put it when it was downloaded]. Then go to 'update my device' [in Home] and redownload the application.

[aka Guivre46]
Go550Live
Go530T
One XLT WE
Based: West London
Message 2 of 4 (1,439 Views)
Please use plain text.
New Traveler
EduardvanD
Posts: 1
Registered: ‎23-07-2013
Location: Netherlands

Re: Error writing file: /tthome.bif

Gents, I was troubled by the same write error for days. Error writing tthome.bif and other files as well. Tried everything you suggested, plus reset to factory settings, nothing worked. And....just when I was about to give up I noticed the original USB-cable that came with my TomTom XL, the one that has a 90 degree tilt at the plug to the device. And.....all errors disappeared !

On my PC it now recognized my TomTom instantly and the copying was much faster than ever. Must be some pins in other USB-cables that are not connected or such. Anyway...usually I am not a fan of manufacturers' specific cables but this one did the trick. Hope this helps for some of you as well. Cheers.

Message 3 of 4 (917 Views)
Please use plain text.
New Traveler
bcovers
Posts: 1
Registered: ‎26-12-2013
Location: US

Re: Error writing file: /tthome.bif

Was having the same issue,  using a generic cable and kept getting errors,  Dug the TomTom factory angled plug wire out, plugged up my XXL 540S World Version and immediately found the unit and started the downloads.  Thanks for sharing, it resolved a considerable amount of frustration here on Christmas night!  :smileyhappy:

Message 4 of 4 (589 Views)
Please use plain text.