Neophyte Traveler
bardo
Posts: 3
Registered: ‎01-12-2012
Location: United Kingdom

Re: Via 130 Battery Not Charging

Yes, I too had a VIA130 arrive from Amazon with no battery life - they must have had a few too many sitting around on their shelves, including some that were drained and probably why they were selling them cheap on their Black Friday deals. To be fair they sent out another as soon as I reported it and the replacement is fine.

Message 11 of 32 (1,917 Views)
Please use plain text.
Novice Explorer
missydee123
Posts: 7
Registered: ‎01-12-2012
Location: United Kingdom

Re: Via 130 Battery Not Charging

Doing a search on google highlighted a few from Amazon with the same problem, glad the replacement works, my replacement has been dispatched, fingers crossed this one will work ok too

Message 12 of 32 (1,906 Views)
Please use plain text.
Novice Explorer
aroy
Posts: 4
Registered: ‎01-12-2012
Location: United Kingdom

Re: Via 130 Battery Not Charging

Got the replacement from Amazon. The new unit works fine - atleast the battery is

Message 13 of 32 (1,886 Views)
Please use plain text.
YamFazMan
Posts: 5,216
Registered: ‎27-05-2011

Re: Via 130 Battery Not Charging

[ Edited ]

Hi

 

Just a thought on these Amazon Tomtoms

 

Does It count down from 10 sec or just die if the later your battery is flat/dead ,charge for a minimum of 2hrs.

With a 10 sec countdown is in the power saving menu.

 

Go :-

<Settings >

Left cursor twice

Battery saving 

<Next >

Device stays on

Done

 

ATB YFM

Help others identify useful content :-

- If someone posted something that was helpful? Click the Kudos button.
- If someone answered your question? Click Accept as Solution.
Also have you tried clicking on the Suport Button.PNG button at the top of the forum page ??? 
World phone numbers to contact Customer support :- Phone-numbers.
Other ways to contact TomTom Support :- How-to-Contact-support.

Message 14 of 32 (1,871 Views)
Please use plain text.
Novice Explorer
missydee123
Posts: 7
Registered: ‎01-12-2012
Location: United Kingdom

Re: Via 130 Battery Not Charging

There was no countdown or anything, I had already ticked the box for the device to stay on, it just wouldn't work without being plugged in to a power source, no matter how long it had been charged for.

 

I have now received my placement and this works fine, good service from Amazon, it was quick and easy to get a replacement

Message 15 of 32 (1,861 Views)
Please use plain text.
Neophyte Traveler
bardo
Posts: 3
Registered: ‎01-12-2012
Location: United Kingdom

Re: Via 130 Battery Not Charging

Yes, same as previous responder. No power at all unless connected to some sort of charger, i.e. car charger, USB mains charger (which I bought in case it was the car charger that had been at fault!), or USB connected to a computer; flat again as soon as connector was withdrawn. Anyway, quite happy now unit has been replaced, except I'd already registered the first unit (duh!) and had to phone TomTom to register the replacement instead because of TomTom's stupid idea that you can only have one satnav unit per email address. But that's another story ....

Message 16 of 32 (1,843 Views)
Please use plain text.
New Traveler
matbedford
Posts: 1
Registered: ‎12-12-2012
Location: United Kingdom

Re: Via 130 Battery Not Charging

I'm having exactly the same problem, via 130 works when plugged in but check battery status and it says 0% power remaining source battery power even when plugged in. no battery symbol but computer symbol in bottom left of display.  I have ticked stay on when removed from external power source but as sson as I unplug cable it powers off and won't power on until I plug it back in

Message 17 of 32 (1,800 Views)
Please use plain text.
New Traveler
Trev63
Posts: 1
Registered: ‎27-12-2012
Location: United Kingdom

Re: Via 130 Battery Not Charging

Have exactly the same prob, bought from Groupon last week.

Message 18 of 32 (1,756 Views)
Please use plain text.
Zsolt
Posts: 21,283
Kudos: 2,390
Solutions: 554
Registered: ‎16-10-2011
Location: United Kingdom

Re: Via 130 Battery Not Charging

Is it charging when you connect it to the computer? If yes, maybe a faulty charger adapter. If not, can be the previous or faulty USB lead. If none of these, faulty unit. Return it under warranty.

0845 161 0009
Monday - Friday: 9:00 a.m. to 5:30 p.m. UTC

or

020 7387 5444

Tip: Help others identify useful content by clicking the kudos thumbs, and by selecting the best answer to your question as the accepted solution


Report map errors (MSR Tool - link)
Actual devices: GO 820 Top Gear Edition, GO 825, Start 60, One XL, GO 600, GO 1000, VIA 120, VIA 135, TomTom Android; Old devices: TomTom WM, GO 530, XL IQ Routes LIVE
How to contact TomTom's Customer Services (link)
TomTom's Customer Services numbers (thx Niall) (link)
How to soft reset your device (link)


I am NOT a TomTom employee, just a user like others.
Message 19 of 32 (1,751 Views)
Please use plain text.
OT
Novice Explorer
OT
Posts: 2
Registered: ‎28-12-2012
Location: Netherlands

Re: Via 130 Battery Not Charging

This seems to be a more general problem with the Via 130. We got one for Christmas and it didn't charge the battery at all. So we went back to the store (Mediamarkt, great service and support) and they offered us a new one. They told us it was already the third one with that problem in one week. So we asked them to test the new one and guess what, it didn't charge the battery either. So they gave us the third one and tested it and it worked. I guess TomTom must be getting back quite some of these devices with the same complaint from the shops?

Message 20 of 32 (1,727 Views)
Please use plain text.