Reply
Neophyte Traveler
RobynOsmond
Posts: 3
Registered: ‎05-01-2012
Location: South Africa

MyTomTom says device is not connected, but it is

Hi, I recently purchased the TomTom Start 20, and I have downloaded and installed MyTomTom. But when i plug the TomTom in with the USB, it says that the device is not connected when i go into MyTomTom. The computer picks it up as a storage device, so I know its not a problem with the USB port. It just doesnt recognise it in MyTomTom.

Message 1 of 10 (17,019 Views)
Please use plain text.
Sovereign Trailblazer
ghost_rider
Posts: 122
Registered: ‎03-01-2012

Re: MyTomTom says device is not connected, but it is

[ Edited ]

RobynOsmond wrote:

Hi, I recently purchased the TomTom Start 20, and I have downloaded and installed MyTomTom. But when i plug the TomTom in with the USB, it says that the device is not connected when i go into MyTomTom. The computer picks it up as a storage device, so I know its not a problem with the USB port. It just doesnt recognise it in MyTomTom.


hi robyn, i follow you..even though your gps is indeed hooked up..it won't show it's connected until you log into your account..click the mytotom green button..then perhaps click '' check for new updates '' ( i think this is the right way ? )..you may just need to just log into your account ?..then it should show your gps connected.

Message 2 of 10 (17,009 Views)
Please use plain text.
Neophyte Traveler
RobynOsmond
Posts: 3
Registered: ‎05-01-2012
Location: South Africa

Re: MyTomTom says device is not connected, but it is

I don't seem to get an option to check for new updates. I can log into my account fine but it still seems to think that nothing is connected.

Message 3 of 10 (16,981 Views)
Please use plain text.
Sovereign Trailblazer
ghost_rider
Posts: 122
Registered: ‎03-01-2012

Re: MyTomTom says device is not connected, but it is


RobynOsmond wrote:

I don't seem to get an option to check for new updates. I can log into my account fine but it still seems to think that nothing is connected.


hi robyn, you won't see the drop down menu on that pesky green mytomtom unless your gps is plugged into your pc..and your logged on to your account...once all of this is in order...then when you click on the mytomtom button ( the green one at the top right )..you should ???..see a buttom that reads check for new items or something like that .

Message 4 of 10 (16,960 Views)
Please use plain text.
Neophyte Traveler
RobynOsmond
Posts: 3
Registered: ‎05-01-2012
Location: South Africa

Re: MyTomTom says device is not connected, but it is

Hi, no, It just keeps saying 'please connect your navigation device to get updates'. And it is connected. So I think my best option is to take it back and get a new one?

Message 5 of 10 (16,903 Views)
Please use plain text.
Neophyte Explorer
rogerval
Posts: 11
Registered: ‎28-12-2011
Location: Australia

Re: MyTomTom says device is not connected, but it is

Hi Robyn,

I've been having some dramas with making my Via 220 / Start 20 (same TomTom, different name) connect to My TomTom, and I believe that I've found the problem (on my PC at least) so I may be able to help (I hope).

What kind of computer are you using, for a start ? Is it a Mac or a Windows based computer (what most would call a PC? Or do you have something else ?

In your first post, you say "The computer picks it up as a storage device". If it's a PC with Windows, I don't think it should see the TomTom as a storage device (such as a USB thumb drive). Rather, it should treat it as a network card of sorts. I don't know about a Mac; perhaps they see the TomTom as a network card too.

Until you can succeed in having the TomTom connect to the PC, "My TomTom" won't work properly at all (but you probably know that...)

Please give us some more detail as to what sort of system you're using, and I (and others reading) would be pleased to try and help you some more.

Kind regards,

Roger.

 

(PS: the problem I was having was caused by ESET Smart Security 4 and its perhaps too efficient firewall. Other people may be able to get this to work with My TomTom, but I couldn't, so I went back to ESET Anti Virus 5 and the Windows firewall. My router has a firewall anyway, so there's plenty of protection still. But unfortunately I don't think this is the problem you have.)

 

(PPS: a few screen shots; hope these work...)

Just in case you do have a PC with Windows XP, here's how I would check for the presence of a TomTom Start 20 connected to the PC USB port and switched on, showing up as a network card: open "My Network Places" and view "My Network Connections", and the TomTom should show up in the list as per this screenshot #1.)

 

Network connection list.JPG 

 

Screen shot #2 showing the My TomTom support application recognising the GPS; should pop up when you click on the icon in your system tray. (My GPS was sold as a Via 220 here in Australia, but as you see in this screen shot, it is recognised as a Start 20, which I believe is it's "real" name.)

My TomTom connected.JPG

 

(This icon, which should appear as shown:smileyhappy:

My TomTom system tray icon.JPG

Message 6 of 10 (16,864 Views)
Please use plain text.
New Traveler
LizE
Posts: 1
Registered: ‎02-10-2012
Location: United Kingdom

Re: MyTomTom says device is not connected, but it is

Thanks for your comments. I went to the network and sharing centre and dicovered that the network entitled TomTom was disabled. So, I selected it and it 'enabled' and this solved the problem for me.

Message 7 of 10 (13,814 Views)
Please use plain text.
Neophyte Explorer
rogerval
Posts: 11
Registered: ‎28-12-2011
Location: Australia

Re: MyTomTom says device is not connected, but it is

Hi LizE,

I'm glad that you found my post useful. :smileyhappy:

Kind regards,

Roger.

Message 8 of 10 (13,791 Views)
Please use plain text.
Novice Explorer
Lambdats
Posts: 2
Registered: ‎03-10-2012
Location: United Kingdom

Re: MyTomTom says device is not connected, but it is

Hi

 

I had same problem with start 25. was fixed by going into save settings and saving.

Message 9 of 10 (13,765 Views)
Please use plain text.
New Traveler
lexgen
Posts: 1
Registered: Thursday
Location: Australia

Re: MyTomTom says device is not connected, but it is

I have the same problem with my VIA 260. It turned out that the driver of the device is not installed (not sure why), but after installing the device driver, it connected in a breeze.

 

Hope this helps.

Message 10 of 10 (73 Views)
Please use plain text.