Reply
New Traveler
vanakki9200
Posts: 1
Registered: ‎13-10-2012
Location: Belgium

Device not recognized in Windows 7

[ Edited ]

My TOMTOM GO820Live is not recognized in Windows 7.

I have tried to reinstal the drivers, but it stil doesn't work.

The PC found "a TomTom" but refuses to recognize it.

 

THIS SUCKS !!  Why can't a large brand like TOMTOM not work with Windows properly !!!!!

 

 

Please help me, I'm out of solutions, already searching Google for 2 days in a row !!!!!!!!!!!!!

 

My email: *removed for privacy*

Message 1 of 7 (1,799 Views)
Please use plain text.
Exalted Navigator
STRUPPI
Posts: 2,299
Registered: ‎09-07-2012

Re: Device not recognized in Windows 7

I do not know this, but....

Is the GO820Live = GO820 not a GOx20 -Device?

And the GOx20 devices needet TomTom HOME, not the MyTomTom -App.

 

I am wrong with this knowing?

 

Greetings from STRUPPI

----------------------------------------------------------------------------------------
Bodhi-Linux + Elive-Linux / MS-Win 7 Ultimate 64Bit
MEDION AKOYA Touch-Notebook mit Win 8.1 64bit WLAN
Google Chrome 36.0.1985.143m [mit tiefem Schutz]
Router [LAN + DLAN + WLAN] + NOD32 + Router/ + OS-Firewall
----------------------------------------------------------------------------------------
Start60 + FW 12.071 + MyDrive Connect 3.3.0.1502 + MAP 9.30
----------------------------------------------------------------------------------------
Message 2 of 7 (1,796 Views)
Please use plain text.
NC
Posts: 1,243
Kudos: 193
Solutions: 72
Registered: ‎21-03-2011

Re: Device not recognized in Windows 7

GO820 is a new hardware that looks similar to the VIA series. It uses MyTomTom.

@vanakki9200
Try disconnecting your GO820 from your computer, hold the power button for about 20 seconds until it drum reboots. Reconnect it to your Win 7 PC.
**************************************************
I am a TomTom user just like you.

Help others identify useful content:
- Did someone answer your question? Click Accept as Solution on the most helpful reply
- Did someone post something helpful? Click the kudos button

Need help with your TomTom device?
Add details about the TomTom device to your post: Device name, Application- and Map version.
Message 3 of 7 (1,781 Views)
Please use plain text.
Exalted Navigator
STRUPPI
Posts: 2,299
Registered: ‎09-07-2012

Re: Device not recognized in Windows 7

Hi NC,

OK, thanks for this info...

 

Greetings from STRUPPI

----------------------------------------------------------------------------------------
Bodhi-Linux + Elive-Linux / MS-Win 7 Ultimate 64Bit
MEDION AKOYA Touch-Notebook mit Win 8.1 64bit WLAN
Google Chrome 36.0.1985.143m [mit tiefem Schutz]
Router [LAN + DLAN + WLAN] + NOD32 + Router/ + OS-Firewall
----------------------------------------------------------------------------------------
Start60 + FW 12.071 + MyDrive Connect 3.3.0.1502 + MAP 9.30
----------------------------------------------------------------------------------------
Message 4 of 7 (1,752 Views)
Please use plain text.
Supreme Trailblazer
piran
Posts: 371
Registered: ‎16-03-2011

Re: Device not recognized in Windows 7

It doesn't get recognised as a device...

it gets recognised as a network connection.

You should look over your Network & Connections

panel in Windows 7... maybe connectivity is disabled

by default or by your administrator.

Message 5 of 7 (1,739 Views)
Please use plain text.
NC
Posts: 1,243
Kudos: 193
Solutions: 72
Registered: ‎21-03-2011

Re: Device not recognized in Windows 7

[ Edited ]

Hi STRUPPI,
No problem! We are all here trying to help each other.

@vanakki9200
If you are still having the issue, refer to this one: http://discussions.tomtom.com/t5/GO-800-1000-2000-Via-Start-20/VIA-1605-not-recognized/m-p/347260#M4...

 

---

Ha! piran is one step ahead of me.

**************************************************
I am a TomTom user just like you.

Help others identify useful content:
- Did someone answer your question? Click Accept as Solution on the most helpful reply
- Did someone post something helpful? Click the kudos button

Need help with your TomTom device?
Add details about the TomTom device to your post: Device name, Application- and Map version.
Message 6 of 7 (1,738 Views)
Please use plain text.
Novice Explorer
TA10
Posts: 5
Registered: ‎07-08-2012
Location: United Kingdom

Re: Device not recognized in Windows 7

i have had this prob since i got my via 135 3 months ago, got it sorted today and all is now upto date. The reason i could not connect was because my new device was not registered, you best bet is to phone customer service and register the device have you serial no at hand. 

Message 7 of 7 (1,671 Views)
Please use plain text.